cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Miguel Ferreira <MFerre...@schubergphilis.com>
Subject Re: BVT report 9/29
Date Wed, 30 Sep 2015 09:15:46 GMT
All,

Following the instructions I had posted in the original PR (https://github.com/apache/cloudstack/pull/741#issuecomment-135415998)
I can reproduce the same result. That is, the test passes against the simulator with an Advanced
zone:
[root@cs1 cloudstack]# nosetests --with-marvin --marvin-config=setup/dev/advanced.cfg   test/integration/smoke/test_scale_vm.py
-s -a tags=advanced,required_hardware=false   --zone=Sandbox-simulator --hypervisor=simulator

==== Marvin Init Started ====

=== Marvin Parse Config Successful ===

=== Marvin Setting TestData Successful===

==== Log Folder Path: /tmp//MarvinLogs//Sep_30_2015_08_42_56_AFB6G9. All logs will be available
here ====

=== Marvin Init Logging Successful===

==== Marvin Init Successful ====
=== TestName: test_02_scale_vm_without_hypervisor_specifics | Status : SUCCESS ===

===final results are now copied to: /tmp//MarvinLogs/test_scale_vm_AKT78U===


I could reproduce the error reported here https://issues.apache.org/jira/browse/CLOUDSTACK-8924
by running both test 1 and test 2 together (toggling require hardware to false in test 1).
[root@cs1 cloudstack]# nosetests --with-marvin --marvin-config=setup/dev/advanced.cfg   test/integration/smoke/test_scale_vm.py
-s -a tags=advanced,required_hardware=false   --zone=Sandbox-simulator --hypervisor=simulator

==== Marvin Init Started ====

=== Marvin Parse Config Successful ===

=== Marvin Setting TestData Successful===

==== Log Folder Path: /tmp//MarvinLogs//Sep_30_2015_08_46_16_U8QJEI. All logs will be available
here ====

=== Marvin Init Logging Successful===

==== Marvin Init Successful ====
=== TestName: test_01_scale_vm | Status : SUCCESS ===

=== TestName: test_02_scale_vm_without_hypervisor_specifics | Status : EXCEPTION ===

===final results are now copied to: /tmp//MarvinLogs/test_scale_vm_4DVZLG===


That seems to me like cleanup is not being performed between the two tests.
However, like Raja already indicated in the JIRA issue, we wouldn’t need test 2 if test
1 works well in the simulator (as it seems to work).
In short, we could get rid of test “test_02_scale_vm_without_hypervisor_specifics” altogether.

Having adapted the basic.cfg (basic zone config) to enable vm scaling, I can reproduce the
same results. Test “test_02_scale_vm_without_hypervisor_specifics" by it self passes.

[root@cs1 cloudstack]# nosetests --with-marvin --marvin-config=setup/dev/advanced.cfg   test/integration/smoke/test_scale_vm.py
-s -a tags=basic,required_hardware=false   --zone=Sandbox-simulator --hypervisor=simulator

==== Marvin Init Started ====

=== Marvin Parse Config Successful ===

=== Marvin Setting TestData Successful===

==== Log Folder Path: /tmp//MarvinLogs//Sep_30_2015_09_11_44_KWEPUS. All logs will be available
here ====

=== Marvin Init Logging Successful===

==== Marvin Init Successful ====
=== TestName: test_02_scale_vm_without_hypervisor_specifics | Status : SUCCESS ===

===final results are now copied to: /tmp//MarvinLogs/test_scale_vm_2IQ0MJ===


Running both tests together fails due to missing cleanup between tests:
[root@cs1 cloudstack]# nosetests --with-marvin --marvin-config=setup/dev/advanced.cfg   test/integration/smoke/test_scale_vm.py
-s -a tags=basic,required_hardware=false   --zone=Sandbox-simulator --hypervisor=simulator

==== Marvin Init Started ====

=== Marvin Parse Config Successful ===

=== Marvin Setting TestData Successful===

==== Log Folder Path: /tmp//MarvinLogs//Sep_30_2015_09_13_45_5NC2QK. All logs will be available
here ====

=== Marvin Init Logging Successful===

==== Marvin Init Successful ====
=== TestName: test_01_scale_vm | Status : SUCCESS ===

=== TestName: test_02_scale_vm_without_hypervisor_specifics | Status : EXCEPTION ===

===final results are now copied to: /tmp//MarvinLogs/test_scale_vm_FUCV6R===


Cheers,
\ Miguel Ferreira
   mferreira@schubergphilis.com<mailto:mferreira@schubergphilis.com>




On 30 Sep 2015, at 10:17, Raja Pullela <raja.pullela@citrix.com<mailto:raja.pullela@citrix.com>>
wrote:

Miguel, please see the defect https://issues.apache.org/jira/browse/CLOUDSTACK-8924
Let me know if you have any questions,
Raja

-----Original Message-----
From: Miguel Ferreira [mailto:MFerreira@schubergphilis.com]
Sent: Wednesday, September 30, 2015 1:43 PM
To: Sebastien Goasguen <runseb@gmail.com<mailto:runseb@gmail.com>>
Cc: dev <dev@cloudstack.apache.org<mailto:dev@cloudstack.apache.org>>; Boris Schrijver
<boris@pcextreme.nl<mailto:boris@pcextreme.nl>>; Pierre-Luc Dion <pdion@cloudops.com<mailto:pdion@cloudops.com>>;
Milamber <milamber@apache.org<mailto:milamber@apache.org>>
Subject: Re: BVT report 9/29

Hi Sebastian,

On 29 Sep 2015, at 20:42, Sebastien Goasguen <runseb@gmail.com<mailto:runseb@gmail.com><mailto:runseb@gmail.com>>
wrote:

@miguel, looks like smoke/test_scale_vm is reporting errors. It seems you were the last one
to touch that test. Could you try to run the tests on some cloudstack setup you have and report
back to use your finding. From below you can see, the test seems to be failing on simulator/basic.

It would be nice to have the output of the tests to troubleshoot...
Anyway, I’m going to build an environment to run the “integration.smoke.test_scale_vm.TestScaleVm.test_02_scale_vm_without_hypervisor_specifics”
test.

From the list you sent I can see that the test is being ran against XS. That should not be
a problem, however that test is a dumbed down, mean for simulator only, version of the other
test in that same file. The other one is the one that actually tries to connect to the VM,
and that’s the one that should be running against real hypervisors.
Have a look at the PR where that test was introduced if you want to have the full context.
(https://github.com/apache/cloudstack/pull/741)

I’ll let you guys know if I can run the test or not, and what’s the output.


\ Miguel Ferreira
  mferreira@schubergphilis.com<mailto:mferreira@schubergphilis.com><mailto:mferreira@schubergphilis.com>





Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message