cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajani Karuturi <raj...@apache.org>
Subject Re: Hypervisors disconnected - java.io.IOException Fail to init SSL java.io.IOException: Connection closed with -1 on reading size
Date Mon, 31 Aug 2015 10:21:45 GMT
Hi Lucian,
Can you share the point release numbers of java before and after the
upgrade? (May be that would help us find the issue.)

~Rajani

On Mon, Aug 31, 2015 at 3:42 PM, Nux! <nux@li.nux.ro> wrote:

> A downgrade of both java-1.6.0-openjdk and java-1.7.0-openjdk followed by
> a reboot of the management server seems to have fixed it, but it's not a
> solution I like very much.
>
> Anyone has any clues as to what causes that error?
>
> Lucian
>
> --
> Sent from the Delta quadrant using Borg technology!
>
> Nux!
> www.nux.ro
>
> ----- Original Message -----
> > From: "Nux!" <nux@li.nux.ro>
> > To: "dev" <dev@cloudstack.apache.org>
> > Sent: Monday, 31 August, 2015 10:58:16
> > Subject: Hypervisors disconnected - java.io.IOException Fail to init SSL
> java.io.IOException: Connection closed with -1
> > on reading size
>
> > Hi,
> >
> > Has anyone seen this before and can translate to English? The logs don't
> say
> > much, it's obviously SSL related somehow.
> >
> > The agent says:
> >
> > java.io.IOException: SSL: Fail to init SSL! java.io.IOException:
> Connection
> > closed with -1 on reading size.
> >       at com.cloud.utils.nio.NioClient.init(NioClient.java:87)
> >       at com.cloud.utils.nio.NioConnection.run(NioConnection.java:111)
> >       at java.lang.Thread.run(Thread.java:745)
> > 2015-08-31 10:27:56,315 INFO  [utils.nio.NioClient] (Agent-Selector:null)
> > Connecting to 192.168.168.2:8250
> >
> > 2015-08-31 10:28:06,333 ERROR [utils.nio.NioConnection]
> (Agent-Selector:null)
> > Unable to initialize the threads.
> > java.io.IOException: SSL: Fail to init SSL! java.io.IOException:
> Connection
> > closed with -1 on reading size.
> >       at com.cloud.utils.nio.NioClient.init(NioClient.java:87)
> >       at com.cloud.utils.nio.NioConnection.run(NioConnection.java:111)
> >       at java.lang.Thread.run(Thread.java:745)
> >
> > openssl s_client -connect 192.168.168.2:8250 just hangs with
> > "CONNECTED(00000003)"
> >
> >
> > This happened after a java openjdk (1.6.0 and 1.7.0) and httpd updates
> from
> > CentOs6.
> >
> > Obviously the hypervisors are in disconnected state and no VM operation
> is
> > possible etc.
> >
> > Thoughts?
> >
> >
> > --
> > Sent from the Delta quadrant using Borg technology!
> >
> > Nux!
> > www.nux.ro
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message