cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cloud stack <cloudstack...@gmail.com>
Subject Problem in configuring autoscaling feature in CloudStack
Date Thu, 06 Aug 2015 22:34:38 GMT
Hi All,

We are trying to use autoscaling feature in Cloudstack either with
NetScaler or without NetScaler.

We have tried with both Cloudstack versions 4.4 and 4.5.

*Our configuration:*
-- management server : centos 6.4
    ip:192.168.1.10
    netmask:255.255.255.0
    gateway:192.168.1.1

-- host : xenserver 6.1
    ip:192.168.1.11
    netmask:255.255.255.0
    gateway:192.168.1.1

-- we have a router with vlan support,and we configured 4 vlans as untagged
in order to get access to internet (according to router user manual):
vlan id (1) : 192.168.1.0/24
vlan id (2) : 192.168.2.0/24
vlan id (3) : 192.168.3.0/24
vlan id (4) : 192.168.4.0/24
- all vlans can ping each other and can access internet.
- firewall is off in the router.


*==> We tried with the following approaches:*

*1) Installation with Basic zone:*
--Network offering: DefaultSharedNetscalerEIPandELBNetworkOffering
--management network: 192.168.1.0/24 (vlan1)
--guest network: 192.168.1.0/24  (vlan1)
--public network: 192.168.2.0/24 (vlan2)
--Note: we prepared the template with snmp and application

*--Issues in this configuration:*
-We can not ping the public ip assigned to the load balancer that getting
from public ips pool.
-We stopped the firewall in XenServer (btw :firewall is restarted
frequently even though with chkconfig iptables off)

*2) Installation with Advance zone:*
--guest cidr (3 different installation):
        10.10.0.0/24
        192.168.1.0/24
        192.168.2.0/24
--management network: 192.168.1.0/24 (vlan1)
--public network (3 different installation):
        192.168.1.0/24 (vlan1)
        192.168.2.0/24 (vlan2)
--guest vlan tag range (2 different installation):
         700-800
         blank-blank
--We tried with both shared and isolated guest network from vlan1 and vlan2:
        vlan1:192.168.1.0/24
        vlan2:192.168.2.0/24

*--Issues in this configuration:*
-We cannot ping the VM IP created with either isolated or shared network
from any vlans and from vm we can not also access the internet.
-We stopped the firewall in xenserver (btw :firewall is restarted
frequently even though with chkconfig iptables off)

Now we are not sure how to proceed with autoscaler configuration, what
combination we should try to make it work.
Can any one please give us some direction to make autoscale running.
We really appreciate any comments or suggestions.
Please let us know if you have any clarification questions.

Thanks in advance,

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message