cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Reategui <create...@gmail.com>
Subject Re: Ec2stack not working with current aws cli
Date Thu, 06 Aug 2015 01:07:30 GMT
BTW I figured out how to force the cli to send v2.  It would still be nice
to update Ec2Stack though:

aws configure set profile.<your profile name>.ec2.signature_version v2


Or for your default profile:


aws configure set default.ec2.signature_version v2


The above will update your ~/.aws/config file.




On Wed, Aug 5, 2015 at 5:49 PM, Carlos Reategui <creategui@gmail.com> wrote:

> Hi,
> I am having trouble with the current aws cli.  Ec2stack is expecting AWS
> signature version 2 but the current aws cli uses v4.
>
> Do I file a JIRA in under cloudstack?  I did not see an ec2stack component.
>
> Here is a wireshark capture:
>
> POST / HTTP/1.1
> Host: localhost:5000
> Accept-Encoding: identity
> Content-Length: 40
> Content-Type: application/x-www-form-urlencoded
> X-Amz-Date: 20150806T002150Z
> Authorization: AWS4-HMAC-SHA256
> Credential=xxxxx/20150806//ec2/aws4_request,
> SignedHeaders=host;user-agent;x-amz-date, Signature=xxxxxx
> User-Agent: aws-cli/1.7.42 Python/2.7.6 Darwin/14.4.0
>
> Action=DescribeImages&Version=2015-04-15
>
> HTTP/1.0 400 BAD REQUEST
> Content-Type: application/xml
> Content-Length: 314
> Server: Werkzeug/0.10.4 Python/2.7.3
> Date: Thu, 06 Aug 2015 00:21:50 GMT
>
> <?xml version="1.0" encoding="UTF-8"?>
> <Response>
>
>
> <Errors>
>    <Error>
>        <Code>MissingParameter</Code>
>        <Message>The request must contain the parameter
> SignatureVersion</Message>
>    </Error>
> </Errors>
>
>
>
>     <RequestId>21ba5526-3bd1-11e5-abbc-d4ae52927e09</RequestId>
>
> </Response>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message