cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daan Hoogland <daan.hoogl...@gmail.com>
Subject Re: [4.6] Issues deploying VM on VMware
Date Sat, 08 Aug 2015 09:34:27 GMT
so a PR with only a log statement following? ;>

On Sat, Aug 8, 2015 at 11:26 AM, Mike Tutkowski <
mike.tutkowski@solidfire.com> wrote:

> OK, just to close this "issue" out:
>
> It turns out I forgot to mount my /export/secondary to /mnt/sec. Simple as
> that. :) Unfortunately the error messages I was receiving didn't really
> indicate anything like that.
>
> Also, I was able to easily re-route the CopyCommand so I could debug it via
> Eclipse inside of the CS MS.
>
> On Sat, Aug 8, 2015 at 2:56 AM, Mike Tutkowski <
> mike.tutkowski@solidfire.com
> > wrote:
>
> > Is there an easy way to avoid routing this command to the SSVM so that I
> > can debug the code in Eclipse more easily?
> >
> > For example, VMwareGuru is where we decide to route this command to the
> > SSVM.
> >
> > Would it be OK if I went in via the debugger and had it not route to the
> > SSVM, so the CopyCommand would be sent to code inside the CS MS (and I
> > could then easily break point it)?
> >
> > On Sat, Aug 8, 2015 at 2:51 AM, Mike Tutkowski <
> > mike.tutkowski@solidfire.com> wrote:
> >
> >> Here's some relevant text from the cloud.log file on the SSVM. It, too,
> >> indicates an UnsupportedAnswer exception.
> >>
> >> 2015-08-08 08:37:26,657 DEBUG [cloud.agent.Agent]
> >> (agentRequest-Handler-3:null) Request:Seq 4-2159476021324152902:  { Cmd
> ,
> >> MgmtId: 52237617797, via: 4, Ver: v1, Flags: 100111,
> >>
> [{"org.apache.cloudstack.storage.command.CopyCommand":{"srcTO":{"org.apache.cloudstack.storage.to.TemplateObjectTO":{"path":"template/tmpl/1/7/5dcd06f5-f6da-3118-993f-bdd0990b88a5.ova","origUrl":"
> >> http://download.cloud.com/releases/2.2.0/CentOS5.3-x86_64.ova
> ","uuid":"e4c59bbe-3a26-11e5-8215-000c299aca85","id":7,"format":"OVA","accountId":1,"checksum":"f6f881b7f2292948d8494db837fe0f47","hvm":false,"displayText":"CentOS
> >> 5.3(64-bit) no GUI
> >>
> (vSphere)","imageDataStore":{"com.cloud.agent.api.to.NfsTO":{"_url":"nfs://
> >> 192.168.129.50/export/secondary
> >>
> ","_role":"Image"}},"name":"centos53-x64","hypervisorType":"VMware"}},"destTO":{"org.apache.cloudstack.storage.to.TemplateObjectTO":{"origUrl":"
> >> http://download.cloud.com/releases/2.2.0/CentOS5.3-x86_64.ova
> ","uuid":"e4c59bbe-3a26-11e5-8215-000c299aca85","id":7,"format":"OVA","accountId":1,"checksum":"f6f881b7f2292948d8494db837fe0f47","hvm":false,"displayText":"CentOS
> >> 5.3(64-bit) no GUI
> >>
> (vSphere)","imageDataStore":{"org.apache.cloudstack.storage.to.PrimaryDataStoreTO":{"uuid":"047443d7-cb2e-4bbc-b743-38118fdf71af","id":6,"poolType":"VMFS","host":"VMFS
> >> datastore:
> datastore-11","path":"datastore-11","port":0,"url":"VMFS://VMFS
> >> datastore:
> >>
> datastore-11/datastore-11/?ROLE=Primary&STOREUUID=047443d7-cb2e-4bbc-b743-38118fdf71af"}},"name":"centos53-x64","hypervisorType":"VMware"}},"executeInSequence":true,"options":{},"options2":{},"wait":10800}}]
> >> }
> >> 2015-08-08 08:37:26,657 DEBUG [cloud.agent.Agent]
> >> (agentRequest-Handler-3:null) Processing command:
> >> org.apache.cloudstack.storage.command.CopyCommand
> >> 2015-08-08 08:37:26,658 DEBUG [cloud.agent.Agent]
> >> (agentRequest-Handler-3:null) Seq 4-2159476021324152902:  { Ans: ,
> MgmtId:
> >> 52237617797, via: 4, Ver: v1, Flags: 110,
> >>
> [{"com.cloud.agent.api.UnsupportedAnswer":{"result":false,"details":"Unsupported
> >> command issued: org.apache.cloudstack.storage.command.CopyCommand.  Are
> you
> >> sure you got the right type of server?","wait":0}}] }
> >>
> >> On Sat, Aug 8, 2015 at 2:42 AM, Mike Tutkowski <
> >> mike.tutkowski@solidfire.com> wrote:
> >>
> >>> I had a little time to look into this and here's what I found so far:
> >>>
> >>> An UnsupportedAnswer exception is being returned by the secondary
> >>> storage VM when the CopyCommand is sent to it to copy the template from
> >>> secondary to primary storage.
> >>>
> >>> Perhaps unrelated, but I also noticed in the host_details table that
> the
> >>> "password" for both of my ESXi hosts is incorrect. What's listed in
> this
> >>> table for these two hosts is the password for vCenter Server.
> >>>
> >>> I updated the host_details table with the proper passwords for the ESXi
> >>> hosts and re-ran my "create VM" test to see if that fixed the
> issue...it
> >>> did not.
> >>>
> >>> On Fri, Aug 7, 2015 at 12:55 PM, Mike Tutkowski <
> >>> mike.tutkowski@solidfire.com> wrote:
> >>>
> >>>> Hi,
> >>>>
> >>>> I was wondering if anyone was aware of issues in 4.6 around deploying
> >>>> VMs on VMware.
> >>>>
> >>>> I have a Basic Zone running system VMs on XenServer and am trying to
> >>>> deploy a VM to local storage on ESXi. CloudStack is claiming
> insufficient
> >>>> space to deploy the VM.
> >>>>
> >>>> I plan to look into this in more depth, but was just curious first if
> >>>> anyone knew of current issues here.
> >>>>
> >>>> Thanks!
> >>>>
> >>>> --
> >>>> *Mike Tutkowski*
> >>>> *Senior CloudStack Developer, SolidFire Inc.*
> >>>> e: mike.tutkowski@solidfire.com
> >>>> o: 303.746.7302
> >>>> Advancing the way the world uses the cloud
> >>>> <http://solidfire.com/solution/overview/?video=play>*™*
> >>>>
> >>>
> >>>
> >>>
> >>> --
> >>> *Mike Tutkowski*
> >>> *Senior CloudStack Developer, SolidFire Inc.*
> >>> e: mike.tutkowski@solidfire.com
> >>> o: 303.746.7302
> >>> Advancing the way the world uses the cloud
> >>> <http://solidfire.com/solution/overview/?video=play>*™*
> >>>
> >>
> >>
> >>
> >> --
> >> *Mike Tutkowski*
> >> *Senior CloudStack Developer, SolidFire Inc.*
> >> e: mike.tutkowski@solidfire.com
> >> o: 303.746.7302
> >> Advancing the way the world uses the cloud
> >> <http://solidfire.com/solution/overview/?video=play>*™*
> >>
> >
> >
> >
> > --
> > *Mike Tutkowski*
> > *Senior CloudStack Developer, SolidFire Inc.*
> > e: mike.tutkowski@solidfire.com
> > o: 303.746.7302
> > Advancing the way the world uses the cloud
> > <http://solidfire.com/solution/overview/?video=play>*™*
> >
>
>
>
> --
> *Mike Tutkowski*
> *Senior CloudStack Developer, SolidFire Inc.*
> e: mike.tutkowski@solidfire.com
> o: 303.746.7302
> Advancing the way the world uses the cloud
> <http://solidfire.com/solution/overview/?video=play>*™*
>



-- 
Daan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message