cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Tutkowski <mike.tutkow...@solidfire.com>
Subject Re: Question: Routing commands to SSVM
Date Sun, 09 Aug 2015 04:25:11 GMT
Hi,

OK, as an FYI, I'll follow up on what I did to solve this (in case others
encounter a similar problem in the future and remember this e-mail):

As it turns out, the code I used to build my cloud was built as such:

mvn -P developer,systemvm clean install

I was not planning on introducing ESXi hosts at the time, but later decided
to do so in order to run additional tests before we start voting on 4.6.

Anyways, when I went to add a VMware datacenter, I received an error
message about a VMware-related API call not existing.

That reminded me that I needed to rebuild the code as such:

mvn -P developer,systemvm clean install -D noredist

Then I ran it this way:

mvn -pl client jetty:run -D noredist

I was now able to add my VMware datacenter.

My next problem was around deploying a VM to local storage on one of the
ESXi hosts.

As it turns out, I had forgotten to run the following:

sudo mount -t nfs <CS MS IP Address>:/export/secondary /mnt/sec

Once I did this, I was able to deploy to local storage.

My following problem was related to using zone-wide primary storage for the
VM.

This is where I kept getting an UnsupportedAnswer exception if the command
was sent to the SSVM (which is the default target in this situation).

The reason this was happening was because the SSVM was using agent code
prior to me having built the codebase using -D noredist.

Since my CloudStack Management Server (CS MS) was built using -D noredist,
when I diverted the CopyCommand to the CS MS, it worked.

What I then needed to do was destroy my SSVM and let it be rebuilt (because
the most recent build of my code was built using -D noredist, so the SSVM
would be patched with the necessary code).

Talk to you later,
Mike

On Sat, Aug 8, 2015 at 9:36 PM, Mike Tutkowski <mike.tutkowski@solidfire.com
> wrote:

> Hi,
>
> I was having some VMware issues yesterday.
>
> I solved the one related to local storage, but the one remaining for me
> deals with routing a CopyCommand to the SSVM.
>
> I notice if I set a breakpoint and force the CopyCommand to not be routed
> to the SSVM, then the CopyCommand is able to successfully interact with
> vCenter Server and all is well.
>
> However, if I let the normal course run and the CopyCommand is routed to
> the SSVM, then I get back an exception: UnsupportedAnswer.
>
> There does not appear to be much to go off of in cloud.log on the SSVM:
>
> 2015-08-09 01:10:11,669 DEBUG [cloud.agent.Agent]
> (agentRequest-Handler-4:null) Request:Seq 4-2159476021324153863:  { Cmd ,
> MgmtId: 52237617797, via: 4, Ver: v1, Flags: 100111,
> [{"org.apache.cloudstack.storage.command.CopyCommand":{"srcTO":{"org.apache.cloudstack.storage.to.TemplateObjectTO":{"path":"template/tmpl/1/7/5dcd06f5-f6da-3118-993f-bdd0990b88a5.ova","origUrl":"
> http://download.cloud.com/releases/2.2.0/CentOS5.3-x86_64.ova","uuid":"e4c59bbe-3a26-11e5-8215-000c299aca85","id":7,"format":"OVA","accountId":1,"checksum":"f6f881b7f2292948d8494db837fe0f47","hvm":false,"displayText":"CentOS
> 5.3(64-bit) no GUI
> (vSphere)","imageDataStore":{"com.cloud.agent.api.to.NfsTO":{"_url":"nfs://
> 192.168.129.50/export/secondary
> ","_role":"Image"}},"name":"centos53-x64","hypervisorType":"VMware"}},"destTO":{"org.apache.cloudstack.storage.to.TemplateObjectTO":{"origUrl":"
> http://download.cloud.com/releases/2.2.0/CentOS5.3-x86_64.ova","uuid":"e4c59bbe-3a26-11e5-8215-000c299aca85","id":7,"format":"OVA","accountId":1,"checksum":"f6f881b7f2292948d8494db837fe0f47","hvm":false,"displayText":"CentOS
> 5.3(64-bit) no GUI
> (vSphere)","imageDataStore":{"org.apache.cloudstack.storage.to.PrimaryDataStoreTO":{"uuid":"SolidFire_f118f9e3-2133-4522-b079-dabe46f6360c_10.10.8.107","id":3,"poolType":"Iscsi","host":"10.10.8.107","path":"MVIP=192.168.139.127;SVIP=10.10.8.107","port":3260,"url":"Iscsi://
> 10.10.8.107/MVIP=192.168.139.127;SVIP=10.10.8.107/?ROLE=Primary&STOREUUID=SolidFire_f118f9e3-2133-4522-b079-dabe46f6360c_10.10.8.107","details":{"managed":"true","managedStoreTargetRootVolume":"ROOT-35","storagePort":"3260","storageHost":"10.10.8.107","managedStoreTarget":"/iqn.2010-01.com.solidfire:deyb.root-35.47/0","volumeSize":"2147483648"}}},"name":"centos53-x64","hypervisorType":"VMware"}},"executeInSequence":true,"options":{},"options2":{},"wait":10800}}]
> }
> 2015-08-09 01:10:11,669 DEBUG [cloud.agent.Agent]
> (agentRequest-Handler-4:null) Processing command:
> org.apache.cloudstack.storage.command.CopyCommand
> 2015-08-09 01:10:11,670 DEBUG [cloud.agent.Agent]
> (agentRequest-Handler-4:null) Seq 4-2159476021324153863:  { Ans: , MgmtId:
> 52237617797, via: 4, Ver: v1, Flags: 110,
> [{"com.cloud.agent.api.UnsupportedAnswer":{"result":false,"details":"Unsupported
> command issued: org.apache.cloudstack.storage.command.CopyCommand.  Are you
> sure you got the right type of server?","wait":0}}] }
>
> Thoughts?
>
> Thanks!
>
> --
> *Mike Tutkowski*
> *Senior CloudStack Developer, SolidFire Inc.*
> e: mike.tutkowski@solidfire.com
> o: 303.746.7302
> Advancing the way the world uses the cloud
> <http://solidfire.com/solution/overview/?video=play>*™*
>



-- 
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the cloud
<http://solidfire.com/solution/overview/?video=play>*™*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message