cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jenk...@cloudstack.org
Subject Build failed in Jenkins: build-master-noredist #4533
Date Tue, 18 Aug 2015 10:08:42 GMT
See <http://jenkins.buildacloud.org/job/build-master-noredist/4533/changes>

Changes:

[radu.stefanache] Typo correction

------------------------------------------
[...truncated 8205 lines...]
2015-08-18 10:11:11 DEBUG Script:433 - Looking for scripts/vm/systemvm/id_rsa.cloud in <http://jenkins.buildacloud.org/job/build-master-noredist/ws/utils/scripts/vm/systemvm/id_rsa.cloud>
2015-08-18 10:11:11 DEBUG Script:433 - Looking for scripts/vm/systemvm/id_rsa.cloud in <http://jenkins.buildacloud.org/job/build-master-noredist/ws/scripts/vm/systemvm/id_rsa.cloud>
2015-08-18 10:11:11 DEBUG Ovm3HypervisorSupport:165 - found SshKey <http://jenkins.buildacloud.org/job/build-master-noredist/ws/scripts/vm/systemvm/id_rsa.cloud>
2015-08-18 10:11:11 DEBUG Ovm3HypervisorResource:389 - override connection: null
2015-08-18 10:11:11 DEBUG Ovm3HypervisorResource:345 - configure ovm-1 with params: {agentusername=oracle,
public.network.device=xenbr0, xenserver.heartbeat.interval=60, private.network.device=xenbr0,
agentpassword=unknown, Hypervisor.Version=4.1.3OVM, secondary.storage.vm=false, Host.OS=Oracle
VM Server, ovm3pool=true, ipaddress=192.168.1.64, password=unknown, username=root, pool=a9c1219d-817d-4242-b23e-2607801c79d5,
ismaster=false, storage.network.device=xenbr0, ovm3.heartbeat.timeout=120, Host.OS.Version=5.7,
xenserver.nics.max=7, agentVersion=3.2.1-183, router.aggregation.command.each.timeout=3, pod=1,
istest=true, max.template.iso.size=50, host=ovm-1, com.cloud.network.Networks.RouterPrivateIpStrategy=DcGlobal,
agentport=8899, Host.OS.Kernel.Version=2.6.39-300.22.2.el5uek, migratewait=3600, storage.network.device1=xenbr0,
ovm3.heartbeat.interval=1, ip=192.168.1.64, ovm3cluster=false, guid=19e5f1e7-22f4-3b6d-8d41-c82f89c65295,
ovm3vip=192.168.1.230, hasmaster=true, cluster=1, guest.network.device=xenbr0, zone=1, xenserver.heartbeat.timeout=120}
2015-08-18 10:11:11 DEBUG ConnectionTest:67 - methodresponse call: check_dom0_ip - [192.168.1.230]
2015-08-18 10:11:11 DEBUG Ovm3HypervisorSupport:587 - ovm-1 is a master, already has vip 192.168.1.230
2015-08-18 10:11:11 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
2015-08-18 10:11:11 DEBUG Ovm3HypervisorNetwork:75 - already have control0
2015-08-18 10:11:11 DEBUG ConnectionTest:67 - methodresponse call: ovs_ip_config - [control0,
static, 169.254.0.1, 255.255.0.0]
2015-08-18 10:11:11 DEBUG ConnectionTest:67 - methodresponse call: ovs_control_interface -
[control0, 169.254.0.0/16]
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_hardware - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_server - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: update_server_roles - [xen,utility]
2015-08-18 10:11:12 DEBUG Ovm3StoragePool:164 - Host ovm-1 owned by us
2015-08-18 10:11:12 DEBUG Ovm3HypervisorResource:208 - executeRequest called: class com.cloud.agent.api.GetHostStatsCommand
2015-08-18 10:11:12 DEBUG ConnectionTest:72 - getresult call: ovs_dom0_stats - [xenbr0]
2015-08-18 10:11:12 DEBUG Ovm3HypervisorSupport:709 - Unable to get host stats for: ovm-1
com.cloud.hypervisor.ovm3.objects.Ovm3ResourceException: Client call ovs_dom0_stats to null
with [xenbr0] went wrong: Exception: null
	at com.cloud.hypervisor.ovm3.objects.OvmObject.callWrapper(OvmObject.java:107)
	at com.cloud.hypervisor.ovm3.objects.CloudstackPlugin.ovsDom0Stats(CloudstackPlugin.java:135)
	at com.cloud.hypervisor.ovm3.resources.helpers.Ovm3HypervisorSupport.execute(Ovm3HypervisorSupport.java:697)
	at com.cloud.hypervisor.ovm3.resources.Ovm3HypervisorResource.executeRequest(Ovm3HypervisorResource.java:253)
	at com.cloud.hypervisor.ovm3.resources.helpers.Ovm3HypervisorSupportTest.GetHostStatsCommandFailTest(Ovm3HypervisorSupportTest.java:218)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
	at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:271)
	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:70)
	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:50)
	at org.junit.runners.ParentRunner$3.run(ParentRunner.java:238)
	at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:63)
	at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:236)
	at org.junit.runners.ParentRunner.access$000(ParentRunner.java:53)
	at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:229)
	at org.junit.runners.ParentRunner.run(ParentRunner.java:309)
	at org.apache.maven.surefire.junit4.JUnit4Provider.execute(JUnit4Provider.java:283)
	at org.apache.maven.surefire.junit4.JUnit4Provider.executeWithRerun(JUnit4Provider.java:173)
	at org.apache.maven.surefire.junit4.JUnit4Provider.executeTestSet(JUnit4Provider.java:153)
	at org.apache.maven.surefire.junit4.JUnit4Provider.invoke(JUnit4Provider.java:128)
	at org.apache.maven.surefire.booter.ForkedBooter.invokeProviderInSameClassLoader(ForkedBooter.java:203)
	at org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(ForkedBooter.java:155)
	at org.apache.maven.surefire.booter.ForkedBooter.main(ForkedBooter.java:103)
2015-08-18 10:11:12 DEBUG ConnectionTest:72 - getresult call: list_vms - []
2015-08-18 10:11:12 DEBUG Ovm3HypervisorSupport:448 - New state without old state: i-2-3-VM
2015-08-18 10:11:12 DEBUG Script:340 - Looking for scripts/vm/systemvm/missing in the classpath
2015-08-18 10:11:12 DEBUG Script:343 - System resource: null
2015-08-18 10:11:12 DEBUG Script:366 - Classpath resource: null
2015-08-18 10:11:12 DEBUG Script:387 - Looking for scripts/vm/systemvm/missing
2015-08-18 10:11:12 DEBUG Script:407 - Current binaries reside at <http://jenkins.buildacloud.org/job/build-master-noredist/ws/utils/target>
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in <http://jenkins.buildacloud.org/job/build-master-noredist/ws/utils/target/scripts/vm/systemvm/missing>
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in <http://jenkins.buildacloud.org/job/build-master-noredist/ws/utils/target/scripts/vm/systemvm/missing>
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in <http://jenkins.buildacloud.org/job/build-master-noredist/ws/utils/scripts/vm/systemvm/missing>
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in <http://jenkins.buildacloud.org/job/build-master-noredist/ws/scripts/vm/systemvm/missing>
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in /home/jenkins/acs/workspace/scripts/vm/systemvm/missing
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in /home/jenkins/acs/scripts/vm/systemvm/missing
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in /home/jenkins/scripts/vm/systemvm/missing
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in /home/scripts/vm/systemvm/missing
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in /scripts/vm/systemvm/missing
2015-08-18 10:11:12 DEBUG Script:410 - Searching in environment.properties
2015-08-18 10:11:12 DEBUG Script:414 - environment.properties could not be opened
2015-08-18 10:11:12 DEBUG Script:423 - environment.properties says scripts should be in 
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in /scripts/vm/systemvm/missing
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in /scripts/vm/systemvm/missing
2015-08-18 10:11:12 DEBUG Script:425 - Searching in the current directory
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in <http://jenkins.buildacloud.org/job/build-master-noredist/ws/plugins/hypervisors/ovm3/./scripts/vm/systemvm/missing>
2015-08-18 10:11:12 DEBUG Script:433 - Looking for scripts/vm/systemvm/missing in <http://jenkins.buildacloud.org/job/build-master-noredist/ws/plugins/hypervisors/ovm3/./scripts/vm/systemvm/missing>
2015-08-18 10:11:12 DEBUG Script:448 - Looking for scripts/vm/systemvm/missing in <http://jenkins.buildacloud.org/job/build-master-noredist/ws/plugins/hypervisors/ovm3/null/scripts/vm/systemvm/missing>
2015-08-18 10:11:12 DEBUG Script:448 - Looking for scripts/vm/systemvm/missing in <http://jenkins.buildacloud.org/job/build-master-noredist/ws/plugins/hypervisors/ovm3/null/scripts/vm/systemvm/missing>
2015-08-18 10:11:12 WARN  Script:455 - Unable to find script scripts/vm/systemvm/missing
2015-08-18 10:11:12 WARN  Ovm3HypervisorSupport:171 - findScript failed, going for generated
client/target/generated-webapp/WEB-INF/classes/scripts/vm/systemvm/missing
2015-08-18 10:11:12 WARN  Ovm3HypervisorSupport:177 - generated key retrieval failed /usr/share/cloudstack-common/scripts/vm/systemvm/missing
2015-08-18 10:11:12 DEBUG ConnectionTest:72 - getresult call: discover_hardware - []
2015-08-18 10:11:12 DEBUG ConnectionTest:72 - getresult call: discover_server - []
2015-08-18 10:11:12 DEBUG Ovm3HypervisorSupport:198 - Hypervisor version: 3.2.1-517
2015-08-18 10:11:12 DEBUG ConnectionTest:72 - getresult call: discover_network - []
2015-08-18 10:11:12 DEBUG ConnectionTest:72 - getresult call: discover_network - []
2015-08-18 10:11:12 DEBUG ConnectionTest:72 - getresult call: discover_network - []
2015-08-18 10:11:12 DEBUG Ovm3HypervisorSupport:252 - Add an Ovm3 host ovm-1:{public.network.device=xenbr0,
private.network.device=xenbr0, com.cloud.network.Networks.RouterPrivateIpStrategy=DcGlobal,
hasmaster=false, ismaster=false, storage.network.device=xenbr0, guest.network.device=xenbr0}
2015-08-18 10:11:12 DEBUG Ovm3HypervisorResource:389 - override connection: null
2015-08-18 10:11:12 DEBUG Ovm3HypervisorResource:345 - configure ovm-1 with params: {agentusername=oracle,
public.network.device=xenbr0, xenserver.heartbeat.interval=60, private.network.device=xenbr0,
agentpassword=unknown, Hypervisor.Version=4.1.3OVM, secondary.storage.vm=false, Host.OS=Oracle
VM Server, ovm3pool=true, ipaddress=192.168.1.64, password=unknown, username=root, pool=a9c1219d-817d-4242-b23e-2607801c79d5,
ismaster=false, storage.network.device=xenbr0, ovm3.heartbeat.timeout=120, Host.OS.Version=5.7,
xenserver.nics.max=7, agentVersion=3.2.1-183, router.aggregation.command.each.timeout=3, pod=1,
istest=true, max.template.iso.size=50, host=ovm-1, com.cloud.network.Networks.RouterPrivateIpStrategy=DcGlobal,
agentport=8899, Host.OS.Kernel.Version=2.6.39-300.22.2.el5uek, migratewait=3600, storage.network.device1=xenbr0,
ovm3.heartbeat.interval=1, ip=192.168.1.64, ovm3cluster=false, guid=19e5f1e7-22f4-3b6d-8d41-c82f89c65295,
ovm3vip=192.168.1.230, hasmaster=true, cluster=1, guest.network.device=xenbr0, zone=1, xenserver.heartbeat.timeout=120}
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: check_dom0_ip - [192.168.1.230]
2015-08-18 10:11:12 DEBUG Ovm3HypervisorSupport:587 - ovm-1 is a master, already has vip 192.168.1.230
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
2015-08-18 10:11:12 DEBUG Ovm3HypervisorNetwork:75 - already have control0
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: ovs_ip_config - [control0,
static, 169.254.0.1, 255.255.0.0]
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: ovs_control_interface -
[control0, 169.254.0.0/16]
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_hardware - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_server - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: update_server_roles - [xen,utility]
2015-08-18 10:11:12 DEBUG Ovm3StoragePool:164 - Host ovm-1 owned by us
2015-08-18 10:11:12 DEBUG Ovm3HypervisorResource:208 - executeRequest called: class com.cloud.agent.api.CheckHealthCommand
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: echo - [put]
Tests run: 14, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.018 sec - in com.cloud.hypervisor.ovm3.resources.helpers.Ovm3HypervisorSupportTest
Running com.cloud.hypervisor.ovm3.resources.helpers.Ovm3ConfigurationTest
2015-08-18 10:11:12 DEBUG Ovm3Configuration:453 - Unable to get PodId params are null
2015-08-18 10:11:12 DEBUG Ovm3Configuration:134 - No VIP, Setting ovm3pool and ovm3cluster
to false
Tests run: 4, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0 sec - in com.cloud.hypervisor.ovm3.resources.helpers.Ovm3ConfigurationTest
Running com.cloud.hypervisor.ovm3.resources.helpers.Ovm3HypervisorNetworkTest
2015-08-18 10:11:12 DEBUG Ovm3HypervisorResource:389 - override connection: null
2015-08-18 10:11:12 DEBUG Ovm3HypervisorResource:345 - configure ovm-1 with params: {agentusername=oracle,
public.network.device=xenbr0, xenserver.heartbeat.interval=60, private.network.device=xenbr0,
agentpassword=unknown, Hypervisor.Version=4.1.3OVM, secondary.storage.vm=false, Host.OS=Oracle
VM Server, ovm3pool=true, ipaddress=192.168.1.64, password=unknown, username=root, pool=a9c1219d-817d-4242-b23e-2607801c79d5,
ismaster=false, storage.network.device=xenbr0, ovm3.heartbeat.timeout=120, Host.OS.Version=5.7,
xenserver.nics.max=7, agentVersion=3.2.1-183, router.aggregation.command.each.timeout=3, pod=1,
istest=true, max.template.iso.size=50, host=ovm-1, com.cloud.network.Networks.RouterPrivateIpStrategy=DcGlobal,
agentport=8899, Host.OS.Kernel.Version=2.6.39-300.22.2.el5uek, migratewait=3600, storage.network.device1=xenbr0,
ovm3.heartbeat.interval=1, ip=192.168.1.64, ovm3cluster=false, guid=19e5f1e7-22f4-3b6d-8d41-c82f89c65295,
ovm3vip=192.168.1.230, hasmaster=true, cluster=1, guest.network.device=xenbr0, zone=1, xenserver.heartbeat.timeout=120}
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: check_dom0_ip - [192.168.1.230]
2015-08-18 10:11:12 DEBUG Ovm3HypervisorSupport:587 - ovm-1 is a master, already has vip 192.168.1.230
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
2015-08-18 10:11:12 DEBUG Ovm3HypervisorNetwork:75 - already have control0
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: ovs_ip_config - [control0,
static, 169.254.0.1, 255.255.0.0]
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: ovs_control_interface -
[control0, 169.254.0.0/16]
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_hardware - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_server - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: update_server_roles - [xen,utility]
2015-08-18 10:11:12 DEBUG Ovm3StoragePool:164 - Host ovm-1 owned by us
2015-08-18 10:11:12 DEBUG Ovm3HypervisorResource:208 - executeRequest called: class com.cloud.agent.api.PingTestCommand
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: ping - [192.168.1.64]
2015-08-18 10:11:12 DEBUG Ovm3HypervisorResource:389 - override connection: null
2015-08-18 10:11:12 DEBUG Ovm3HypervisorResource:345 - configure ovm-1 with params: {agentusername=oracle,
public.network.device=xenbr0, xenserver.heartbeat.interval=60, private.network.device=xenbr0,
agentpassword=unknown, Hypervisor.Version=4.1.3OVM, secondary.storage.vm=false, Host.OS=Oracle
VM Server, ovm3pool=true, ipaddress=192.168.1.64, password=unknown, username=root, pool=a9c1219d-817d-4242-b23e-2607801c79d5,
ismaster=false, storage.network.device=xenbr0, ovm3.heartbeat.timeout=120, Host.OS.Version=5.7,
xenserver.nics.max=7, agentVersion=3.2.1-183, router.aggregation.command.each.timeout=3, pod=1,
istest=true, max.template.iso.size=50, host=ovm-1, com.cloud.network.Networks.RouterPrivateIpStrategy=DcGlobal,
agentport=8899, Host.OS.Kernel.Version=2.6.39-300.22.2.el5uek, migratewait=3600, storage.network.device1=xenbr0,
ovm3.heartbeat.interval=1, ip=192.168.1.64, ovm3cluster=false, guid=19e5f1e7-22f4-3b6d-8d41-c82f89c65295,
ovm3vip=192.168.1.230, hasmaster=true, cluster=1, guest.network.device=xenbr0, zone=1, xenserver.heartbeat.timeout=120}
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: check_dom0_ip - [192.168.1.230]
2015-08-18 10:11:12 DEBUG Ovm3HypervisorSupport:587 - ovm-1 is a master, already has vip 192.168.1.230
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
2015-08-18 10:11:12 DEBUG Ovm3HypervisorNetwork:75 - already have control0
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: ovs_ip_config - [control0,
static, 169.254.0.1, 255.255.0.0]
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: ovs_control_interface -
[control0, 169.254.0.0/16]
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_hardware - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_server - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: update_server_roles - [xen,utility]
2015-08-18 10:11:12 DEBUG Ovm3StoragePool:164 - Host ovm-1 owned by us
2015-08-18 10:11:12 DEBUG Ovm3HypervisorResource:208 - executeRequest called: class com.cloud.agent.api.CheckNetworkCommand
2015-08-18 10:11:12 DEBUG Ovm3HypervisorNetwork:119 - Checking if network name setup is done
on ovm-1
2015-08-18 10:11:12 DEBUG Ovm3HypervisorNetwork:99 - Looking for network setup by name xenbr0
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
2015-08-18 10:11:12 DEBUG Ovm3HypervisorNetwork:105 - Found bridge with name: xenbr0
2015-08-18 10:11:12 DEBUG Ovm3HypervisorNetwork:99 - Looking for network setup by name xenbr0

	at net.sourceforge.pmd.RuleSetFactory.parseRuleSetNode(RuleSetFactory.java:219)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:164)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:129)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:114)
	at net.sourceforge.pmd.processor.PmdRunnable$PmdThread.getRuleSets(PmdRunnable.java:113)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:63)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:25)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
java.lang.RuntimeException: Couldn't find the class Can't find resource 'rulesets/java/empty.xml'
for rule 'null'.  Make sure the resource is a valid file or URL and is on the CLASSPATH. Here's
the current classpath: /home/jenkins/acs/tools/hudson.tasks.Maven_MavenInstallation/maven-3.1.1/boot/plexus-classworlds-2.5.1.jar
	at net.sourceforge.pmd.RuleSetFactory.classNotFoundProblem(RuleSetFactory.java:247)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleSetNode(RuleSetFactory.java:237)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:164)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:129)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:114)
	at net.sourceforge.pmd.processor.PmdRunnable$PmdThread.getRuleSets(PmdRunnable.java:113)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:63)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:25)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
[INFO] 
[INFO] --- maven-site-plugin:3.1:attach-descriptor (attach-descriptor) @ cloud-plugin-network-globodns
---
2015-08-18 10:11:12 DEBUG Ovm3HypervisorNetwork:105 - Found bridge with name: xenbr0
2015-08-18 10:11:12 DEBUG Ovm3HypervisorNetwork:99 - Looking for network setup by name xenbr0
2015-08-18 10:11:12 DEBUG ConnectionTest:67 - methodresponse call: discover_network - []
net.sourceforge.pmd.RuleSetNotFoundException: Can't find resource 'rulesets/java/basic.xml'
for rule 'null'.  Make sure the resource is a valid file or URL and is on the CLASSPATH. Here's
the current classpath: /home/jenkins/acs/tools/hudson.tasks.Maven_MavenInstallation/maven-3.1.1/boot/plexus-classworlds-2.5.1.jar
	at net.sourceforge.pmd.RuleSetReferenceId.getInputStream(RuleSetReferenceId.java:315)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:164)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleSetReferenceNode(RuleSetFactory.java:303)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleNode(RuleSetFactory.java:262)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleSetNode(RuleSetFactory.java:219)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:164)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:129)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:114)
	at net.sourceforge.pmd.processor.PmdRunnable$PmdThread.getRuleSets(PmdRunnable.java:113)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:63)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:25)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
java.lang.RuntimeException: Couldn't find the class Can't find resource 'rulesets/java/basic.xml'
for rule 'null'.  Make sure the resource is a valid file or URL and is on the CLASSPATH. Here's
the current classpath: /home/jenkins/acs/tools/hudson.tasks.Maven_MavenInstallation/maven-3.1.1/boot/plexus-classworlds-2.5.1.jar
	at net.sourceforge.pmd.RuleSetFactory.classNotFoundProblem(RuleSetFactory.java:247)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleSetNode(RuleSetFactory.java:237)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:164)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:129)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:114)
	at net.sourceforge.pmd.processor.PmdRunnable$PmdThread.getRuleSets(PmdRunnable.java:113)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:63)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:25)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
net.sourceforge.pmd.RuleSetNotFoundException: Can't find resource 'rulesets/java/basic.xml'
for rule 'null'.  Make sure the resource is a valid file or URL and is on the CLASSPATH. Here's
the current classpath: /home/jenkins/acs/tools/hudson.tasks.Maven_MavenInstallation/maven-3.1.1/boot/plexus-classworlds-2.5.1.jar
	at net.sourceforge.pmd.RuleSetReferenceId.getInputStream(RuleSetReferenceId.java:315)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:164)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleSetReferenceNode(RuleSetFactory.java:303)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleNode(RuleSetFactory.java:262)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleSetNode(RuleSetFactory.java:219)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:164)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:129)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:114)
	at net.sourceforge.pmd.processor.PmdRunnable$PmdThread.getRuleSets(PmdRunnable.java:113)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:63)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:25)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
java.lang.RuntimeException: Couldn't find the class Can't find resource 'rulesets/java/basic.xml'
for rule 'null'.  Make sure the resource is a valid file or URL and is on the CLASSPATH. Here's
the current classpath: /home/jenkins/acs/tools/hudson.tasks.Maven_MavenInstallation/maven-3.1.1/boot/plexus-classworlds-2.5.1.jar
	at net.sourceforge.pmd.RuleSetFactory.classNotFoundProblem(RuleSetFactory.java:247)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleSetNode(RuleSetFactory.java:237)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:164)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:129)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:114)
	at net.sourceforge.pmd.processor.PmdRunnable$PmdThread.getRuleSets(PmdRunnable.java:113)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:63)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:25)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
net.sourceforge.pmd.RuleSetNotFoundException: Can't find resource 'rulesets/java/basic.xml'
for rule 'null'.  Make sure the resource is a valid file or URL and is on the CLASSPATH. Here's
the current classpath: /home/jenkins/acs/tools/hudson.tasks.Maven_MavenInstallation/maven-3.1.1/boot/plexus-classworlds-2.5.1.jar
	at net.sourceforge.pmd.RuleSetReferenceId.getInputStream(RuleSetReferenceId.java:315)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:164)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleSetReferenceNode(RuleSetFactory.java:303)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleNode(RuleSetFactory.java:262)
	at net.sourceforge.pmd.RuleSetFactory.parseRuleSetNode(RuleSetFactory.java:219)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSet(RuleSetFactory.java:164)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:129)
	at net.sourceforge.pmd.RuleSetFactory.createRuleSets(RuleSetFactory.java:114)
	at net.sourceforge.pmd.processor.PmdRunnable$PmdThread.getRuleSets(PmdRunnable.java:113)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:63)
	at net.sourceforge.pmd.processor.PmdRunnable.call(PmdRunnable.java:25)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Build step 'Invoke top-level Maven targets' marked build as failure
Archiving artifacts

Mime
View raw message