cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From France <mailingli...@isg.si>
Subject Re: Upgrading 4.3.1 to 4.3.2 including system templates - quick help please
Date Fri, 26 Jun 2015 11:42:04 GMT
Seems like this q. is related.
Andria, which CS build would/do you use? Which would you personally recommend?
I will go with 3.2.2 + patches from shapeblue.

Official build: http://cloudstack.apt-get.eu/rhel/4.3/
There also build in Shapeblue’s repo based on 4.3.2 : http://packages.shapeblue.com/cloudstack/upstream/centos/4.3/
And they also provide additionally pached build via: http://packages.shapeblue.com/cloudstack/main/centos/4.3/

Regards,
F.

On 26 Jun 2015, at 13:01, Andrija Panic <andrija.panic@gmail.com> wrote:

> http://packages.shapeblue.com/tools/ghost-systemvm-upgrader.py is a
> shapeblue's stuff, if they are fine - then no problem :)
> 
> But I see inside the script, it's hardcoded to 4.3 and 4.4 vesions, and it
> loads templates from shapeblue's repos only
> 
> So again we might go back to the story (not sure what was decided there) of
> hosting stuff on apt-get.eu or shapeblue, or both etc...
> 
> Would be nice to have some general decision arround this...and then, yes,
> make/update documentation...
> 
> On 26 June 2015 at 12:52, Erik Weber <terbolous@gmail.com> wrote:
> 
>> Edit it and send a piller request :-)
>> 
>> Erik
>> 
>> Den fredag 26. juni 2015 skrev Andrija Panic <andrija.panic@gmail.com>
>> følgende:
>> 
>>> I also used this approach - worked for me.
>>> 
>>> It would be nice if we could put this somewhere in the official docs in
>> ACS
>>> repo...
>>> 
>>> On 26 June 2015 at 12:35, France <mailinglists@isg.si <javascript:;>>
>>> wrote:
>>> 
>>>> OK, I was able to find instructions for upgrading templates:
>>>> http://www.shapeblue.com/cloudstack-and-the-ghost-vulnerabilitystack/
>>>> it even has a nice script, which we will try this weekend.
>>>> 
>>>> Also for vhd-utils link, I have found vhd-utils at:
>>>> http://download.cloud.com.s3.amazonaws.com/tools/vhd-util
>>>> 
>>>> If these are not correct for CS 4.3.* and XS 6.0.2*, someone please let
>>> us
>>>> know.
>>>> Hopefully this mail will help others upgrade, if they see it.
>>>> 
>>>> Regards,
>>>> F.
>>>> 
>>>> On 26 Jun 2015, at 11:40, France <mailinglists@isg.si <javascript:;>>
>>> wrote:
>>>> 
>>>>> Anyone?
>>>>> 
>>>>> 
>>>>> On 24 Jun 2015, at 15:07, France <mailinglists@isg.si
>> <javascript:;>>
>>> wrote:
>>>>> 
>>>>>> Hi all,
>>>>>> 
>>>>>> we got CS 4.3.1 which we will upgrade to 4.3.2 this weekend, using
>>> RPMs
>>>> from shapeblue (
>>> http://packages.shapeblue.com/cloudstack/main/centos/4.3/
>>>> ).
>>>>>> 
>>>>>> Following the instructions at:
>>>>>> 
>>>> 
>>> 
>> http://docs.cloudstack.apache.org/projects/cloudstack-release-notes/en/4.3.2/rnotes.html#upgrade-from-4-3-1-to-4-3-2
>>>>>> 
>>>>>> First problem I notice, that there is no link provided for vhd-utils
>>>> from the last step of the upgrade.
>>>>>> Where can we get the right vhd-utils as required?
>>>>>> 
>>>>>> Also no step in upgrade docs is mentioning of the system-vm template
>>>> upgrade.
>>>>>> I see Shapeblue provides a link to ?updated? templates:
>>>> http://packages.shapeblue.com/systemvmtemplate/4.3/
>>>>>> But i failed to find instructions how to update them. Are they
>> updated
>>>> when updating base RPMs? I doubt it.
>>>>>> Please direct us, to the correct instructions for updating
>> templates.
>>>>>> 
>>>>>> Thank you for your help/responses.
>>>>>> Regards,
>>>>>> France.
>>>>> 
>>>> 
>>>> 
>>> 
>>> 
>>> --
>>> 
>>> Andrija Panić
>>> 
>> 
> 
> 
> 
> -- 
> 
> Andrija Panić


Mime
View raw message