cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Hair <j...@greenqloud.com>
Subject Re: Trying to Run awsapi on 4.5 from Maven
Date Thu, 11 Jun 2015 11:01:58 GMT
Some progress: by adding the MySQL connector dependency to the awsapi POM,
the MySQL error was solved. I suspect it's something similar for the XML
library problem.

On Thu, Jun 11, 2015 at 10:32 AM, Jeff Hair <jeff@greenqloud.com> wrote:

> Hi,
>
> I'm trying to run the awsapi server on the 4.5 branch from Maven. Normally
> we work with 4.2 and a deployed version of awsapi, so this is the first
> time I'm trying it from mvn.
>
> I'm using this command: mvn -Pawsapi -pl :cloud-awsapi jetty:run
>
> I have a few errors:
> 1. java.sql.SQLException: No suitable driver found for
> jdbc:mysql://localhost:3306/cloudbridge?autoReconnect=true
> 2. The version-1.5.6.aar service, which is not valid, caused
> java.lang.NoSuchMethodError:
> org.apache.ws.commons.schema.XmlSchemaForm.<init>(Ljava/lang/String;)V
>
> Both of these sound like classpath problems. But awsapi builds
> successfully, so shouldn't the MySQL driver and the proper form of the XML
> parsing library already be on the classpath?
>
> Thanks,
>
> Jeff
>



-- 
*Jeff Hair*
Core Systems Developer

Tel: (+354) 415 0200
jeff@greenqloud.com
www.greenqloud.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message