cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From France <mailingli...@isg.si>
Subject CS 4.3.2 RPM builds have dependencies on i686 glibc?! while 4.3.1 do not.
Date Sun, 28 Jun 2015 13:43:29 GMT
Hi guys,

we are upgrading CS 4.3.1 to 4.3.2 currently.

Official repo listed on: https://cloudstack.apache.org/downloads.html which is: http://cloudstack.apt-get.eu/rhel/
is currently down.
I was able to find packages on some other mirror: http://mirrors.coreix.net/cloudstack.apt-get.eu/rhel/4.3/
just to test it out.
The below description is also true if, using repos from Shapeblue (http://packages.shapeblue.com/cloudstack/main/centos/4.3,
http://packages.shapeblue.com/cloudstack/main/centos/4.3/), which are currently working. We
will be installing from Shapeblues main repo.

After updating whole system, only CS was left. However I see that it wants to pull i686 libraries!
It seems to me that there is an error in packaging process or. does CS upgrading from 4.3.1
to 4.3.2 suddenly require i686 glibc to work?

[root@mc1 yum.repos.d]# yum clean
Loaded plugins: fastestmirror, priorities
Error: clean requires an option: headers, packages, metadata, dbcache, plugins, expire-cache,
rpmdb, all
[root@mc1 yum.repos.d]# yum update
Loaded plugins: fastestmirror, priorities
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirror.lihnidos.org
 * epel: mirror.vutbr.cz
 * extras: mirror.lihnidos.org
 * updates: mirror.lihnidos.org
118 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package cloudstack-awsapi.x86_64 0:4.3.1-1.el6 will be updated
---> Package cloudstack-awsapi.x86_64 0:4.3.2-1.el6 will be an update
---> Package cloudstack-common.x86_64 0:4.3.1-1.el6 will be updated
---> Package cloudstack-common.x86_64 0:4.3.2-1.el6 will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: cloudstack-common-4.3.2-1.el6.x86_64
--> Processing Dependency: libuuid.so.1 for package: cloudstack-common-4.3.2-1.el6.x86_64
---> Package cloudstack-management.x86_64 0:4.3.1-1.el6 will be updated
---> Package cloudstack-management.x86_64 0:4.3.2-1.el6 will be an update
---> Package cloudstack-usage.x86_64 0:4.3.1-1.el6 will be updated
---> Package cloudstack-usage.x86_64 0:4.3.2-1.el6 will be an update
--> Running transaction check
---> Package glibc.i686 0:2.12-1.149.el6_6.9 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.149.el6_6.9.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.149.el6_6.9.i686
---> Package libuuid.i686 0:2.17.2-12.18.el6 will be installed
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.14.3-22.el6_6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================================================
 Package                                            Arch                                Version
                                           Repository                                    
 Size
================================================================================================================================================================================================
Updating:
 cloudstack-awsapi                                  x86_64                              4.3.2-1.el6
                                       apache-cloudstack                               84
M
 cloudstack-common                                  x86_64                              4.3.2-1.el6
                                       apache-cloudstack                               94
M
 cloudstack-management                              x86_64                              4.3.2-1.el6
                                       apache-cloudstack                               75
M
 cloudstack-usage                                   x86_64                              4.3.2-1.el6
                                       apache-cloudstack                               39
M
Installing for dependencies:
 glibc                                              i686                                2.12-1.149.el6_6.9
                                updates                                        4.3 M
 libuuid                                            i686                                2.17.2-12.18.el6
                                  base                                            69 k
 nss-softokn-freebl                                 i686                                3.14.3-22.el6_6
                                   updates                                        157 k

Transaction Summary
================================================================================================================================================================================================
Install       3 Package(s)
Upgrade       4 Package(s)

Total download size: 296 M
Is this ok [y/N]: 


Mime
View raw message