cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike C <mcrosson_cloudst...@nusku.net>
Subject Re: libvirt exception
Date Fri, 08 May 2015 20:22:56 GMT
On 2015-05-08 15:18, Remi Bergsma wrote:
> It mixes bridge/bond... How did you configure it? Can you post
> agent.properties and/or explain a bit about the setup you are using?
I've included a rough overview of my Ubuntu 14.04 network config(s) 
below. I followed the standard conventions in the CloudStack userguide 
for 4.3 and haven't updated it for 4.4. My understanding was it didn't 
need to change at all.

On 2015-05-08 15:22, Simon Weller wrote:
> Can you provide some data from the /var/log/libvirt/libvirtd log, and
> also your network configuration for both hosts? Also the contents of
> /etc/cloudstack/agent.properties would be useful.
I've included my network config, agent.properties and a chunk of the 
libvirtd log below.

===
= Source network cconfig
===
Management: mgmbr0 -> eth0
cloudbr0: bond0.1100 -> p1p1 p1p2
cloudbr1: bond0.1200 -> p1p1 p1p2
bond0: mode balance-alb


===
= Destination network config
===
Management: mgmtbr0 -> eth1
cloudbr0: eth0.1100
cloudbr1: eth0.1200


===
= Source agent.properties
===
# cat /etc/cloudstack/agent/agent.properties
#Storage
#Fri May 08 09:57:54 EDT 2015
guest.network.device=cloudbr1
workers=5
private.network.device=mgmtbr0
port=8250
resource=com.cloud.hypervisor.kvm.resource.LibvirtComputingResource
pod=1
zone=1
guid=b86fc0dc-1017-3776-a9a3-2775684a0c84
public.network.device=cloudbr0
cluster=1
local.storage.uuid=3dd4a3a3-2853-4f1d-b0f2-c028168ca81d
domr.scripts.dir=scripts/network/domr/kvm
LibvirtComputingResource.id=1
host=172.16.16.30

===
= Destination agent.properties
===
# cat /etc/cloudstack/agent/agent.properties
#Storage
#Fri May 08 09:55:57 EDT 2015
guest.network.device=cloudbr1
workers=5
private.network.device=mgmtbr0
port=8250
resource=com.cloud.hypervisor.kvm.resource.LibvirtComputingResource
pod=1
zone=1
guid=9a421209-fb8b-30ad-8304-95a4e33f3286
hypervisor.type=kvm
public.network.device=cloudbr0
cluster=1
local.storage.uuid=1d17ac0d-c94a-4490-87fd-714bf063572b
domr.scripts.dir=scripts/network/domr/kvm
LibvirtComputingResource.id=18
host=172.16.16.30

===
= libvirtd error (source)
===
The timestamps are off compared to the main cloudstack logs for some 
reason. The below are the only  log entries from 2015/05/08 that I see. 
I do have ntpd setup and working, the timestamps when logged in normally 
are accurate. I'm in EST for a TZ as a point of reference.
2015-05-08 13:56:26.695+0000: 20220: warning : qemuDomainObjTaint:1628 : 
Domain id=27 name='r-93-VM' uuid=5269e919-564a-4986-92c1-07464e99e3ce is 
tainted: high-privileges
2015-05-08 13:57:24.203+0000: 20217: warning : 
qemuMigrationCancelDriveMirror:1421 : Unable to stop block job on 
drive-ide0-0-0
2015-05-08 13:57:48.466+0000: 20216: error : virNetSocketReadWire:1454 : 
End of file while reading data: Input/output error
2015-05-08 13:57:48.466+0000: 20216: error : virNetSocketReadWire:1454 : 
End of file while reading data: Input/output error
2015-05-08 13:58:14.225+0000: 20221: warning : 
qemuMigrationCancelDriveMirror:1421 : Unable to stop block job on 
drive-ide0-0-0
2015-05-08 14:11:23.269+0000: 20216: error : qemuMonitorIO:656 : 
internal error: End of file from monitor
2015-05-08 19:05:14.093+0000: 20220: error : virNetDevGetMTU:397 : 
Cannot get interface MTU on 'breth0-1221': No such device
2015-05-08 19:06:04.043+0000: 20219: error : virNetDevGetMTU:397 : 
Cannot get interface MTU on 'breth0-1221': No such device


===
= libvirtd error (destination)
===
None found

Mime
View raw message