cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrija Panic <andrija.pa...@gmail.com>
Subject Re: Swift 2.x as Secondary Storage - auth v2 ?
Date Tue, 26 May 2015 12:57:07 GMT
Hi Pierre,

I understand the Xen limitations, we are here with KVM, and it seems most
of the problems I described, are actually results of our modification to
support v2 auth...

My comments/answer down below :)

On 26 May 2015 at 14:51, Pierre-Luc Dion <pdion@cloudops.com> wrote:

> Hi Andrija,
>
> Swift integration in cloudstack + XenServer require interaction from
> Xenserver to initiate connection to Swift proxies,  this is made using
> /etc/xapi.d/plugins/swiftxen which is a fairly old python script that only
> support Swift api V1.  I've tried to upgrade that script which seams to be
> a generic one from OpenStack, but the Python version running on XenServer
> Dom0 (XS 6.2) is too old to make the new script work :-S.  Maybe it would
> on XS 6.5 ?  I don't know if this would be easily fixed on KVM.
>
>
> and some correction inline...
>
>
>>>
>>> > Hi people,
>>> >
>>> > anyone using Swift as Region wide Secondary Storage with Swift 2.x,
>>> auth v
>>> > 2.0?
>>> >
>>> > We are rewriting auth scripts/making wraper, and changing systemVM
>>> template
>>> > to support v2 auth, and main download/register tempalte/iso works, but
>>> we
>>> > are hitting many other bugs, that we try to iron out as we speak, some
>>> of
>>> > them  as Pierre alreadyshared:
>>> > - Percentage indiction not working while register/download new
>>> ISO/Template
>>>
>> > - Cant download/extract template/ISO from ACS - by design
>>> > - Can't delete template/ISO (why are checking why...)
>>>
>>
> true only from UI, using the API  the zoneid must *not* be define and the
> UI query using the zoneid.
>
>
>> > - Cant create volume snapshots (we are checking why...)
>>>
>>
> it work, but it's slower then pure NFS, as the snapshot goes on the
> staging NFS then is upload into swift.
>

For us its broken, probably because we messed up with systemVM tempate and
v2 auth...

>
>
>> > - Cant download volume from Primary (we are checking why...)
>>>
>>
> you mean download button on the UI for a Data disk ?
>

Yes, download volume from UI... doesnt work.

>
>
>> > - Upload VOLUME doesn't work (we are checking why...)
>>>
>>
> Upload templates and iso into cloudstack does work, I suspect you are not
> refering to this.
>

Correct, templates and ISOs can be uploaded o ACS, but volumes not -
probably we broke this :)

>
>
>> >
>>> >
>>> > Any opinions/suggestions are most welcome :)
>>> >
>>> >
>>> > I know
>>> >
>>> > --
>>> >
>>> > Andrija Panić
>>> >
>>>
>>
>>
>>
>> --
>>
>> Andrija Panić
>>
>
>


-- 

Andrija Panić

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message