cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milamber <milam...@apache.org>
Subject Re: SystemVM (kvm) : 3 different versions for the same CloudStack version (4.5.1)
Date Mon, 25 May 2015 12:14:23 GMT


On 25/05/2015 11:56, Rohit Yadav wrote:
> Hi Milamber,
>
> In theory you should be able to use any of the systemvmtemplates and also from jenkins.buildacloud.org,
but the one I published on packages.shapeblue.com is the latest and has the few additional
improvements, latest packages and security updates.

Ok so it's better to use the shapeblue systemvm.


>
> I’ve tested this and it seems to have worked for me on Ubuntu 14.04 based host,

Debian 7 + backports enabled. It's works fine with CS 4.4 (probably I 
will re-install with Ubuntu 14.04.1)

>   can you share what is your KVM host like, distro, libvirt/qemu version and kernel version?

ipxe-qemu 1.0.0+git-20131111.c3d1e78-2.1~bpo70+1
libvirt-bin 1.2.9-9~bpo70+1
libvirt-clients 1.2.9-9~bpo70+1
libvirt-daemon 1.2.9-9~bpo70+1
libvirt-daemon-system 1.2.9-9~bpo70+1
libvirt0 1.2.9-9~bpo70+1
linux-image-3.2.0-4-amd64 3.2.68-1+deb7u1
linux-image-amd64 3.2+46
python-libvirt 1.2.1-2~bpo70+1
qemu-kvm 1:2.1+dfsg-12~bpo70+1
qemu-system-common 1:2.1+dfsg-12~bpo70+1
qemu-system-x86 1:2.1+dfsg-12~bpo70+1
qemu-utils 1:2.1+dfsg-12~bpo70+1



> Was the host Intel-VT or AMD-V enabled, or was it virtualized (KVM on KVM/Xen/VMWare)?

Intel-VT
model name    : Intel(R) Core(TM)2 Duo CPU     P8700  @ 2.53GHz
flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca 
cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall 
nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni 
dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave 
lahf_lm ida dtherm tpr_shadow vnmi flexpriority



> What is the time and timezone on your host and if kvmclock was disable/enabled on the
kvm host?

Timezone : Africa/Casablanca

kvm clock NO
cat /sys/devices/system/clocksource/clocksource0/current_clocksource
hpet



>
> Lastly, can you also share if the SSVM gets stuck indefinitely or you did not wait that
long and decided to reboot it?

I decided to reboot after at least 10 minutes after the Cleaning message 
display on console (not reboot: don't work, virsh reset instance_name)


>
> Regarding the upgrade path, it does not matter really. Since you register 4.5 template
before upgrading the upgrade path would simply check if a systemvm template exists for currently
used unique hypervisors (it does that by checking for current hosts with distinct hypervisors
from cluster table). The checksums and URLs are in there for adding rows in the db in case
you decide to add a new hypervisor host and it needs to donwload a suitable template for that
new hypervisor. There are on-going discussion on improving the upgrade process so this issue
may be addressed in that.

Ok thanks for the explain.
Only "systemvm-kvm-4.5" in the template before the update is relevant.

Milamber


>
>> On 25-May-2015, at 9:13 am, Milamber <milamber@apache.org> wrote:
>>
>> Hello,
>>
>> There have 3 different versions of the SystemVM image for CloudStack 4.5.1 (for KVM,
but I assumed that concerns other hypervisors)
>>
>> 1/ shapeblue.com version on Upgrade 4.5.1 from 4.4 page [1]
>>
>> 2/ apt-get.eu version on Installation Management Server Page [2]
>>
>> 3/ cloud.com version in com.cloud.upgrade.dao.Upgrade442to450 class [3] (Used for
the upgrade process from 4.4.2-3 to 4.5.1)
>>
>> The checksums are different:
>> 1 - 5b6d9f276bc1faf50d2fe839c3c7dc5a systemvm64template-4.5-kvm.qcow2.bz2
>> 2 - c3f5d60fbc4a6af7e85c94bb776f2778 systemvm64template-4.5-kvm.qcow2.bz2
>> 3 - aa9f501fecd3de1daeb9e2f357f6f002 systemvm64template-4.5-kvm.qcow2.bz2
>>
>> The date/size (of the Qcow2 inside) too:
>> 1 - -rw-r--r-- 1 milamber milamber 312669696 May    5 01:40 systemvm64template-4.5-kvm.qcow2
>> 2 - -rw-r--r-- 1 milamber milamber 303972352 Mar   7 12:21 systemvm64template-4.5-kvm.qcow2
>> 3 - -rw-r--r-- 1 milamber milamber 305387008 Sep  4  2014 systemvm64template-4.5-kvm.qcow2
>>
>>
>> I'm not sure if that's relevant, but yesterday, my upgrade from 4.4.3 to 4.5.1 is
failed when I would re-create a virtual router (using the cloud.com version). I have tried
to recreate SSVM and CPVM without success too)
>> (Installation type: Adv Network without SG)
>>
>> I made a re-installation of my test platform with a fresh 4.5.1 version with shapeblue
version (more recent), failed too on the start of SSVM (blocked on "Cleaning up temporary
files..."), after 1 manual VM reset, the SSVM started, but the first VR have the same problem
and the reset don't work like the SSVM.
>> (Installation type: Adv Network with SG)
>>
>> I made another re-installation of the test platform with a fresh 4.5.1 with apt-get.eu
version. OK for SSVM but need to do 1 reset for the first VR (and the second VR too).
>> (Installation type: Adv Network without SG)
>>
>>
>> That is relevant?
>>
>> What is the good version?
>>
>> That is a bug for the freeze on "Cleaning up temporary files"?
>>
>> Why the Systemvm checksum is hard-coded in the class? If I had make my upgrade with
the shapeblue or apt-get.eu version I think an error will be occur on Upgrade process?
>>
>>
>> Milamber
>>
>> ====
>> [1] http://docs.cloudstack.apache.org/projects/cloudstack-release-notes/en/4.5.1/upgrade/upgrade-4.4.html#update-system-vm-templates
>> [2] http://docs.cloudstack.apache.org/projects/cloudstack-installation/en/4.5/management-server/index.html#prepare-the-system-vm-template
>> [3] https://github.com/apache/cloudstack/blob/master/engine/schema/src/com/cloud/upgrade/dao/Upgrade442to450.java#L229
>>
>>
>>
>>
> Regards,
> Rohit Yadav
> Software Architect, ShapeBlue
> M. +91 88 262 30892 | rohit.yadav@shapeblue.com
> Blog: bhaisaab.org | Twitter: @_bhaisaab
>
>
>
> Find out more about ShapeBlue and our range of CloudStack related services
>
> IaaS Cloud Design & Build<http://shapeblue.com/iaas-cloud-design-and-build//>
> CSForge – rapid IaaS deployment framework<http://shapeblue.com/csforge/>
> CloudStack Consulting<http://shapeblue.com/cloudstack-consultancy/>
> CloudStack Software Engineering<http://shapeblue.com/cloudstack-software-engineering/>
> CloudStack Infrastructure Support<http://shapeblue.com/cloudstack-infrastructure-support/>
> CloudStack Bootcamp Training Courses<http://shapeblue.com/cloudstack-training/>
>
> This email and any attachments to it may be confidential and are intended solely for
the use of the individual to whom it is addressed. Any views or opinions expressed are solely
those of the author and do not necessarily represent those of Shape Blue Ltd or related companies.
If you are not the intended recipient of this email, you must neither take any action based
upon its contents, nor copy or show it to anyone. Please contact the sender if you believe
you have received this email in error. Shape Blue Ltd is a company incorporated in England
& Wales. ShapeBlue Services India LLP is a company incorporated in India and is operated
under license from Shape Blue Ltd. Shape Blue Brasil Consultoria Ltda is a company incorporated
in Brasil and is operated under license from Shape Blue Ltd. ShapeBlue SA Pty Ltd is a company
registered by The Republic of South Africa and is traded under license from Shape Blue Ltd.
ShapeBlue is a registered trademark.



Mime
View raw message