cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remi Bergsma <r...@remi.nl>
Subject Re: Cloustack packaging
Date Sun, 26 Apr 2015 14:11:12 GMT
Hi Rafael,

Welcome to CloudStack and thanks for your mail.

What RPM packages did you use for your testing?
From my personal experience I know that the CentOS7 (el7) packages for CloudStack 4.4 work
just fine as a KVM hypervisor (on CentOS 7.1). In 4.5 work is done to also make it work as
a Management server. So, what exact problems do you run into when installing the RPM’s on
CentOS 7.1?

As far as I know, the centos7-rpm branch is old and no longer maintained. I’d recommend
using the 4.5 and/or master branches instead, as these are most up to date and actively maintained.


Feel free to send a PR to fix what you think is broken.

Regards,
Remi


> On 26 Apr 2015, at 15:30 , Rafael Fonseca <rsafonseca@gmail.com> wrote:
> 
> Hi all,
> 
> I'm new to the cloudstack community, but i'm a seasoned developer and
> systems engineer and i'm sure i'll be able to help out a lot :)
> 
> I've just started on getting cloudstack running on Centos 7.1 and noticed
> many problems, which make it NOT work out of the box.
> 
> I'll be doing a series of fixes and submitting the code for review, since
> i'm not a commiter yet, if no one else is working on this.
> 
> I've seen that there's a branch called centos7-rpm which is already merged
> with master, but there hasn't been any activity on that on the last six
> months, so i guess it's currently stale.
> 
> Perhaps some of these things that i spotted were working on 7.0, but i
> haven't tested it out on that version yet.. ideally we can make specs that
> work on ANY 7.x version and not have a spec file for every minor release.
> 
> One of the things i immediately noticed (that is present in all
> centos/fedora specs, not just centos7) is the following:
> 
> %define __os_install_post %{nil}
> %global debug_package %{nil}
> 
> # DISABLE the post-percentinstall java repacking and line number stripping
> # we need to find a way to just disable the java repacking and line number
> stripping, but not the autodeps
> 
> 
> It's easy enough to get the __os_install_post to only do that, but it
> shouldn't be disabling autodeps.. rather the rpmbuild's dependency routines
> can't find any required external libs in the java or python files :)
> 
> Replace:
> 
> %define __os_install_post %{nil}
> 
> with:
> 
> %define __jar_repack %{nil}
> %define __debug_package %{nil}
> 
> That will do it, as checked in "rpm --showrc", although there won't be much
> to be gained with it.
> 
> -14: __os_install_post
>    /usr/lib/rpm/redhat/brp-compress
>    %{!?__debug_package:
>    /usr/lib/rpm/redhat/brp-strip %{__strip}
>    /usr/lib/rpm/redhat/brp-strip-comment-note %{__strip} %{__objdump}
>    }
>    /usr/lib/rpm/redhat/brp-strip-static-archive %{__strip}
>    /usr/lib/rpm/brp-python-bytecompile %{__python}
> %{?_python_bytecompile_errors_terminate_build}
>    /usr/lib/rpm/redhat/brp-python-hardlink
>    %{!?__jar_repack:/usr/lib/rpm/redhat/brp-java-repack-jars}
> %{nil}


Mime
View raw message