cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anshul Gangwar <>
Subject Re: Question regarding VM snapshot restrictions
Date Tue, 28 Apr 2015 08:32:45 GMT
Hi Jan-Arve,

In which order have you tried adding vCPUs and NICs?
i.e. After creating VM snapshot or before creating snapshot.
And have you deleted VM snapshots before adding vCPUs and NICs?


On 24-Apr-2015, at 5:58 pm, Jan-Arve Nygård <<>>


With 4.5 there are some restrictions applied to VMs that have VM snapshots.
According to CLOUDSTACK-7688
<> VM snapshot stops
working when the following operations are performed on VM with VM snapshots:

1. Volumes of VM are migrated to other storage
2. Add and remove NIC to/from VM
3. Attach and Detach volume to VM
4. Scale up/down of VM(change service offering)
5. Volume snapshot which is not major use case in this scenario
6. Resize volume
7. Live migration of VM which involves storage migration

Does anyone have more technical details about why this is restricted?

I tried some quick tests with XenServer 6.5 and CS 4.5.1 and I was able to
both revert and take VM snapshots in CloudStack while adding vCPU and NICs
on the hypervisor.



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message