cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@shapeblue.com>
Subject Re: [SOLVED] No response received when trying to login
Date Mon, 20 Apr 2015 07:29:25 GMT
This is a known issue with ACS 4.3, where ACS becomes unresponsive/stuck if RabbitMQ is not
running or if both RMQ broker and ACS plugin are not correctly configured.

I’m not sure about 4.4, but with 4.5+ in case RabbitMQ server is not running or the plugin
is not correctly configured, ACS will add error logs that it was unable to publish events
on the event bus (rabbitmq).

> On 17-Apr-2015, at 2:08 am, Yiping Zhang <yzhang@marketo.com> wrote:
>
> I am using RabbitMQ feature,  and I did notice that the UI become
> noticeably slower for some operations, such as VM create / destroy actions.
> When the RabbitMQ server is down, the login process become unresponsive.
>
> Yiping
>
> On 4/16/15, 3:42 AM, "Erik Weber" <terbolous@gmail.com> wrote:
>
>> Since I don't really use the feature, but merely tested it, I removed the
>> rabbitmq bean I previously set up.
>>
>> I guess the proper solution is to figure out why rabbitmq barks, probably
>> due to something being full..
>>
>> --
>> Erik
>>
>> On Thu, Apr 16, 2015 at 12:40 PM, Nux! <nux@li.nux.ro> wrote:
>>
>>> Erik,
>>>
>>> Can you share more details about how you solved this? What did you have
>>> to
>>> do exactly?
>>>
>>> Just thinking it may come it handy to some poor soul in the future.
>>>
>>> --
>>> Sent from the Delta quadrant using Borg technology!
>>>
>>> Nux!
>>> www.nux.ro
>>>
>>> ----- Original Message -----
>>>> From: "Erik Weber" <terbolous@gmail.com>
>>>> To: "dev" <dev@cloudstack.apache.org>, users@cloudstack.apache.org
>>>> Sent: Thursday, 16 April, 2015 10:27:16
>>>> Subject: Re: [SOLVED] No response received when trying to login
>>>
>>>> Thank you Rajani, it was rabbitmq problems.
>>>>
>>>> All solved, and I can log in again :-)
>>>>
>>>> --
>>>> Erik
>>>>
>>>> On Thu, Apr 16, 2015 at 10:54 AM, Rajani Karuturi <rajani@apache.org>
>>> wrote:
>>>>
>>>>> If you configured RabbitMQ service, check logs on the Rabbitmq hosts.
>>>>>
>>>>> check the size of the events table and see if an insert is taking
>>> time.
>>> You
>>>>> could try the login and then show full processlist at the mysql
>>> prompt
>>> to
>>>>> see any slow queries.
>>>>>
>>>>>
>>>>> ~Rajani
>>>>>
>>>>> On Thu, Apr 16, 2015 at 1:57 PM, Erik Weber <terbolous@gmail.com>
>>> wrote:
>>>>>
>>>>>> On Thu, Apr 16, 2015 at 10:21 AM, Rajani Karuturi
>>> <rajani@apache.org>
>>>>>> wrote:
>>>>>>
>>>>>>> Can you check if its blocked on raising the login event? probably
>>>>>> activemq
>>>>>>> is down or the events table is full..
>>>>>>>
>>>>>>>
>>>>>> Thanks for the suggestion, how would I go forward to check that?
>>>>>>
>>>>>> I've restarted cloudstack-management multiple times if it matters.
>>>>>>
>>>>>> --
>>>>>> Erik
>>>>>>
>>>
>

Regards,
Rohit Yadav
Software Architect, ShapeBlue
M. +91 88 262 30892 | rohit.yadav@shapeblue.com
Blog: bhaisaab.org | Twitter: @_bhaisaab



Find out more about ShapeBlue and our range of CloudStack related services

IaaS Cloud Design & Build<http://shapeblue.com/iaas-cloud-design-and-build//>
CSForge – rapid IaaS deployment framework<http://shapeblue.com/csforge/>
CloudStack Consulting<http://shapeblue.com/cloudstack-consultancy/>
CloudStack Software Engineering<http://shapeblue.com/cloudstack-software-engineering/>
CloudStack Infrastructure Support<http://shapeblue.com/cloudstack-infrastructure-support/>
CloudStack Bootcamp Training Courses<http://shapeblue.com/cloudstack-training/>

This email and any attachments to it may be confidential and are intended solely for the use
of the individual to whom it is addressed. Any views or opinions expressed are solely those
of the author and do not necessarily represent those of Shape Blue Ltd or related companies.
If you are not the intended recipient of this email, you must neither take any action based
upon its contents, nor copy or show it to anyone. Please contact the sender if you believe
you have received this email in error. Shape Blue Ltd is a company incorporated in England
& Wales. ShapeBlue Services India LLP is a company incorporated in India and is operated
under license from Shape Blue Ltd. Shape Blue Brasil Consultoria Ltda is a company incorporated
in Brasil and is operated under license from Shape Blue Ltd. ShapeBlue SA Pty Ltd is a company
registered by The Republic of South Africa and is traded under license from Shape Blue Ltd.
ShapeBlue is a registered trademark.
Mime
View raw message