cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Praveen B <pbprave...@gmail.com>
Subject Re: API: listUsageRecords
Date Sun, 05 Apr 2015 02:53:24 GMT
Hi Ramzi,

A couple of checks for troubleshooting your usage data issue
    1) Check whether  usage data is generated for the selective range
            - You can validate this by going through usage log located in
/var/log/cloudstack/usage/usage.log file OR check data in usage
               DB tables. To make it simple, always check for latest data.

    2) If you have an other cloudstack instance, execute same API call on
it to confirm whether API parameters are correct or not.
        I am not sure about simulator whether it can generate and show
usage data or not. Give us the API call that you used.

listUsageRecords API is programmed in a way that it can be executed by only
admins. Users may not be able to execute it.
Since you are calling this API through billing module, can you try to use
admin's keys for all users in the code and see if normal users also can
list usage data?

Thanks,
Praveen

On Sun, Apr 5, 2015 at 1:31 AM, Ramzi Youssefi <ryoussefi@gmail.com> wrote:

> Hello dear developers,
>
> I'm developing a billing module for Cloudstack and I'm having troubles in
> two points:
> 1.- When I call the API I just a receive a response without data (maybe
> because I'm using the simulator?). Maybe I'm using the wrong call?
> (startdate and enddate are set)
>
> 2.- The idea is that the client can query their usage data but the API
> won't work for users. Only root and domain admin. Is there any way to make
> possible that the users can call the API?
>
> Thanks for your help!
> --
> Ramzi Youssefi
> Görlitzer Str. 49
> 01099 Dresden, Germany.
> Cell: +49 173 1965465
> Email: ryoussefi@gmail.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message