cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cs user <acldstk...@gmail.com>
Subject Re: Simulator failing
Date Thu, 02 Apr 2015 14:29:26 GMT
Fix for this was to use this command:

mvn -P simulator -pl :cloud-client-ui jetty:run

And not:

mvn -pl :cloud-client-ui jetty:run





On Thu, Apr 2, 2015 at 2:42 PM, cs user <acldstkusr@gmail.com> wrote:

> Hi All,
>
> I'm trying to run the simulator, I've tried with git tags 4.3, 4.3.2 and
> 4.4.1.
>
> Each time I hit this error when adding a cluster. Adding a zone and pod
> work fine.
>
> ==== Deploy DC Started ====
> Exception Occurred ['Traceback (most recent call last):\n', '  File
> "marvin/deployDataCenter.py", line 185, in createClusters\n
>  clusterresponse = self.__apiClient.addCluster(clustercmd)\n', '  File
> "/usr/lib/python2.6/site-packages/Marvin-4.4.1-py2.6.egg/marvin/cloudstackAPI/cloudstackAPIClient.py",
> line 1506, in addCluster\n    response =
> self.connection.marvinRequest(command, response_type=response,
> method=method)\n', '  File
> "/usr/lib/python2.6/site-packages/Marvin-4.4.1-py2.6.egg/marvin/cloudstackConnection.py",
> line 378, in marvinRequest\n    raise e\n', 'CloudstackAPIException:
> Execute cmd: addcluster failed, due to: errorCode: 431, errorText:Could not
> find corresponding resource manager for simulator\n']
>
> ===deploy dc failed, so cleaning the created entries===
>
> Specifically :
> errorCode: 431, errorText:Could not find corresponding resource manager
> for simulator
>
> Has anyone seen this before? Is there a fix?
>
> This thread talks about commenting out references to simulator in
> componentContext.xml
>
>
> http://mail-archives.apache.org/mod_mbox/incubator-cloudstack-dev/201302.mbox/%3C97F4356AEA71904482CD192135C038F9011CC1D12FB5@BANPMAILBOX01.citrite.net%3E
>
> But I've checked in there and I can't see any references.
>
> Cheers
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message