cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Tutkowski <mike.tutkow...@solidfire.com>
Subject Re: [4.6] Trouble with virtual router
Date Thu, 30 Apr 2015 05:24:25 GMT
Thanks for your comments, everyone.

So, it looks like I got it to work. I logged in and then immediately
restarted networking services.

/etc/init.d/networking restart

Once I did that, I ran ifconfig and saw that the VR had the necessary IP
addresses and I was able to successfully ping the CS MS.

Seems like something is wrong here that I needed to do this.

Should I open a ticket for this?

On Wed, Apr 29, 2015 at 1:51 PM, Marcus <shadowsor@gmail.com> wrote:

> Log into the vm and look at the /var/log/cloud.log. It might be that
> the agent isn't starting (e.g. you require non-oss build but have oss
> build, and agent fails to find PremiumSecondaryStorageResource or
> whatever)
>
> On Wed, Apr 29, 2015 at 12:36 PM, Mike Tutkowski
> <mike.tutkowski@solidfire.com> wrote:
> > Hey Wilder,
> >
> > Thanks for the reply.
> >
> > I was wondering if you could point me to the system VM template that you
> > used?
> >
> > This is what I used and am having trouble with:
> >
> >
> http://jenkins.buildacloud.org/job/build-systemvm64-master/lastSuccessfulBuild/artifact/tools/appliance/dist/systemvm64template-master-4.6.0-xen.vhd.bz2
> >
> > Thanks!
> > Mike
> >
> > On Wed, Apr 29, 2015 at 6:12 AM, Wilder Rodrigues <
> > WRodrigues@schubergphilis.com> wrote:
> >
> >> Hi Mike,
> >>
> >> I just built, deploy and created isolated network, VPC and VMS using
> >> latest master (4.6.0). I put some screenshots on imgur:
> >> http://imgur.com/a/OmSyy.
> >>
> >> In addition, I created FW + PF rules and SSH (using the routers’ pub ip)
> >> to the VM:
> >>
> >> [wrodrigues@mct-wrodrigues ~]$ ssh root@192.168.22.52<mailto:
> >> root@192.168.22.52>
> >> root@192.168.22.52<mailto:root@192.168.22.52>'s password:
> >> %
> >> %
> >> % ls
> >> ssh-host-dss-key.pub  ssh-host-rsa-key.pub
> >> % uname -a
> >> Linux ttylinux_host 2.6.32-5-686-bigmem #1 SMP Mon Jun 13 05:03:09 UTC
> >> 2011 i686 unknown
> >> %
> >>
> >> Could you please share your XenServer SMlog with us?
> >>
> >> Cheers,
> >> Wilder
> >>
> >> On 29 Apr 2015, at 08:23, Erik Weber <terbolous@gmail.com<mailto:
> >> terbolous@gmail.com>> wrote:
> >>
> >> Anything in /var/log/cloud.log?
> >>
> >> --
> >> Erik
> >>
> >> On Tue, Apr 28, 2015 at 11:58 PM, Mike Tutkowski <
> >> mike.tutkowski@solidfire.com<mailto:mike.tutkowski@solidfire.com>>
> wrote:
> >>
> >> Unfortunately I'm not able to make out any errors on the console.
> >>
> >> Is there something within the VM's OS that I can look at to debug this?
> >>
> >> I see that SSVM and CPVM have IP addresses, but the VR does not.
> >>
> >> Any hints would be great as unfortunately I had to postpone a CloudStack
> >> demo for a potential customer today due to this issue.
> >>
> >> Thanks!
> >>
> >> On Tue, Apr 28, 2015 at 4:24 AM, Sanjeev N <sanjeev@apache.org<mailto:
> >> sanjeev@apache.org>> wrote:
> >>
> >> One of the reasons for VR not to come up is, once CS creates VR on
> >> hypervisor, it does a ping on VR's management interface for centain
> no.of
> >> of times. If it does not receive any response then it will shut down the
> >> VR.
> >>
> >> So when VR is coming up check its console and see any network issues.
> >>
> >> On Tue, Apr 28, 2015 at 12:39 PM, Mike Tutkowski <
> >> mike.tutkowski@solidfire.com<mailto:mike.tutkowski@solidfire.com>>
> wrote:
> >>
> >> Huh...it doesn't work on KVM either (this is on Ubuntu 14.04). The
> >> failure
> >> is a bit different, though. In this case, the SSVM stays in the Running
> >> state, but the agent doesn't seem to ever come up.
> >>
> >> Oh well...I guess I'll try ESXi later.
> >>
> >> On Mon, Apr 27, 2015 at 11:45 PM, Mike Tutkowski <
> >> mike.tutkowski@solidfire.com<mailto:mike.tutkowski@solidfire.com>>
> wrote:
> >>
> >> Thanks for the message, Abhi.
> >>
> >> I went ahead and deleted the host tag from each of my XenServer hosts
> >> (it's a new environment, so I only had one host tag per host). I then
> >> performed a force reconnect on each host.
> >>
> >> Unfortunately, I still seem to be encountering the same issue (even
> >> after
> >> destroying and re-creating the VR). This seems broken on both
> >> XenServer
> >> 6.2
> >> and XenServer 6.1.
> >>
> >> I think I will give it a try with ESXi 5.1 or KVM. I'm mainly
> >> interested
> >> in dealing with XenServer (for the time being) for this particular
> >> feature
> >> I'm working on, but perhaps I can at least get the system VMs up and
> >> running on another hypervisor to allow me to move forward.
> >>
> >> On Mon, Apr 27, 2015 at 11:23 PM, Abhinandan Prateek <
> >> abhinandan.prateek@shapeblue.com<mailto:
> abhinandan.prateek@shapeblue.com>>
> >> wrote:
> >>
> >> Had similar problem where SSVM and CPVM came up but not the VR.
> >> In my case I traced it to systemvm.iso not getting updated on
> >> XenServer,
> >> due to the old host-tag.
> >> On deleting the host tag the MS was able to copy the systemvm.iso to
> >> Xen
> >> and things were fine after that.
> >>
> >> -abhi
> >>
> >>
> >> On 28-Apr-2015, at 10:15 am, Mike Tutkowski <
> >> mike.tutkowski@solidfire.com<mailto:mike.tutkowski@solidfire.com>>
> wrote:
> >>
> >> Hi,
> >>
> >> Tonight I tried to re-create a cloud from scratch and made use of
> >> the
> >> following system template:
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> http://jenkins.buildacloud.org/job/build-systemvm64-master/lastSuccessfulBuild/artifact/tools/appliance/dist/systemvm64template-master-4.6.0-xen.vhd.bz2
> >>
> >> My SSVM and CPVM get IP addresses and seem to behave OK; however,
> >> my
> >> VR
> >> never gets into the Running state. It gets to a point and then is
> >> restarted
> >> (this happens a couple times). Eventually CS gives up on it.
> >>
> >> I only have two XenServer 6.2 hosts in this environment. The
> >> system
> >> VMs
> >> are
> >> running on local storage.
> >>
> >> Thoughts on this?
> >>
> >> Thanks!
> >>
> >> --
> >> *Mike Tutkowski*
> >> *Senior CloudStack Developer, SolidFire Inc.*
> >> e: mike.tutkowski@solidfire.com
> >> o: 303.746.7302
> >> Advancing the way the world uses the cloud
> >> <http://solidfire.com/solution/overview/?video=play>*™*
> >>
> >> Find out more about ShapeBlue and our range of CloudStack related
> >> services
> >>
> >> IaaS Cloud Design & Build<
> >> http://shapeblue.com/iaas-cloud-design-and-build//>
> >> CSForge – rapid IaaS deployment framework<
> >> http://shapeblue.com/csforge/
> >>
> >> CloudStack Consulting<http://shapeblue.com/cloudstack-consultancy/>
> >> CloudStack Software Engineering<
> >> http://shapeblue.com/cloudstack-software-engineering/>
> >> CloudStack Infrastructure Support<
> >> http://shapeblue.com/cloudstack-infrastructure-support/>
> >> CloudStack Bootcamp Training Courses<
> >> http://shapeblue.com/cloudstack-training/>
> >>
> >> This email and any attachments to it may be confidential and are
> >> intended
> >> solely for the use of the individual to whom it is addressed. Any
> >> views
> >> or
> >> opinions expressed are solely those of the author and do not
> >> necessarily
> >> represent those of Shape Blue Ltd or related companies. If you are
> >> not
> >> the
> >> intended recipient of this email, you must neither take any action
> >> based
> >> upon its contents, nor copy or show it to anyone. Please contact the
> >> sender
> >> if you believe you have received this email in error. Shape Blue Ltd
> >> is
> >> a
> >> company incorporated in England & Wales. ShapeBlue Services India
> >> LLP
> >> is a
> >> company incorporated in India and is operated under license from
> >> Shape
> >> Blue
> >> Ltd. Shape Blue Brasil Consultoria Ltda is a company incorporated in
> >> Brasil
> >> and is operated under license from Shape Blue Ltd. ShapeBlue SA Pty
> >> Ltd
> >> is
> >> a company registered by The Republic of South Africa and is traded
> >> under
> >> license from Shape Blue Ltd. ShapeBlue is a registered trademark.
> >>
> >>
> >>
> >>
> >> --
> >> *Mike Tutkowski*
> >> *Senior CloudStack Developer, SolidFire Inc.*
> >> e: mike.tutkowski@solidfire.com
> >> o: 303.746.7302
> >> Advancing the way the world uses the cloud
> >> <http://solidfire.com/solution/overview/?video=play>*™*
> >>
> >>
> >>
> >>
> >> --
> >> *Mike Tutkowski*
> >> *Senior CloudStack Developer, SolidFire Inc.*
> >> e: mike.tutkowski@solidfire.com
> >> o: 303.746.7302
> >> Advancing the way the world uses the cloud
> >> <http://solidfire.com/solution/overview/?video=play>*™*
> >>
> >>
> >>
> >>
> >>
> >> --
> >> *Mike Tutkowski*
> >> *Senior CloudStack Developer, SolidFire Inc.*
> >> e: mike.tutkowski@solidfire.com
> >> o: 303.746.7302
> >> Advancing the way the world uses the cloud
> >> <http://solidfire.com/solution/overview/?video=play>*™*
> >>
> >>
> >>
> >
> >
> > --
> > *Mike Tutkowski*
> > *Senior CloudStack Developer, SolidFire Inc.*
> > e: mike.tutkowski@solidfire.com
> > o: 303.746.7302
> > Advancing the way the world uses the cloud
> > <http://solidfire.com/solution/overview/?video=play>*™*
>



-- 
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the cloud
<http://solidfire.com/solution/overview/?video=play>*™*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message