cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anshul Gangwar <anshul.gang...@citrix.com>
Subject Re: Question regarding VM snapshot restrictions
Date Tue, 28 Apr 2015 10:16:10 GMT
These restrictions are not there due to Hypervisor limitations. These limitations are due to
way this feature is implemented in CloudStack.
If we allow those operation then they may work fine but in long run they may lead to corruption
of VM etc. So to avoid those situation these restrictions are added till we we figure out
the better way.

Regards,
Anshul

On 28-Apr-2015, at 3:27 pm, Jan-Arve Nygård <jan.arve.nygard@gmail.com<mailto:jan.arve.nygard@gmail.com>>
wrote:

Thanks Anshul,

I did a quick test with adding vCPU and NIC in XenCenter after creating a
snapshot through CloudStack. I also tried reverting the VM to the snapshots
afterwards with the vCPU and NIC still added, and it worked OK.

This made curious about what the background and details for this patch is.
If it's specific to any hypervisor/version and maybe is fixed in XenServer
6.5?

If you have some more details about why this was patched I could maybe help
about with testing this with XenServer 6.5.


-thinktwo

2015-04-28 10:32 GMT+02:00 Anshul Gangwar <anshul.gangwar@citrix.com<mailto:anshul.gangwar@citrix.com>>:

Hi Jan-Arve,

In which order have you tried adding vCPUs and NICs?
i.e. After creating VM snapshot or before creating snapshot.
And have you deleted VM snapshots before adding vCPUs and NICs?

Regards,
Anshul

On 24-Apr-2015, at 5:58 pm, Jan-Arve Nygård <jan.arve.nygard@gmail.com<mailto:jan.arve.nygard@gmail.com>
<mailto:jan.arve.nygard@gmail.com>> wrote:

Hi,

With 4.5 there are some restrictions applied to VMs that have VM snapshots.
According to CLOUDSTACK-7688
<https://issues.apache.org/jira/browse/CLOUDSTACK-7688> VM snapshot stops
working when the following operations are performed on VM with VM
snapshots:

1. Volumes of VM are migrated to other storage
2. Add and remove NIC to/from VM
3. Attach and Detach volume to VM
4. Scale up/down of VM(change service offering)
5. Volume snapshot which is not major use case in this scenario
6. Resize volume
7. Live migration of VM which involves storage migration

Does anyone have more technical details about why this is restricted?

I tried some quick tests with XenServer 6.5 and CS 4.5.1 and I was able to
both revert and take VM snapshots in CloudStack while adding vCPU and NICs
on the hypervisor.

Thanks,

-thinktwo



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message