cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Weller <swel...@ena.com>
Subject Re: Compute offering Host tag
Date Tue, 07 Apr 2015 16:22:18 GMT
ok, well I thought we were using multiple host tags, but it doesn't appear we are.
I just tested this on a 4.3 system, and I'm seeing the same result as you. 
If the service offering has multiple host tags, it seems the allocator is trying to match
the entire string, rather than the individual tags.

http://pastebin.com/wSrnXLED

- Si


________________________________________
From: Erik Weber <terbolous@gmail.com>
Sent: Tuesday, April 07, 2015 8:53 AM
To: dev
Subject: Re: Compute offering Host tag

On Tue, Apr 7, 2015 at 3:34 PM, Simon Weller <sweller@ena.com> wrote:

> Erik,
>
> Is there something in particular you can point to that demonstrates what
> you're seeing?
> I have a few compute offerings that have multiple host tags separate by
> commas.
>
>
I've tried the same.. Should mention that this is on the 4.5 branch

Log: http://pastebin.com/ug08Vhvc (see line 16)

List serviceofferings (filter=id,hosttags): http://pastebin.com/7qzbZfh1
List hosts (filter=id,hosttags): http://pastebin.com/8dp2wNpN

The one where I use underscore (ndla_h3) works as expected, however if I
try to use any of the service offerings with more than one host tag it
fails.

--
Erik

Mime
View raw message