cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Star Guo" <st...@ceph.me>
Subject Re: Compile CloudStack 4.4.2
Date Mon, 09 Mar 2015 08:56:55 GMT
Thanks, I run as bellow:

" mvn install:install-file -Dfile=libvirt-0.5.1.jar -DpomFile=libvirt-0.5.1.pom.xml -DgroupId=org.libvirt
-DartifactId=libvirt -Dversion=0.5.1 -Dpackaging=jar -DgeneratePom=true"

And Compile is OK. My Maven version is " Apache Maven 3.0.5" .

Best Regards,
Star Guo

-----邮件原件-----
发件人: Rajani Karuturi [mailto:rajani@apache.org] 
发送时间: 2015年3月9日 14:42
收件人: dev@cloudstack.apache.org
主题: Re: Compile CloudStack 4.4.2

can you manually download the jar and pom, install to mvn repo and try?

mvn install:install-file -Dfile=jar/location/libvirt-0.5.1.jar
-DpomFile=pom/location/pom.xml -DgroupId=org.libvirt -DartifactId=libvirt
-Dversion=0.5.1 -Dpackaging=jar -DgeneratePom=true


http://maven.apache.org/plugins/maven-install-plugin/examples/specific-local-repo.html


~Rajani

On Mon, Mar 9, 2015 at 10:21 AM, Star Guo <starg@ceph.me> wrote:

> Hi, Laszlo,
>
> Thanks for your reply. However, follow this commit, I even not solve 
> this issue.
> "
> [INFO]
> [INFO] --- maven-jar-plugin:2.4:jar (default-jar) @ 
> cloud-plugin-hypervisor-xen --- [INFO] Building jar:
> /root/test/gci-cloud-apple-2015-03-06/plugins/hypervisors/xen/target/c
> loud-plugin-hypervisor-xen-4.4.3-SNAPSHOT.jar
> [INFO]
> [INFO] --- maven-site-plugin:3.3:attach-descriptor (attach-descriptor) 
> @ cloud-plugin-hypervisor-xen --- [INFO] [INFO]
> ----------------------------------------------------------------------
> -- [INFO] Building Apache CloudStack Plugin - Hypervisor KVM 
> 4.4.3-SNAPSHOT [INFO]
> ----------------------------------------------------------------------
> --
> Downloading:
> http://ceph.com/maven/org/libvirt/libvirt/0.5.1/libvirt-0.5.1.pom
> "
> Also hungs.
>
> Best Regards,
> Star Guo
>
> -----邮件原件-----
> 发件人: Laszlo Hornyak [mailto:laszlo.hornyak@gmail.com]
> 发送时间: 2015年3月7日 0:50
> 收件人: dev@cloudstack.apache.org
> 主题: Re: Compile CloudStack 4.4.2
>
> Star Guo, could you check if this solves your problem?
> https://github.com/apache/cloudstack/pull/100
>
> Thank you,
> Laszlo
>
> On Fri, Mar 6, 2015 at 6:56 AM, Star Guo <starg@ceph.me> wrote:
>
> > Hi,
> >
> > When I compile CloudStack 4.4.2 on CentOS 6.6 x86_64, and the log 
> > show as below and waiting for long time:
> >
> > ####################################################################
> > ##
> > #####
> > [INFO]
> > [INFO] --- maven-jar-plugin:2.5:jar (default-jar) @ 
> > cloud-plugin-hypervisor-xenserver --- [INFO] Building jar:
> >
> > /root/.hudson/jobs/cloudstack-master/workspace/plugins/hypervisors/x
> > en server 
> > /target/cloud-plugin-hypervisor-xenserver-4.6.0-SNAPSHOT.jar
> > [INFO]
> > [INFO] --- maven-site-plugin:3.3:attach-descriptor 
> > (attach-descriptor) @ cloud-plugin-hypervisor-xenserver --- [INFO]
> >
> > [INFO]
> > --------------------------------------------------------------------
> > --
> > -- [INFO] Building Apache CloudStack Plugin - Hypervisor KVM 
> > 4.6.0-SNAPSHOT [INFO]
> > --------------------------------------------------------------------
> > --
> > --
> > Downloading:
> > http://libvirt.org/maven2/joda-time/joda-time/maven-metadata.xml
> > Mar 06, 2015 1:47:47 PM
> >
> > org.apache.maven.wagon.providers.http.httpclient.impl.client.Default
> > Re
> > questD
> > irector tryExecute
> > INFO: I/O exception (java.net.SocketException) caught when 
> > processing
> > request: Connection reset
> > Mar 06, 2015 1:47:47 PM
> >
> > org.apache.maven.wagon.providers.http.httpclient.impl.client.Default
> > Re
> > questD
> > irector tryExecute
> > INFO: Retrying request
> >
> > Downloading:
> > http://libvirt.org/maven2/org/libvirt/libvirt/0.5.1/libvirt-0.5.1.po
> > m
> >
> > Downloading:
> > http://ceph.com/maven/org/libvirt/libvirt/0.5.1/libvirt-0.5.1.pom
> >
> > ####################################################################
> > ##
> > #####
> >
> > I find
> > http://libvirt.org/maven2/org/libvirt/libvirt/0.5.1/libvirt-0.5.1.po
> > m is not found, and 
> > http://libvirt.org/maven2/org/libvirt/libvirt/0.5.1/
> > is OK.
> > And 
> > http://ceph.com/maven/org/libvirt/libvirt/0.5.1/libvirt-0.5.1.pom
> > is not found.
> >
> > How to fix this problem ? Thanks.
> >
> > Best Regards
> > Star Guo
> >
> >
> >
>
>
> --
>
> EOF
>
>


Mime
View raw message