cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Tutkowski <mike.tutkow...@solidfire.com>
Subject Re: Major breakage in GUI after upgrade from 4.3.2 to 4.4.2
Date Mon, 02 Feb 2015 21:25:31 GMT
Hey Andrei,

Are you familiar with debugging in your web browser?

One thing you could try is to set a breakpoint in instanceWizard.js where
deployVirtualMachine is invoked and see what happens.

Talk to you later,
Mike

On Mon, Feb 2, 2015 at 2:16 PM, Andrei Mikhailovsky <andrei@arhont.com>
wrote:

> Mike, you are absolutely right, thanks! The delete function has been
> hidden under the Zones tab (in my version of GUI it is shown as
> "label.zones"). So, this one is sorted out.
>
> Now, I wonder how to fix the major issue #1 - unable to create new vm
> instances? Anyone any thoughts?
>
> Thanks
>
> Andrei
>
> ----- Original Message -----
>
> > From: "Mike Tutkowski" <mike.tutkowski@solidfire.com>
> > To: dev@cloudstack.apache.org
> > Sent: Monday, 2 February, 2015 7:38:39 PM
> > Subject: Re: Major breakage in GUI after upgrade from 4.3.2 to 4.4.2
>
> > I wonder for your Major issue #2 if you have drilled down into the
> > applicable zone from which you want to delete the template?
>
> > I had trouble finding this at one point, as well.
>
> > I don't have easy access to a 4.4 GUI at the time being, but in 4.6
> > you
> > need to go to Templates, click on the template in the table, select
> > the
> > Zone tab, click on the applicable zone in the table, then you see a
> > delete
> > button.
>
> > On Mon, Feb 2, 2015 at 12:23 PM, Andrei Mikhailovsky
> > <andrei@arhont.com>
> > wrote:
>
> > > Hi guys,
> > >
> > > Sorry for duplicating the message from the user list. I've not got
> > > anywhere there.
> > >
> > > I've recently upgraded my ASC from version 4.3.2 to version 4.4.2.
> > > The
> > > upgrade process went well without any setbacks or issues. I've not
> > > seen any
> > > errors in the log files. All looks good apart from the GUI issues.
> > > I've
> > > tried to clear browser caches and pressed force refresh as well.
> > > This
> > > happens in Firefox as well as Chrome.
> > >
> > > The following major issue that i've identified so far:
> > >
> > > 1. I can no longer create new instances. Regardless of if I am
> > > doing it
> > > from the ISO or existing Templates. After following the Add
> > > Instance wizard
> > > and clicking on the Launch button nothing happens. The wizard
> > > window
> > > becomes shaded and the spinning circle appears. I've left it for
> > > hours
> > > without any change. When the Launch button is pressed, the
> > > management
> > > server does not receive an API call to create an instance. There
> > > are
> > > actually nothing in the logs after the button is pressed. However,
> > > I can
> > > successfully create new instances by using the CloudMonkey clie.
> > > 2. There is no Delete button for Templates and ISOs. The Edit and
> > > Download
> > > buttons are there, but not the Delete button.
> > >
> > > The following minor issues that i've seen so far:
> > >
> > > 1. The elements in the Dashboard screen are not fitting their
> > > corresponding boxes. They stick out and not aligning properly
> > > 2. Some Tabs are not labeled properly and instead show something
> > > like:
> > > label.zones or label.add.isolated.network and a few more that i've
> > > noticed,
> > > but can't recall exactly what they were. But it seems that these
> > > labels are
> > > all over the place (probably about 20% of all Tabs and buttons in
> > > the GUI)
> > >
> > >
> > > Has anyone else seen these types of issues with the 4.4.x branch?
> > > Any
> > > thoughts on what is causing the issues and how to resolve them?
> > >
> > > Thanks
> > >
> > > Andrei
> > >
>
> > --
> > *Mike Tutkowski*
> > *Senior CloudStack Developer, SolidFire Inc.*
> > e: mike.tutkowski@solidfire.com
> > o: 303.746.7302
> > Advancing the way the world uses the cloud
> > <http://solidfire.com/solution/overview/?video=play>*™*
>



-- 
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the cloud
<http://solidfire.com/solution/overview/?video=play>*™*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message