cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francois Gaudreault <fgaudrea...@cloudops.com>
Subject Templates are no longer available on SSVM/ACS restart when using Swift
Date Wed, 04 Feb 2015 21:27:27 GMT
We have a very weird situation here. All the templates derived from 
snapshots are put to "Not Available" upon a ACS/SSVM restart. We use 
Swift as the secondary storage provider.

Basically, the data looks like this prior the restart:
data_center_id: NULL
     data_center_uuid: NULL
     data_center_name: NULL
        lp_account_id: NULL
             store_id: 4
          store_scope: REGION
                state: Ready
       download_state: DOWNLOADED
         download_pct: 100
            error_str: NULL
                 size: 4082758144
            destroyed: 0
     created_on_store: 2015-02-03 15:33:39
          detail_name: platform
         detail_value: 
viridian:true;acpi:1;apic:true;pae:true;nx:true;timeoffset:0

And looks like this after the restart:
data_center_id: 1
     data_center_uuid: 04afdbd1-e32d-4999-86d0-96703736dded
     data_center_name: QC-1
        lp_account_id: NULL
             store_id: NULL
          store_scope: NULL
                state: NULL
       download_state: NULL
         download_pct: NULL
            error_str: NULL
                 size: NULL
            destroyed: NULL
     created_on_store: NULL
          detail_name: hypervisortoolsversion
         detail_value: xenserver56

Also, all templates that have been imported are not affected. We are 
running 4.4.1. Ideas?

-- 
Francois Gaudreault
Gestionnaire de Produit | Product Manager - Cloud Platform & Services
t:514-629-6775

CloudOps Votre partenaire infonuagique | Cloud Solutions Experts
420 rue Guy | Montreal | Quebec | H3J 1S6
w: cloudops.com | tw: @CloudOps_


Mime
View raw message