cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohamed Infaz <infaz...@cse.mrt.ac.lk>
Subject Re: Cloudstack Agent Not starting
Date Tue, 16 Dec 2014 11:56:12 GMT
Thanks for the reply,

2014-12-17 00:49:21,586 INFO  [cloud.agent.AgentShell] (main:null) Agent
started
2014-12-17 00:49:21,601 INFO  [cloud.agent.AgentShell] (main:null)
Implementation Version is 4.3.1
2014-12-17 00:49:21,630 INFO  [cloud.agent.AgentShell] (main:null)
agent.properties found at /etc/cloudstack/agent/agent.properties
2014-12-17 00:49:21,792 INFO  [cloud.agent.AgentShell] (main:null)
Defaulting to using properties file for storage
2014-12-17 00:49:21,794 INFO  [cloud.agent.AgentShell] (main:null)
Defaulting to the constant time backoff algorithm
2014-12-17 00:49:21,856 INFO  [cloud.utils.LogUtils] (main:null) log4j
configuration found at /etc/cloudstack/agent/log4j-cloud.xml
2014-12-17 00:49:22,029 INFO  [cloud.agent.Agent] (main:null) id is
2014-12-17 00:49:22,033 WARN  [cloud.resource.ServerResourceBase]
(main:null) Nics are not specified in properties file/db, will try to
autodis$
2014-12-17 00:49:22,039 INFO  [cloud.resource.ServerResourceBase]
(main:null) Designating private to be nic cloudbr0
2014-12-17 00:49:22,047 INFO
[resource.virtualnetwork.VirtualRoutingResource] (main:null)
VirtualRoutingResource _scriptDir to use: scripts/ne$
2014-12-17 00:49:22,324 ERROR [cloud.agent.AgentShell] (main:null) Unable
to start agent:
com.cloud.utils.exception.CloudRuntimeException: Failed to connect socket
to '/var/run/libvirt/libvirt-sock': No such file or directory

This was the log.



On 16 December 2014 at 17:15, Erik Weber <terbolous@gmail.com> wrote:
>
> On Tue, Dec 16, 2014 at 12:37 PM, Mohamed Infaz <infaz.10@cse.mrt.ac.lk>
> wrote:
> >
> > Hi all,
> >
> > I am trying to deploy cloudstack with the hypervisor kvm in a single
> > machine where my operating system is ubuntu 14.04. I have configured the
> > network and also i did configure the libvirt.conf file. When i start
> > cloudstack-agent it does start at first and then as soon as i check the
> > status of the service i see it as fails. Because of this reason i can't
> add
> > a host. What could be the issue?
> >
> >
> Is there anything in /var/log/cloudstack/agent or similar?
>
> --
> Erik
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message