cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@shapeblue.com>
Subject [NOTICE] CloudMonkey 5.3 not starting on Ubuntu 14.10
Date Mon, 01 Dec 2014 10:42:48 GMT
Hi Andrei,

Thanks for bringing this to our notice. With Ubuntu 14.04/14.10, the
default pip has some issues. To install CloudMonkey or any package
dependent on "requests" users simply need to upgrade pip to make it work:

1. Uninstall the default pip:
    sudo apt-get remove --purge python-pip

2. Download and install latest pip from
https://pip.pypa.io/en/latest/installing.html#install-pip

I faced this issue too and the above worked for me. After doing the
above, retry/reinstall cloudmonkey it should work.

On Monday 01 December 2014 04:02 PM, Andrei Mikhailovsky wrote:
> Hi guys,
>
> I am having issues starting cloudmonkey on ubuntu 14.10. I get the following error:
>
> $ cloudmonkey
> Import error in cloudmonkey.cloudmonkey : No module named packages
>
> I have tried to google for the error, but can't find the solution.
>
> I've installed it via pip install cloudmonkey.
>
> Could some one point me in the right direction please?
>
> Thanks
>
> Andrei

This is the bug reference from Launchpad:
https://bugs.launchpad.net/ubuntu/+source/python-pip/+bug/1306991

If you've any issues, let me know.

--
Regards,
Rohit Yadav
Software Architect, ShapeBlue
M. +41 779015219 | rohit.yadav@shapeblue.com
Blog: bhaisaab.org | Twitter: @_bhaisaab
Find out more about ShapeBlue and our range of CloudStack related services

IaaS Cloud Design & Build<http://shapeblue.com/iaas-cloud-design-and-build//>
CSForge – rapid IaaS deployment framework<http://shapeblue.com/csforge/>
CloudStack Consulting<http://shapeblue.com/cloudstack-consultancy/>
CloudStack Software Engineering<http://shapeblue.com/cloudstack-software-engineering/>
CloudStack Infrastructure Support<http://shapeblue.com/cloudstack-infrastructure-support/>
CloudStack Bootcamp Training Courses<http://shapeblue.com/cloudstack-training/>

This email and any attachments to it may be confidential and are intended solely for the use
of the individual to whom it is addressed. Any views or opinions expressed are solely those
of the author and do not necessarily represent those of Shape Blue Ltd or related companies.
If you are not the intended recipient of this email, you must neither take any action based
upon its contents, nor copy or show it to anyone. Please contact the sender if you believe
you have received this email in error. Shape Blue Ltd is a company incorporated in England
& Wales. ShapeBlue Services India LLP is a company incorporated in India and is operated
under license from Shape Blue Ltd. Shape Blue Brasil Consultoria Ltda is a company incorporated
in Brasil and is operated under license from Shape Blue Ltd. ShapeBlue SA Pty Ltd is a company
registered by The Republic of South Africa and is traded under license from Shape Blue Ltd.
ShapeBlue is a registered trademark.

Mime
View raw message