cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajani Karuturi <raj...@apache.org>
Subject Re: ldap with microsoft ad on 4.5
Date Mon, 03 Nov 2014 15:55:06 GMT
Nope. Haven't done that. Will try.

I enabled err in ldap environment settings and tried. Didn't give me much
info.

Thanks.


On Mon, Nov 3, 2014 at 21:00 PM, Ian Duffy <ian@ianduffy.ie> wrote:

Hi Rajani,

That's a pity. I don't have anything near me to test this on at the moment.

Have you tried running tcpdump on the management server to inspect the
responses from AD?
On 3 Nov 2014 10:41, "Rajani Karuturi" <rajani@apache.org <javascript:;>>
wrote:

> already tried. didnt work.
>
> ~Rajani
>
> On Mon, Nov 3, 2014 at 4:10 PM, Ian Duffy <ian@ianduffy.ie <javascript:;>>
wrote:
>
> > Hi Rajani,
> >
> > in the LdapContextFactory.java class can you try setting the an extra
> > environment variable.
> >
> > environment.put(*Context.REFERRAL*, "follow");
> >
> > http://docs.oracle.com/javase/jndi/tutorial/ldap/referral/jndi.html
> >
> > Let me know if this solves it for you.
> > Ian.
> >
> > On 3 November 2014 09:32, Rajani Karuturi <rajani@apache.org
<javascript:;>> wrote:
> >
> > > using Apache Directory Server works fine on 4.3 and 4.5.
> > > But, If I use Microsoft AD(on windows server 2012), it doesnt work on
> > 4.5.
> > >
> > > It binds to the server properly. But, it doesnt list any users.
> > > I see "javax.naming.PartialResultException: Unprocessed Continuation
> > > Reference(s);" exception with no stacktrace.
> > >
> > > The same server and configuration works on 4.3 instance.
> > >
> > > Did anyone notice this? Any pointers?
> > >
> > >
> > > ~Rajani
> > >
> >
>



-- 
Sent from Windows Phone

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message