cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Tutkowski <mike.tutkow...@solidfire.com>
Subject Re: Templates created from snapshots get purged from cloud.template_store_ref
Date Wed, 12 Nov 2014 04:39:30 GMT
So, I just confirmed that once a properties file is generated for the
template that's being created that the template is not deleted when the CS
MS is re-started.

I checked in this fix to master:

5c388a5c8087d544ff89dccf20f8af88f8f73d1b

So, as it turns out, if anyone has created a template with the XenServer
6.2.5 resource code in releases prior to 4.6, that template will not be
usable if a management server gets restarted. Perhaps users could correct
such a problem by manually creating a properties file for that template.

On Mon, Nov 10, 2014 at 10:38 PM, Mike Tutkowski <
mike.tutkowski@solidfire.com> wrote:

> It looks like those rows get deleted in
> TemplateServiceImpl.handleTemplateSync(DataStore).
>
> I noticed earlier that the XenServer 6.2.5 resource code does NOT write
> out a properties file alongside the VHD template the way the XenServer 6.1
> resource code does.
>
> At the moment, I suspect that that is the problem.
>
> Does anyone know if the properties file that is for a given VHD template
> is required?
>
> On Mon, Nov 10, 2014 at 6:09 PM, Mike Tutkowski <
> mike.tutkowski@solidfire.com> wrote:
>
>> Thanks, Marcus
>>
>> I'll take a look into it later tonight more. I'm working on a feature for
>> 4.6 and noticed this yesterday. It happened again today and I narrowed it
>> down to occurring when the CS MS was stopped and re-started.
>>
>> On Mon, Nov 10, 2014 at 5:44 PM, Marcus <shadowsor@gmail.com> wrote:
>>
>>> I remember there was an issue with that occasionally happening when
>>> templates were simply registered. Sometimes they'd be downloaded and
>>> installed, and other times they would disappear. I think that was fixed
>>> maybe 18 months ago, could be related.
>>> On Nov 10, 2014 3:36 PM, "Mike Tutkowski" <mike.tutkowski@solidfire.com>
>>> wrote:
>>>
>>> > Hi,
>>> >
>>> > In 4.6 I've noticed when I create a template from a snapshot that I can
>>> > spin VMs up from this template until I shut the CS MS down and
>>> re-start it.
>>> >
>>> > Upon re-start, the template entries in cloud.template_store_ref get
>>> purged
>>> > (as in completely removed from the table). That being the case, the CS
>>> MS
>>> > no longer returns these templates as usable, so they're not available,
>>> say,
>>> > in the GUI to use to spin up VMs from.
>>> >
>>> > Has anyone else noticed this behavior? I'm doing this on what
>>> CloudStack
>>> > refers to as XenServer 6.2.5 (which is really XS 6.2 + some specific
>>> > patches).
>>> >
>>> > Thanks!
>>> >
>>> > --
>>> > *Mike Tutkowski*
>>> > *Senior CloudStack Developer, SolidFire Inc.*
>>> > e: mike.tutkowski@solidfire.com
>>> > o: 303.746.7302
>>> > Advancing the way the world uses the cloud
>>> > <http://solidfire.com/solution/overview/?video=play>*™*
>>> >
>>>
>>
>>
>>
>> --
>> *Mike Tutkowski*
>> *Senior CloudStack Developer, SolidFire Inc.*
>> e: mike.tutkowski@solidfire.com
>> o: 303.746.7302
>> Advancing the way the world uses the cloud
>> <http://solidfire.com/solution/overview/?video=play>*™*
>>
>
>
>
> --
> *Mike Tutkowski*
> *Senior CloudStack Developer, SolidFire Inc.*
> e: mike.tutkowski@solidfire.com
> o: 303.746.7302
> Advancing the way the world uses the cloud
> <http://solidfire.com/solution/overview/?video=play>*™*
>



-- 
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the cloud
<http://solidfire.com/solution/overview/?video=play>*™*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message