cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anshul Gangwar <anshul.gang...@citrix.com>
Subject RE: hyperv ssvm start failed
Date Thu, 13 Nov 2014 05:21:37 GMT
You got me wrong. I have not suggested to change permissions. I have suggested to change the
locale to US English(instead of Chinese/Japanese) of account with which the Hyper-V Agent
service is running.

I suspect that your windows server account is running in different locale other than English.


-----Original Message-----
From: 穆凯辉 [mailto:khmu@landhightech.com] 
Sent: Thursday, November 13, 2014 6:10 AM
To: dev@cloudstack.apache.org
Subject: 答复: hyperv ssvm start failed

Thanks.

We try to run Hyper-v agent by local administrator. But the agent crashed.
So we change to use domain administrator to run this agent. 

We will try to create a new user to run this agent.

Thank you very much.



----------------------------------------------------------------------------
-------------------------------

-----邮件原件-----
发件人: Anshul Gangwar [mailto:anshul.gangwar@citrix.com]
发送时间: 2014年11月12日 19:39
收件人: dev@cloudstack.apache.org
主题: RE: hyperv ssvm start failed

You have to run Hyper-V Agent service with the account which has it locale set to US English.



-----Original Message-----
From: 穆凯辉 [mailto:khmu@landhightech.com]
Sent: Wednesday, November 12, 2014 4:56 PM
To: dev@cloudstack.apache.org
Subject: hyperv ssvm start failed

Hi all,

 

         We use cloudstack 4.4.0 to manage a windows server 2012 dc hyper-v host. Both of
the primary and secondary storage are setup on this windows hyper-v host using SMB protocol.
The Virtual Switch in Hyperv is named “VirtualNetork”.

         

when we start the zone, the ssvm is created in hyper-v, but it can not start, and is destroy
immediately. The error event in windows is as follows:

         


2014-11-12 18:55:03,150 [12] INFO  HypervResource.HypervResourceController
[55c7a1ce-0320-4976-9915-ae6fb44682ba] - {

  "com.cloud.agent.api.StartAnswer": {

    "result": false,

    "details": "com.cloud.agent.api.StartCommand fail on exception未将对象引
用设置到对象的实例。",

    "vm": {

      "id": 1,

      "name": "v-1-VM",

      "type": "ConsoleProxy",

      "cpus": 1,

      "minSpeed": 500,

      "maxSpeed": 500,

      "minRam": 1073741824,

      "maxRam": 1073741824,

      "arch": "x86_64",

      "os": "Debian GNU/Linux 5.0 (64-bit)",

      "bootArgs": " template=domP type=consoleproxy host=192.168.1.137
port=8250 name=v-1-VM zone=1 pod=1 guid=Proxy.1 proxy_vm=1 disable_rp_filter=true eth2ip=192.168.1.33
eth2mask=255.255.255.0
gateway=192.168.1.254 eth0ip=169.254.0.70 eth0mask=255.255.0.0
eth1ip=192.168.1.224 eth1mask=255.255.255.0 mgmtcidr=192.168.1.0/24
localgw=192.168.1.254 internaldns1=192.168.1.92 internaldns2=8.8.8.8
dns1=192.168.1.92 dns2=8.8.8.8",

      "rebootOnCrash": false,

      "enableHA": false,

      "limitCpuUse": false,

      "enableDynamicallyScaleVm": false,

      "vncPassword": "861c2ac4e36ed3c3",

      "params": {},

      "uuid": "0c1a15f6-5cc6-4c10-8cf7-46fac26ee215",

      "disks": [

        {

          "data": {

            "org.apache.cloudstack.storage.to.VolumeObjectTO": {

              "uuid": "8b299dfc-2453-4e6a-bd02-b6dcc12fb32a",

              "volumeType": "ROOT",

              "dataStore": {

                "org.apache.cloudstack.storage.to.PrimaryDataStoreTO": {

                  "uuid": "2c739a85-40bf-365f-b448-152f6e10cad0",

                  "id": 2,

                  "poolType": "SMB",

                  "host": "192.168.1.80",

                  "path": "/Primary?user=administrator&domain=vsdevel",

                  "port": 445,

                  "url":
"SMB://192.168.1.80/Primary?user=administrator&domain=vsdevel/?ROLE=Primary&
STOREUUID=2c739a85-40bf-365f-b448-152f6e10cad0"

                }

              },

              "name": "ROOT-1",

              "size": 0,

              "path": "8b299dfc-2453-4e6a-bd02-b6dcc12fb32a",

              "volumeId": 1,

              "vmName": "v-1-VM",

              "accountId": 1,

              "format": "VHD",

              "id": 1,

              "deviceId": 0,

              "hypervisorType": "Hyperv"

            }

          },

          "diskSeq": 0,

          "path": "8b299dfc-2453-4e6a-bd02-b6dcc12fb32a",

          "type": "ROOT",

          "_details": {

            "managed": "false",

            "storagePort": "445",

            "storageHost": "192.168.1.80",

            "volumeSize": "0"

          }

        }

      ],

      "nics": [

        {

          "deviceId": 2,

          "networkRateMbps": -1,

          "defaultNic": true,

          "uuid": "e48caaf7-b544-443c-94ee-40055fcf90cc",

          "ip": "192.168.1.33",

          "netmask": "255.255.255.0",

          "gateway": "192.168.1.254",

          "mac": "06:4b:cc:00:00:87",

          "dns1": "192.168.1.92",

          "dns2": "8.8.8.8",

          "broadcastType": "Native",

          "type": "Guest",

          "broadcastUri": "vlan://untagged",

          "isSecurityGroupEnabled": true,

          "name": "VirtualNetwork"

        },

        {

          "deviceId": 0,

          "networkRateMbps": -1,

          "defaultNic": false,

          "uuid": "13bb00ec-b354-4fbf-b3f6-fb0dc29715b4",

          "ip": "169.254.0.70",

          "netmask": "255.255.0.0",

          "gateway": "169.254.0.1",

          "mac": "0e:00:a9:fe:00:46",

          "broadcastType": "LinkLocal",

          "type": "Control",

          "isSecurityGroupEnabled": false

        },

        {

          "deviceId": 1,

          "networkRateMbps": -1,

          "defaultNic": false,

          "uuid": "a6d63c0f-72b9-439e-91ce-d158cb37a482",

          "ip": "192.168.1.224",

          "netmask": "255.255.255.0",

          "gateway": "192.168.1.254",

          "mac": "06:e7:80:00:00:5f",

          "broadcastType": "Native",

          "type": "Management",

          "isSecurityGroupEnabled": false,

          "name": "VirtualNetwork"

        }

      ]

    },

    "contextMap": {}

  }

}

 

 

 

We have worked on this problem 3 days, and setup the new zone again and again. But we still
can not solve this problem.The Agentshell.exe is build in our development environment. 

Can anyone encounter this problem. Please help us. Thank you very much. 

 

 

Khmu


Mime
View raw message