cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ilia Shakitko <i.shaki...@tech.leaseweb.com>
Subject [4.4.2][API] Api parameter "account" is not being taken into consideration in "listUsageRecords" call
Date Mon, 03 Nov 2014 13:49:53 GMT
Hi,

I am doing an API call: command=listUsageRecords&response=json&startdate=2014-11-03&enddate=2014-11-03&type=8&account=Ilia
Shakitko

class stdClass#1 (1) {
  public $listusagerecordsresponse =>
  class stdClass#2 (2) {
    public $count =>
    int(3)
    public $usagerecord =>
    array(3) {
      [0] =>
      class stdClass#3 (13) {
        public $account =>
        string(5) "admin"
        public $accountid =>
        string(36) "039ae2dc-0115-11e4-9be4-005056ac252f"
        public $domainid =>
        string(36) "039ac40c-0115-11e4-9be4-005056ac252f"
        public $zoneid =>
        string(36) "75cb86ef-d0e0-4459-b781-0a31002f2786"
        public $description =>
        string(42) "ISO Id:211 Size:8091648VirtualSize:8091648"
        public $usage =>
        string(12) "0.166667 Hrs"
        public $usagetype =>
        int(8)
        public $rawusage =>
        string(8) "0.166667"
        public $usageid =>
        string(36) "6a6600a5-f979-4d56-86c0-c24877db0555"
        public $size =>
        int(8091648)
        public $virtualsize =>
        int(8091648)
        public $startdate =>
        string(27) "2014-11-03'T'14:35:00+01:00"
        public $enddate =>
        string(27) "2014-11-03'T'14:45:00+01:00"
      }
     }
}}

I can see record for admin user for some reason.

Kind regards,

Ilia Shakitko
Innovation Engineer
LeaseWeb Technologies B.V.

T: +31 20 316 0235

E: i.shakitko@tech.leaseweb.com
W: www.leaseweb.com<http://www.leaseweb.com>

Luttenbergweg 8,        1101 EC Amsterdam,      Netherlands



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message