cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Weller <swel...@ena.com>
Subject Re: uuid was invalid
Date Thu, 13 Nov 2014 19:36:47 GMT
I've seen something similar with KVM when using CLVM backed storage. The issue was libvirtd
was restarted and didn't have any of the storage UUIDs populated. Restarting the CS Agent
repopulated these. I'm not sure how XEN handles the storage side, or what kind of storage
you're using, but I thought I'd mention this in case it helps at all.

- Si



________________________________________
From: Francois Gaudreault <fgaudreault@cloudops.com>
Sent: Thursday, November 13, 2014 1:24 PM
To: dev@cloudstack.apache.org
Subject: uuid was invalid

Hi,

We had some issues with one of our cluster SR, and since then, ACS goes
crazy. Any ideas how to fix this?

2014-11-13 14:22:54,307 WARN  [c.c.h.x.r.CitrixResourceBase]
(DirectAgent-340:ctx-1a22d5c2) Catch Exception: class
com.xensource.xenapi.Types$UuidInvalid due to The uuid you supplied was
invalid.
The uuid you supplied was invalid.
     at com.xensource.xenapi.Types.checkResponse(Types.java:1482)
     at com.xensource.xenapi.Connection.dispatch(Connection.java:350)
     at
com.cloud.hypervisor.xen.resource.XenServerConnectionPool$XenServerConnection.dispatch(XenServerConnectionPool.java:456)
     at com.xensource.xenapi.VDI.getByUuid(VDI.java:326)
     at
com.cloud.hypervisor.xen.resource.CitrixResourceBase.mount(CitrixResourceBase.java:1224)

--
Francois Gaudreault
Gestionnaire de Produit | Product Manager - Cloud Platform & Services
t:514-629-6775

CloudOps Votre partenaire infonuagique | Cloud Solutions Experts
420 rue Guy | Montreal | Quebec | H3J 1S6
w: cloudops.com | tw: @CloudOps_


Mime
View raw message