cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ritu Sabharwal <rsabh...@Brocade.com>
Subject RE: Help in Adding XenServer to CS Management Server
Date Thu, 16 Oct 2014 17:05:05 GMT
Thanks Yitao and Pierre for replying!

I enabled the Zone and monitored the CS server logs. 

I did not configured the Secondary Storage earlier and did that.

After that I could see that Secondary Storage and Console Proxy VMs are starting and stopping
again and again.

In the logs:

2014-10-16 09:21:59,395 WARN  [c.c.h.x.r.XenServerStorageProcessor] (DirectAgent-317:ctx-2212833f)
can't mount 10.24.41.132:/export/secondary/template/tmpl/1/1 to /var/run/cloud_mount/67fce140-25f9-480f-a08a-3b2746adf142
2014-10-16 09:21:59,395 WARN  [c.c.h.x.r.XenServerStorageProcessor] (DirectAgent-317:ctx-2212833f)
Catch Exception com.cloud.utils.exception.CloudRuntimeException for template +  due to com.cloud.utils.exception.CloudRuntimeException:
can't mount 10.24.41.132:/export/secondary/template/tmpl/1/1 to /var/run/cloud_mount/67fce140-25f9-480f-a08a-3b2746adf142
com.cloud.utils.exception.CloudRuntimeException: can't mount 10.24.41.132:/export/secondary/template/tmpl/1/1
to /var/run/cloud_mount/67fce140-25f9-480f-a08a-3b2746adf142
        at com.cloud.hypervisor.xenserver.resource.XenServerStorageProcessor.copy_vhd_from_secondarystorage(XenServerStorageProcessor.java:699)
        at com.cloud.hypervisor.xenserver.resource.XenServerStorageProcessor.copyTemplateToPrimaryStorage(XenServerStorageProcessor.java:815)
        at com.cloud.storage.resource.StorageSubsystemCommandHandlerBase.execute(StorageSubsystemCommandHandlerBase.java:78)
        at com.cloud.storage.resource.StorageSubsystemCommandHandlerBase.handleStorageCommands(StorageSubsystemCommandHandlerBase.java:53)
                                                                                  

I also tried to manually mount the NF S share on XenServer on CLI and see this error.

[root@DCM-Xen-67 ~]# mount -t nfs 10.24.41.132:/export/secondary/template/1/1 /mnt/secondary
mount: mount to NFS server '10.24.41.132' failed: RPC Error: Program not registered.

Looks like the NFS mount is not working on XenServer from NFS share.

How can I solve this issue? Any specific setting on the XenServer needed?

Thanks & Regards,
Ritu s.

-----Original Message-----
From: Pierre-Luc Dion [mailto:pdion891@apache.org] 
Sent: Wednesday, October 15, 2014 7:52 PM
To: dev@cloudstack.apache.org
Subject: Re: Help in Adding XenServer to CS Management Server

Ritu,
 You have to wait a little when creating a zone until you have the SSVM and CPVM ready. then
it will automatically download a centos 5.6  which confirm your initial zone is working. if
 this is not happening, there might be a config issue related to primary, secondary storage
or network label.

hope this help,

PL


On Wed, Oct 15, 2014 at 9:08 PM, Yitao Jiang <willierjyt@gmail.com> wrote:

> 1.Check zone status, make sure enabled.
> 2.change mgmt server debug level, watch ing the log file in 
> /var/log/cloud/ On Oct 16, 2014 7:13 AM, "Ritu Sabharwal" <rsabharw@brocade.com>
wrote:
>
> > Hi,
> >
> > I am trying to add XenServer to the CS Management Server.
> >
> > I could add the hosts and I see Host status as up on the GUI. But I 
> > don't see any System VMs coming up and Virtual Router coming up in 
> > the
> dashboard.
> > When I try to create a User VM there is no template available to select.
> >
> > I am blocked at this point.
> >
> > I did seed Secondary Storage by importing system VM templat from 
> > http://jenkins.buildacloud.org/view/4.4/job/cloudstack-4.4-systemvm6
> > 4/ for Xen (systemvm64template-4.4-2014-09-30-xen.vhd.bz2<
> >
> http://jenkins.buildacloud.org/view/4.4/job/cloudstack-4.4-systemvm64/
> lastSuccessfulBuild/artifact/tools/appliance/dist/systemvm64template-4
> .4-2014-09-30-xen.vhd.bz2
> > >)
> >
> > Any help on this is appreciated.
> >
> > Thanks & Regards,
> > Ritu S.
> >
>
Mime
View raw message