cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nitin Mehta <Nitin.Me...@citrix.com>
Subject Re: Help in Adding XenServer to CS Management Server
Date Tue, 21 Oct 2014 20:45:56 GMT
I am talking about systemvm.iso and not the systemvm template
Systemvm.iso contains all our systemvm (ssvm, cpvm, routervm)  agent
code(java + some scripts) that gets patched onto the systemvms once they
are deployed.


Did you build your systemvm.iso recently [1] (mvn clean install -P
developer,systemvm)? I highly doubt that it is stale copy.
Once you build it make sure to propagate to XS using [2]



[1] - 
https://cwiki.apache.org/confluence/display/CLOUDSTACK/How+to+build+CloudSt
ack



On 21/10/14 1:37 PM, "Ritu Sabharwal" <rsabharw@Brocade.com> wrote:

>Hi  Nitin,
>
>I have picked the system vm template from
>http://secure-web.cisco.com/1p_apfJrUd4xtpNMybTlJT2rF1GVAA_ArTgZgpoLLM7iz_
>v_dk65i2eNK12F0Hue3YL5mlJVoVAHNjbKmY_1TPUYUClbuqglIw-MV8Tb-TmketxXTmakYdFc
>SJYL5ba6JS-m9QkG81DIklmXeMCyvSrZlWcQQiHeCsQDZKs-wE70/http%3A%2F%2Fjenkins.
>buildacloud.org%2Fview%2F4.4%2Fjob%2Fcloudstack-4.4-systemvm64%2FlastStabl
>eBuild%2F . This Build #132.
>
>My XenServer is 5.6 SP2 and CS Mgmt Server is built from master.
>
>Please verify is this is the right combination.
>
>Thanks & Regards,
>Ritu S.
>
>
>-----Original Message-----
>From: Nitin Mehta [mailto:Nitin.Mehta@citrix.com]
>Sent: Tuesday, October 21, 2014 11:34 AM
>To: dev@cloudstack.apache.org
>Subject: Re: Help in Adding XenServer to CS Management Server
>
>Make sure you are using the right systemvm.iso, for this version and for
>this hypervisor. You won't find scripts if scripts in sytemvm.iso havent
>been injected onto ssvm You can also login from Xencenter into ssvm and
>check logs as well.
>
>On 21/10/14 10:03 AM, "Ritu Sabharwal" <rsabharw@Brocade.com> wrote:
>
>>Hi Rajani,
>>
>>The SSVM is up and I can see it green in XenCenter.
>>
>>The systemvm.iso is available in the XenServer host. Below is the
>>snapshot of it.
>>
>>[root@DCM-Xen-69 ~]# ls -al /opt/xensource/packages/iso/ total 160684
>>drwxr-xr-x 2 root root     4096 Oct 15 10:49 .
>>drwxr-xr-x 5 root root     4096 May 20  2011 ..
>>-rw-r--r-- 1 root root 51802112 Oct 20 09:20 systemvm.iso
>>-rw-r--r-- 1 root root 45643776 May  5  2011 XenCenter.iso
>>-rw-r--r-- 1 root root 66908160 May 10  2011 xs-tools-5.6.100.iso
>>
>>The current value of secstorage.allowed.internal.sites is 0.0.0.0/0.
>>The CentOS template is not seeded offline i.e. from internal n/w. In
>>that case also, do I need to change the value of
>>secstorage.allowed.internal.sites?
>>
>>Thanks & Regards,
>>Ritu S.
>>-----Original Message-----
>>From: Rajani Karuturi [mailto:rajani@apache.org]
>>Sent: Monday, October 20, 2014 9:30 PM
>>To: dev@cloudstack.apache.org
>>Subject: Re: Help in Adding XenServer to CS Management Server
>>
>>Is the SSVM Agent UP? (check 9 and 10 in the wiki) Did you check
>>secstorage.allowed.internal.sites config value? (point 6 in the wiki)
>>
>>~Rajani
>>
>>On Tue, Oct 21, 2014 at 1:20 AM, Ritu Sabharwal <rsabharw@brocade.com>
>>wrote:
>>
>>> Hi,
>>>
>>> I have been trying hard to get this up and running but have no luck
>>>so far.
>>>
>>> I have refereed to this troubleshooting guide for system vms:
>>> https://cwiki.apache.org/confluence/display/CLOUDSTACK/SSVM,+template
>>> s
>>> ,+Secondary+storage+troubleshooting
>>>
>>> The SSVM and CPVM are running but I don't see any health check script
>>> there and also I can't ssh from XenServer host to the SSVM. I get no
>>> route to host error.
>>>
>>> Please provide help in resolving these errors.
>>>
>>> Thanks & Regards,
>>> Ritu S.
>>>
>>> -----Original Message-----
>>> From: Ritu Sabharwal [mailto:rsabharw@Brocade.com]
>>> Sent: Friday, October 17, 2014 3:02 PM
>>> To: dev@cloudstack.apache.org
>>> Subject: RE: Help in Adding XenServer to CS Management Server
>>>
>>> Hi,
>>>
>>> I could move ahead with the issues and see the SSVM and CPVM coming up
>>>.
>>> But when I  try to create a user VM I still don't see the default
>>>template.
>>>
>>> What could be the problem here? Any suggestions?
>>>
>>> Thanks & Regards,
>>> Ritu S.
>>>
>>> -----Original Message-----
>>> From: Pierre-Luc Dion [mailto:pdion891@apache.org]
>>> Sent: Wednesday, October 15, 2014 7:52 PM
>>> To: dev@cloudstack.apache.org
>>> Subject: Re: Help in Adding XenServer to CS Management Server
>>>
>>> Ritu,
>>>  You have to wait a little when creating a zone until you have the
>>> SSVM and CPVM ready. then it will automatically download a centos 5.6
>>> which confirm your initial zone is working. if  this is not
>>> happening, there might be a config issue related to primary,
>>> secondary storage or network label.
>>>
>>> hope this help,
>>>
>>> PL
>>>
>>>
>>> On Wed, Oct 15, 2014 at 9:08 PM, Yitao Jiang <willierjyt@gmail.com>
>>>wrote:
>>>
>>> > 1.Check zone status, make sure enabled.
>>> > 2.change mgmt server debug level, watch ing the log file in
>>> > /var/log/cloud/ On Oct 16, 2014 7:13 AM, "Ritu Sabharwal" <
>>> rsabharw@brocade.com> wrote:
>>> >
>>> > > Hi,
>>> > >
>>> > > I am trying to add XenServer to the CS Management Server.
>>> > >
>>> > > I could add the hosts and I see Host status as up on the GUI. But
>>> > > I don't see any System VMs coming up and Virtual Router coming up
>>> > > in the
>>> > dashboard.
>>> > > When I try to create a User VM there is no template available to
>>> select.
>>> > >
>>> > > I am blocked at this point.
>>> > >
>>> > > I did seed Secondary Storage by importing system VM templat from
>>> > > 
>>>http://secure-web.cisco.com/1gUYzrTMP4_zt6B7yu1eZm6uBqfffITqyVeBGbnHBI
>>>-0W 
>>>51IPO478b_yzMFXjTTcV15QCBCQnmZjqkRmiKzqbu3N90krlwtq1PCEBOg_XGxtGFpbQZs
>>>ZdC 
>>>c8XLiDDwFq4Ov4RD1naqhDxLv0HXM7LqyMU7JnQlVx1xaiwb8z_m-E/http%3A%2F%2Fje
>>>nki ns.buildacloud.org%2Fview%2F4.4%2Fjob%2Fcloudstack-4.4-systemv
>>> > > m6 4/ for Xen (systemvm64template-4.4-2014-09-30-xen.vhd.bz2<
>>> > >
>>> > 
>>>http://secure-web.cisco.com/16OFpcrv9LcUzeznlMuXnFxkgvkcDd81s4oz4P5Vo3
>>>i8_ 
>>>GA3m_OvSDO5KgPom5CEcuPM3FEKi0oqEWqfu70dU4Mp-CL_WYUvuU66MqRZVqGt6mNT7Kh
>>>mWU 
>>>WkvDAGQl31uLHdXUKD-zonVFZjKRIe5zsuqz7KqnAYqgf9BmfMKj2Q/http%3A%2F%2Fje
>>>nki
>>>ns.buildacloud.org%2Fview%2F4.4%2Fjob%2Fcloudstack-4.4-systemvm6
>>> > 4/
>>> > lastSuccessfulBuild/artifact/tools/appliance/dist/systemvm64templat
>>> > e
>>> > -4
>>> > .4-2014-09-30-xen.vhd.bz2
>>> > > >)
>>> > >
>>> > > Any help on this is appreciated.
>>> > >
>>> > > Thanks & Regards,
>>> > > Ritu S.
>>> > >
>>> >
>>>
>
>


Mime
View raw message