cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Luc Dion <pdion...@apache.org>
Subject Re: [VOTE][ACS44]Apache CloudStack 4.4.1 RC 3 in branch 4.4-RC20141014T2316
Date Fri, 17 Oct 2014 12:43:11 GMT
Hi Rohit,

I'm aware of this behavior, it start with 4.3.0, if you upgrade to 4.3.0 or
4.3.1 without having the new systemvm prior the upgrade, the db upgrade
will fail. which is why upgrading from 4.2.x to 4.4.1 require 2 new
systemvm to be install prior the upgrade.

Further more, if you have multiple hypervisor type, let say you have
XenServer and KVM clusters but forced system vm to run on xenserver only.
by default you might only install the new sysvmtemplate for xenserver, but,
 if you upgrade without having install the kvm systemvm version the db
upgrade will fail.

I think their is jira issue around this already.

On Fri, Oct 17, 2014 at 7:36 AM, Rohit Yadav <rohit.yadav@shapeblue.com>
wrote:

> Hi Pierre,
>
> On 17-Oct-2014, at 4:42 pm, Pierre-Luc Dion <pdion@cloudops.com> wrote:
> > Hi Rohit,
> > The doc in /latest is not the 4.4.1 latest, the correct documentation is
> in
> > /4.4.1 it should have been corrected for the behavior describe and also
> > contain correct url for sysvm ( not jenkins.bac.o).
> >
> > Once the 4.4.1 is released ill change the defaut url and update issues
> > lists in the RN.
>
> Thanks, that would be much needed.
>
> The issue is not that docs have those links, but that the Java class
> (440to441, the upgrade path) that upgrades CloudStack db has hard coded URL
> and MD5 checksums of 4.4.0 template.
>
> The real issue is when a user tries to upgrade from any prior version of
> CloudStack to 4.4.1 or later version, they would be required to register a
> 4.4.0-6 template (from Wido’s repo) before the upgrade which is something
> they skip or forget to do it which would result in messed up upgraded DB.
> For example, if I’m on 4.2.1 and I want to upgrade to 4.4.1 or later (say
> 4.5.0 in future) if I don’t follow the docs (i.e. register 4.4.0-06
> template, that too not any 4.4.0 template, but the specific one from Wido’s
> repo or some other url) my upgrade will fail.
>
> Regards,
> Rohit Yadav
> Software Architect, ShapeBlue
> M. +91 88 262 30892 | rohit.yadav@shapeblue.com
> Blog: bhaisaab.org | Twitter: @_bhaisaab
>
> Find out more about ShapeBlue and our range of CloudStack related services
>
> IaaS Cloud Design & Build<
> http://shapeblue.com/iaas-cloud-design-and-build//>
> CSForge – rapid IaaS deployment framework<http://shapeblue.com/csforge/>
> CloudStack Consulting<http://shapeblue.com/cloudstack-consultancy/>
> CloudStack Infrastructure Support<
> http://shapeblue.com/cloudstack-infrastructure-support/>
> CloudStack Bootcamp Training Courses<
> http://shapeblue.com/cloudstack-training/>
>
> This email and any attachments to it may be confidential and are intended
> solely for the use of the individual to whom it is addressed. Any views or
> opinions expressed are solely those of the author and do not necessarily
> represent those of Shape Blue Ltd or related companies. If you are not the
> intended recipient of this email, you must neither take any action based
> upon its contents, nor copy or show it to anyone. Please contact the sender
> if you believe you have received this email in error. Shape Blue Ltd is a
> company incorporated in England & Wales. ShapeBlue Services India LLP is a
> company incorporated in India and is operated under license from Shape Blue
> Ltd. Shape Blue Brasil Consultoria Ltda is a company incorporated in Brasil
> and is operated under license from Shape Blue Ltd. ShapeBlue SA Pty Ltd is
> a company registered by The Republic of South Africa and is traded under
> license from Shape Blue Ltd. ShapeBlue is a registered trademark.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message