cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Tutkowski <mike.tutkow...@solidfire.com>
Subject Re: Questions about new methods on PrimaryDataStoreDriver
Date Wed, 22 Oct 2014 19:27:32 GMT
Just an FYI:

I needed to change the signatures of the following interfaces on
PrimaryDataStoreDriver:

    public boolean connectVolumeToHost(VolumeInfo volumeInfo, Host host,
DataStore dataStore);



    public void disconnectVolumeFromHost(VolumeInfo volumeInfo, Host host,
DataStore dataStore);


For one, I renamed them (as Edison had requested a while back).


Secondly, I changed the first parameter's type from VolumeInfo to
DataObject to support volumes and snapshots being granted and revoked
access.


    public boolean grantAccess(DataObject dataObject, Host host, DataStore
dataStore);



    public void revokeAccess(DataObject dataObject, Host host, DataStore
dataStore);


I don't think anyone but my storage driver is currently making use of this,
but I wanted to mention it nonetheless.


I merged this code (along with related code that enables snapshots to be
taken on primary storage instead of necessarily needing to VM snapshot a
volume and then backing up the VM snapshot to secondary storage) into
master today.

On Wed, Jan 15, 2014 at 4:10 PM, Edison Su <Edison.su@citrix.com> wrote:

>  Hi Mike,
>
>    Just found there are few new methods are added on
> PrimaryDataStoreDriver:
>
>
>
>     public boolean connectVolumeToHost(VolumeInfo volumeInfo, Host host,
> DataStore dataStore);
>
>
>
>     public void disconnectVolumeFromHost(VolumeInfo volumeInfo, Host host,
> DataStore dataStore);
>
>
>
>     public long getVolumeSizeIncludingHypervisorSnapshotReserve(Volume
> volume, StoragePool pool);
>
>
>
> Could we rename the first two to something like(access/revokeAccess)? I
> have this two methods long time ago, then I removed them during the merging
> into 4.2, as nobody use them.
>
> getVolumeSizeIncludingHypervisorSnapshotReserve methods seems too specific
> to your storage, better to not add it on the driver. What’s this method
> used for? If you want change the usage size of volume, then why not return
> a proper volume size in createAsync? Or we can add a new method called
> getCapacities on the driver, if the default capacities is not enough for
> storage provider.
>



-- 
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the cloud
<http://solidfire.com/solution/overview/?video=play>*™*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message