cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francois Gaudreault <fgaudrea...@cloudops.com>
Subject Re: Issue with Snapshot push to Swift
Date Mon, 27 Oct 2014 16:17:47 GMT
Further details. Looks like the swift script fails on my dom0 with:
Oct 27 12:00:47 cca-c7-xen01 xapi: 
[debug|cca-c7-xen01|11232208|Async.host.call_plugin 
R:59f11fa92646|dispatcher] Server_helpers.exec exception_handler: Got 
exception XENAPI_PLUGIN_FAILURE: [ swift; TypeError; unsubscriptable 
object ]

What can cause this?

FG

On 2014-10-27 11:29 AM, Francois Gaudreault wrote:
> Hi,
>
> I am facing a weird issue where the volume snapshots are not pushed to 
> Swift, but the system thinks it's there. Any ideas where to start 
> troubleshooting? We are using XenServer.
>
> In the snapshot_spool_ref, I see the database entries for my snapshot, 
> but in reality, the file is not in Swift (verified using CyberDuck):
>
> | 500 |        7 |         193 | 2014-10-27 15:21:44 | 
> NULL                | NULL   | Primary    | 68719476736 |             
> 0 |                  0 | 
> 20831aa6-bcc6-41c6-94e9-77e480e807c3                       | Ready     
> |            2 |       0 | 2014-10-27 15:21:47 | 965 |
> ---> | 502 |        4 |         193 | 2014-10-27 15:21:47 | 
> NULL                | NULL   | Image      |           0 |             
> 0 |                  0 | 
> S-965/fc30d0e5-dc26-42db-b5ca-5e7cf8ef3ef8.vhd             | Ready     
> |            2 |       0 | 2014-10-27 15:25:22 | 965 |
>
> Thanks
>


-- 
Francois Gaudreault
Gestionnaire de Produit | Product Manager - Cloud Platform & Services
t:514-629-6775

CloudOps Votre partenaire infonuagique | Cloud Solutions Experts
420 rue Guy | Montreal | Quebec | H3J 1S6
w: cloudops.com | tw: @CloudOps_


Mime
View raw message