cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nux! <...@li.nux.ro>
Subject Re: Couple of questions about the 4.4.1 systemvm (re failed VR upgrades) and how to fix it
Date Wed, 22 Oct 2014 16:37:03 GMT
I copied the script to the lowercase filename as well, so they're both there. Uploaded the
ISO on the hypervisor/agent (also here http://tmp.nux.ro/Wz9-systemvm.iso )

The problem now is - after I destroy the VR to make sure the new ISO is used - the new VR
will not start. Logs: http://fpaste.org/144244/14139957/raw/

Perhaps I am not generating the ISO with the right options. How is it being built exactly?

--
Sent from the Delta quadrant using Borg technology!

Nux!
www.nux.ro

----- Original Message -----
> From: "Daan Hoogland" <daan.hoogland@gmail.com>
> To: "dev" <dev@cloudstack.apache.org>
> Sent: Wednesday, 22 October, 2014 17:09:02
> Subject: Re: Couple of questions about the 4.4.1 systemvm (re failed VR upgrades) and
how to fix it

> rename the script or create a link to it in the systemvm.iso
> 
> On Wed, Oct 22, 2014 at 5:53 PM, Nux! <nux@li.nux.ro> wrote:
>> Lovely!
>> Now, how do I fix it? :-)
>>
>> --
>> Sent from the Delta quadrant using Borg technology!
>>
>> Nux!
>> www.nux.ro
>>
>> ----- Original Message -----
>>> From: "Daan Hoogland" <daan.hoogland@gmail.com>
>>> To: "dev" <dev@cloudstack.apache.org>
>>> Sent: Wednesday, 22 October, 2014 16:46:56
>>> Subject: Re: Couple of questions about the 4.4.1 systemvm (re failed VR
>>> upgrades) and how to fix it
>>
>>> I had it backwards. the script is installed from the systemvm.iso not
>>> in the template it seems. sorry my search was correct but I
>>> interpreted the results wrong
>>>
>>> On Wed, Oct 22, 2014 at 5:37 PM, Daan Hoogland <daan.hoogland@gmail.com>
wrote:
>>>> Lucian, see inline
>>>>
>>>> On Wed, Oct 22, 2014 at 5:24 PM, Nux! <nux@li.nux.ro> wrote:
>>>>> Hi,
>>>>>
>>>>> So as per my other emails[1] regarding the failing upgrade because the
VR won't
>>>>> find /opt/cloud/bin/createipAlias.sh (a typo by the looks of it):
>>>>>
>>>>> - can I just download the systemvm, customise it and use it or is the
systemvm's
>>>>> cheksum, size and others locked in the DB?
>>>> the checksum is used during downloading only AFAIR
>>>>
>>>>> - if I can customise the systemvm, is it enough to just symlink
>>>>> /opt/cloud/bin/createIpAlias.sh (correct path) to
>>>>> /opt/cloud/bin/createipAlias.sh?
>>>> You could. It still seems strange to me that the 4.3 version should
>>>> work and the 4.4 not.
>>>>
>>>>>
>>>>> Is there anything else I need to do to fix this? Jayapal mentioned the
>>>>> systemvm.iso, do I need to edit this one as well?
>>>> a search shows it is not mentioned in the iso scripts. Redoing this
>>>> search now and let you know if otherwise.
>>>>
>>>>>
>>>>> Lucian
>>>>>
>>>>>
>>>>> [1] - http://www.mail-archive.com/dev@cloudstack.apache.org/msg36853.html
>>>>>
>>>>> --
>>>>> Sent from the Delta quadrant using Borg technology!
>>>>>
>>>>> Nux!
>>>>> www.nux.ro
>>>>
>>>>
>>>>
>>>> --
>>>> Daan
>>>
>>>
>>>
>>> --
>>> Daan
> 
> 
> 
> --
> Daan

Mime
View raw message