cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ritu Sabharwal <rsabh...@Brocade.com>
Subject RE: [VMWARE SETUP ERROR] Error seeing in brining up System VMs with Vmware setup with CS server
Date Mon, 22 Sep 2014 19:58:09 GMT
Hi Mike,

From where did you use the system vm template for 4.4 case?

Thanks & Regards,
Ritu S.

-----Original Message-----
From: Mike Tutkowski [mailto:mike.tutkowski@solidfire.com]
Sent: Monday, September 22, 2014 12:19 PM
To: dev@cloudstack.apache.org
Cc: Abhinandan Prateek
Subject: Re: [VMWARE SETUP ERROR] Error seeing in brining up System VMs with Vmware setup with CS server

I just updated the ticket with an FYI that the 4.4 system template (which I just tried) with CS 4.4 worked fine for the SSVM, CPVM, and the virtual router.

On Mon, Sep 22, 2014 at 10:57 AM, Mike Tutkowski < mike.tutkowski@solidfire.com> wrote:

> I opened the following ticket:
>
> https://issues.apache.org/jira/browse/CLOUDSTACK-7599
>
> Where can I put vmops.log? It's about 14MB and 10MB is JIRA's
> attachment limit.
>
> On Mon, Sep 22, 2014 at 9:21 AM, Sateesh Chodapuneedi <
> sateesh.chodapuneedi@citrix.com> wrote:
>
>> > -----Original Message-----
>> > From: Abhinandan Prateek [mailto:agneya2001@gmail.com]
>> > Sent: 22 September 2014 10:29
>> > To: CloudStack Dev
>> > Cc: Sateesh Chodapuneedi
>> > Subject: Re: [VMWARE SETUP ERROR] Error seeing in brining up System
>> > VMs
>> with Vmware setup with CS server
>> >
>> > Mike,
>> >
>> >   Lets wait for sometime, till someone from Citrix respond.
>> > I am working from Garage and not from Citrix and do not have quick
>> access to VMWare setup.
>> > In case we are still not sure about the VMWare template then we can
>> plan a more collaborative effort by participating in a debugging
>> > session.
>> > I can pass on the information on issues that I have seen, we can
>> > then
>> put some joint effort to fix these followed by
>> > documenting/automating these.
>> >
>> > I still hope that Sateesh or someone form Citrix respond on the
>> > latex
>> VMware templates and procedure.
>> >
>> > -abhi
>> >
>> > On 21-Sep-2014, at 3:57 am, Mike Tutkowski <
>> mike.tutkowski@solidfire.com> wrote:
>> >
>> > > So, I just tried with this system template and got (essentially)
>> > > the same results.
>> > >
>> > > I say "essentially" because with this template I never arrived at
>> > > a login prompt (it just shut down at some point in the boot
>> > > stage). With the other template, I was brought to the login
>> > > prompt and then the VM
>> was shut down.
>> > >
>> > > On Fri, Sep 19, 2014 at 9:18 PM, Abhinandan Prateek
>> > > <agneya2001@gmail.com>
>> > > wrote:
>> > >
>> > >>
>> > >> VMWare Template:
>> > >>
>> http://download.cloud.com/templates/4.5/systemvm64template-4.5-vmware
>> > >> .ova
>> > >> Checksum: 3106a79a4ce66cd7f6a7c50e93f2db57
>>
>> I am running ACS master with this template without issues.
>> Can somebody file a JIRA ticket and attach all relevant logs? I will
>> check it.
>> May be patching of systemvm is not working in the setup where VR did
>> not come up.
>>
>> For information aboutman manual changes to Jenkins generated
>> templates, please see ACS tickets CLOUDSTACK-5883 (
>> https://issues.apache.org/jira/browse/CLOUDSTACK-5883?focusedCommentI
>> d=13906809&page=com.atlassian.jira.plugin.system.issuetabpanels:comme
>> nt-tabpanel#comment-13906809
>> )
>> And CLOUDSTACK-4864.
>>
>> Regards,
>> Sateesh
>>
>> > >>
>> > >> Last I checked systemvm.iso will not get mounted.
>> > >>
>> > >> -abhi
>> > >>
>> > >> On 20-Sep-2014, at 8:32 am, Mike Tutkowski
>> > >> <mike.tutkowski@solidfire.com>
>> > >> wrote:
>> > >>
>> > >>> Can you provide me a link to the Citrix ones?
>> > >>>
>> > >>> Does this mean the standard build for VMware on Jenkins in
>> > >>> terms of the system template is pretty much useless when it
>> > >>> comes to the virtual
>> > >> router?
>> > >>>
>> > >>> Thanks
>> > >>>
>> > >>> On Fri, Sep 19, 2014 at 7:49 PM, Abhinandan Prateek <
>> > >> agneya2001@gmail.com>
>> > >>> wrote:
>> > >>>
>> > >>>> The VMWare template build by jenkins job does not have VMWare
>> > >>>> tools installed on it.
>> > >>>> Use the ones provided by Citrix.
>> > >>>>
>> > >>>> On 19-Sep-2014, at 9:31 pm, Mike Tutkowski <
>> > >> mike.tutkowski@solidfire.com>
>> > >>>> wrote:
>> > >>>>
>> > >>>>>
>> > >>>>
>> > >>
>> http://jenkins.buildacloud.org/job/build-systemvm64-master/lastSucces
>> > >> sfulBuild/artifact/tools/appliance/dist/systemvm64template-maste
>> > >> r-vmw
>> > >> are.ova
>> > >>>>>
>> > >>>>> On Fri, Sep 19, 2014 at 9:58 AM, Erik Weber
>> > >>>>> <terbolous@gmail.com>
>> > >> wrote:
>> > >>>>>
>> > >>>>>> Which systemvm template are you using?
>> > >>>>>>
>> > >>>>>> Erik
>> > >>>>>> 19. sep. 2014 03:47 skrev "Mike Tutkowski" <
>> > >>>> mike.tutkowski@solidfire.com>
>> > >>>>>> følgende:
>> > >>>>>>
>> > >>>>>>> Actually, the virtual router says it requires an upgrade.
>> > >>>>>>>
>> > >>>>>>> I think I can just turn that check off and re-run my
>> > >>>>>>> create-VM
>> test.
>> > >>>>>>>
>> > >>>>>>> On Thu, Sep 18, 2014 at 7:43 PM, Mike Tutkowski <
>> > >>>>>>> mike.tutkowski@solidfire.com> wrote:
>> > >>>>>>>
>> > >>>>>>>> OK, I checked in a fix for this:
>> > >>>>>>>>
>> > >>>>>>>>
>> > >>>>>>>>
>> > >>>>>>>
>> > >>>>>>
>> > >>>>
>> > >>
>> https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;a=commitdiff
>> > >> ;h=18e5aa116e99906f24a292bf7546809e05c72ec2;hp=7537c33bcdda65672
>> > >> fdd8f
>> > >> 81509e6885aa536932
>> > >>>>>>>>
>> > >>>>>>>> I did notice that both before and after my fix that the
>> > >>>>>>>> virtual
>> > >> router
>> > >>>>>> is
>> > >>>>>>>> NOT coming up.
>> > >>>>>>>>
>> > >>>>>>>> The system VM being cloned and the starting of the VM
>> > >>>>>>>> looks fine. It
>> > >>>>>> gets
>> > >>>>>>>> to the command prompt and then a little while later is
>> > >>>>>>>> shut down and restarted. I get an error in the GUI
>> > >>>>>>>> indicating that my VM
>> > >> deployment
>> > >>>>>>>> failed.
>> > >>>>>>>>
>> > >>>>>>>> I don't personally know a whole lot about how the virtual
>> > >>>>>>>> router
>> > >> code
>> > >>>>>>>> works, so we should pass that on to an appropriate developer.
>> > >>>>>>>>
>> > >>>>>>>> On Thu, Sep 18, 2014 at 6:35 PM, Mike Tutkowski <
>> > >>>>>>>> mike.tutkowski@solidfire.com> wrote:
>> > >>>>>>>>
>> > >>>>>>>>> Just destroyed and re-created my env from scratch without
>> > >>>>>>>>> 8bb4022f3729154f85036c4a7f55e2de783e4909 and it works fine.
>> > >>>>>>>>>
>> > >>>>>>>>> I think I know what the author was intending with the
>> > >>>>>>>>> code that is causing the problem, so I'll go ahead and
>> > >>>>>>>>> put in what I think is a
>> > >>>>>> fix,
>> > >>>>>>>>> re-create my env, and see if it works.
>> > >>>>>>>>>
>> > >>>>>>>>> On Thu, Sep 18, 2014 at 6:26 PM, ilya musayev <
>> > >>>> ilya.musayev@gmail.com
>> > >>>>>>>
>> > >>>>>>>>> wrote:
>> > >>>>>>>>>
>> > >>>>>>>>>> Thank you Mike, please keep us posted.
>> > >>>>>>>>>>
>> > >>>>>>>>>> Regards
>> > >>>>>>>>>> ilya
>> > >>>>>>>>>>
>> > >>>>>>>>>> On 9/18/14, 4:14 PM, Mike Tutkowski wrote:
>> > >>>>>>>>>>
>> > >>>>>>>>>> Little clarification on this:
>> > >>>>>>>>>>
>> > >>>>>>>>>> "The dsName is derived from the UUID of the datastore."
>> > >>>>>>>>>>
>> > >>>>>>>>>> I mean that the dsName is derived from the UUID primary
>> > >>>>>>>>>> storage in
>> > >>>>>> the
>> > >>>>>>>>>> DB.
>> > >>>>>>>>>>
>> > >>>>>>>>>> On Thu, Sep 18, 2014 at 5:12 PM, Mike Tutkowski <
>> > >>>>>>>>>> mike.tutkowski@solidfire.com> wrote:
>> > >>>>>>>>>>
>> > >>>>>>>>>>> Just a little update on this:
>> > >>>>>>>>>>>
>> > >>>>>>>>>>> The problem doesn't seem to have anything to do with
>> "managed"
>> > >>>>>>>>>>> storage code that was introduced back in March.
>> > >>>>>>>>>>>
>> > >>>>>>>>>>> The dsName is derived from the UUID of the datastore.
>> > >>>>>>>>>>> This leads
>> > >>>>>> to a
>> > >>>>>>>>>>> null being returned from
>> > >>>>>>> diskInfoBuilder.getDiskInfoByBackingFileBaseName,
>> > >>>>>>>>>>> which subsequently leads to a null being returned from
>> > >>>>>>>>>>> this
>> > >> method
>> > >>>>>>> (and a
>> > >>>>>>>>>>> NullPointerException being thrown).
>> > >>>>>>>>>>>
>> > >>>>>>>>>>> I plan to take a look at the history of this file in gitk.
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>  private VirtualMachineDiskInfo
>> > >>>>>>>>>>> getMatchingExistingDisk(VirtualMachineDiskInfoBuilder
>> > >>>>>> diskInfoBuilder,
>> > >>>>>>>>>>> DiskTO vol) {
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>      if (diskInfoBuilder != null) {
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>          VolumeObjectTO volume =
>> > >>>>>>>>>>> (VolumeObjectTO)vol.getData();
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>          String dsName =
>> > >>>>>>> volume.getDataStore().getUuid().replace("-",
>> > >>>>>>>>>>> "");
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>           Map<String, String> details =
>> > >>>>>>>>>>> vol.getDetails();
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>          boolean isManaged = details != null &&
>> > >>>>>>>>>>> Boolean.parseBoolean(details.get(DiskTO.MANAGED));
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>           VirtualMachineDiskInfo diskInfo =
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>
>> > >>>>>>>>>>> diskInfoBuilder.getDiskInfoByBackingFileBaseName(isManaged ?
>> > >>>>>>>>>>> new
>> > >>>>>>>>>>> DatastoreFile(volume.getPath()).getFileBaseName() :
>> > >>>>>> volume.getPath(),
>> > >>>>>>>>>>> dsName);
>> > >>>>>>>>>>>
>> > >>>>>>>>>>> On Thu, Sep 18, 2014 at 4:34 PM, Mike Tutkowski <
>> > >>>>>>>>>>> mike.tutkowski@solidfire.com> wrote:
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>> I think I found the magic. :)
>> > >>>>>>>>>>>>
>> > >>>>>>>>>>>> sudo mount -t nfs 192.168.129.46:/export/secondary
>> /mnt/sec
>> > >>>>>>>>>>>>
>> > >>>>>>>>>>>> If I mount /export/secondary to /mnt/sec (I did it in
>> > >>>>>>>>>>>> a bit of a roundabout way here), then the management
>> > >>>>>>>>>>>> server is
>> happy.
>> > >>>>>>>>>>>>
>> > >>>>>>>>>>>> I think this is only VMware "thing" for the management
>> server.
>> > >>>>>>>>>>>>
>> > >>>>>>>>>>>> Does anyone know if we document this?
>> > >>>>>>>>>>>>
>> > >>>>>>>>>>>> Thanks!
>> > >>>>>>>>>>>>
>> > >>>>>>>>>>>> On Thu, Sep 18, 2014 at 4:18 PM, Mike Tutkowski <
>> > >>>>>>>>>>>> mike.tutkowski@solidfire.com> wrote:
>> > >>>>>>>>>>>>
>> > >>>>>>>>>>>>> The instructions even say the following:
>> > >>>>>>>>>>>>>
>> > >>>>>>>>>>>>> If your secondary storage mount point is not named
>> > >>>>>> /mnt/secondary,
>> > >>>>>>>>>>>>> substitute your own mount point name.
>> > >>>>>>>>>>>>>
>> > >>>>>>>>>>>>> On Thu, Sep 18, 2014 at 4:15 PM, Mike Tutkowski <
>> > >>>>>>>>>>>>> mike.tutkowski@solidfire.com> wrote:
>> > >>>>>>>>>>>>>
>> > >>>>>>>>>>>>>> Yeah, I've been through the instructions a couple
>> > >>>>>>>>>>>>>> times and
>> > >>>> don't
>> > >>>>>>>>>>>>>> see anything that indicates why it's having trouble
>> > >>>>>>>>>>>>>> with
>> > >>>> /mnt/sec
>> > >>>>>>> (it says
>> > >>>>>>>>>>>>>> /mnt/sec instead of /mnt/secondary in the log messages).
>> > >>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>> On Thu, Sep 18, 2014 at 4:01 PM, Ritu Sabharwal <
>> > >>>>>>>>>>>>>> rsabharw@brocade.com> wrote:
>> > >>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>> I have an external NFS server and it is mounted to
>> > >>>>>> /mnt/secondary
>> > >>>>>>>>>>>>>>> on my CS server so seeding command I used is:
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>
>> > >>>>>>
>> > >>>>
>> > >> /usr/share/cloudstack-common/scripts/storage/secondary/cloud-ins
>> > >> tall-
>> > >> sys-tmplt
>> > >>>>>>>>>>>>>>> -m /mnt/secondary  -u
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>
>> > >>>>>>
>> > >>>>
>> > >>
>> http://cloudstack.apt-get.eu/systemvm/4.4/systemvm64template-4.4.0-6-
>> > >> vmware.ova
>> > >>>>>>>>>>>>>>> -h vmware -F
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>> I guess, if the secondary storage is local, then
>> > >>>>>> /export/secondary
>> > >>>>>>>>>>>>>>> should be fine.
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>> Regards,
>> > >>>>>>>>>>>>>>> Ritu S.
>> > >>>>>>>>>>>>>>> -----Original Message-----
>> > >>>>>>>>>>>>>>> From: Mike Tutkowski
>> > >>>>>>>>>>>>>>> [mailto:mike.tutkowski@solidfire.com]
>> > >>>>>>>>>>>>>>> Sent: Thursday, September 18, 2014 2:34 PM
>> > >>>>>>>>>>>>>>> To: dev@cloudstack.apache.org
>> > >>>>>>>>>>>>>>> Cc: ilya musayev; Koushik Das; Sateesh
>> > >>>>>>>>>>>>>>> Chodapuneedi; Adip
>> > >>>> Shetty
>> > >>>>>>>>>>>>>>> Subject: Re: [VMWARE SETUP ERROR] Error seeing in
>> > >>>>>>>>>>>>>>> brining up
>> > >>>>>>> System
>> > >>>>>>>>>>>>>>> VMs with Vmware setup with CS server
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>> The instructions to seed secondary storage for
>> > >>>>>>>>>>>>>>> VMware look
>> > >> like
>> > >>>>>>>>>>>>>>> this:
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>
>> > >>>>>>
>> > >>>>
>> > >> /usr/share/cloudstack-common/scripts/storage/secondary/cloud-ins
>> > >> tall-
>> > >> sys-tmplt
>> > >>>>>>>>>>>>>>> \ -m /mnt/secondary \ -u
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>
>> > >>>>>>
>> > >>>>
>> > >>
>> http://cloudstack.apt-get.eu/systemvm/4.4/systemvm64template-4.4.0-6-
>> > >> vmware.ova
>> > >>>>>>>>>>>>>>> \
>> > >>>>>>>>>>>>>>> -h vmware \
>> > >>>>>>>>>>>>>>> -s <optional-management-server-secret-key> \ -F
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>> For -m, I have /export/secondary (not
>> > >>>>>>>>>>>>>>> /mnt/secondary). I
>> > >> assume
>> > >>>>>>>>>>>>>>> that's correct because that is, in fact, where my
>> > >>>>>>>>>>>>>>> secondary
>> > >>>>>>> storage system
>> > >>>>>>>>>>>>>>> template is located for XenServer and that seems to
>> > >>>>>>>>>>>>>>> work just
>> > >>>>>>> fine.
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>> On Thu, Sep 18, 2014 at 3:20 PM, Mike Tutkowski <
>> > >>>>>>>>>>>>>>> mike.tutkowski@solidfire.com> wrote:
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>> I'm not getting far enough along in the process to
>> > >>>>>>>>>>>>>>>> repro (or
>> > >>>>>>> not)
>> > >>>>>>>>>>>>>>> the
>> > >>>>>>>>>>>>>>>> problem.
>> > >>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>> I do have a /mnt/sec folder (and I even made it 777).
>> > >>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>> Any thoughts on this?
>> > >>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>> WARN  [c.c.s.r.VmwareStorageProcessor]
>> > >>>>>>>>>>>>>>> (DirectAgent-46:ctx-fdd23ec9
>> > >>>>>>>>>>>>>>>> 192.168.129.71, job-95/job-123, cmd: CopyCommand)
>> Exception:
>> > >>>>>> tar
>> > >>>>>>>>>>>>>>>> --no-same-owner -xf
>> > >> /mnt/sec/template/tmpl/1/8//routing-8.ova
>> > >>>>>>>>>>>>>>>> java.io.IOException: Cannot run program "tar" (in
>> > >>>>>>>>>>>>>>>> directory
>> > >>>>>>>>>>>>>>>> "/mnt/sec/template/tmpl/1/8"): error=2, No such
>> > >>>>>>>>>>>>>>>> file or
>> > >>>>>>> directory
>> > >>>>>>>>>>>>>>>>  at
>> > >>>>>> java.lang.ProcessBuilder.start(ProcessBuilder.java:1041)
>> > >>>>>>>>>>>>>>>>  at
>> > >>>>>>>>>>>>>>>> com.cloud.utils.script.Script.execute(Script.java:
>> > >>>>>>>>>>>>>>>> 195)
>> > >>>>>>>>>>>>>>>>  at
>> > >>>>>>>>>>>>>>>> com.cloud.utils.script.Script.execute(Script.java:
>> > >>>>>>>>>>>>>>>> 163)  at com.cloud.storage.res
>> > >>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>> On Wed, Sep 17, 2014 at 2:53 PM, Mike Tutkowski <
>> > >>>>>>>>>>>>>>>> mike.tutkowski@solidfire.com> wrote:
>> > >>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>> You're right, Marcus. Now that I think about it,
>> > >>>>>>>>>>>>>>>>> asserts
>> > >> are
>> > >>>>>>>>>>>>>>> ignored
>> > >>>>>>>>>>>>>>>>> by default.
>> > >>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>> On Wed, Sep 17, 2014 at 1:59 PM, Marcus <
>> > >> shadowsor@gmail.com
>> > >>>>>>>
>> > >>>>>>>>>>>>>>> wrote:
>> > >>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>> Aren't asserts ignored by default? I think we
>> > >>>>>>>>>>>>>>>>>> had an issue
>> > >>>>>>> with
>> > >>>>>>>>>>>>>>>>>> asserts in the past, and I believe at the time
>> > >>>>>>>>>>>>>>>>>> the default
>> > >>>>>>>>>>>>>>> config
>> > >>>>>>>>>>>>>>>>>> had asserts disabled.
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>> On Wed, Sep 17, 2014 at 1:35 PM, Ritu Sabharwal
>> > >>>>>>>>>>>>>>>>>> <rsabharw@brocade.com>
>> > >>>>>>>>>>>>>>>>>> wrote:
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> Hi Mike,
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> I updated the master just now and tried the
>> > >>>>>>>>>>>>>>>>>>> setup. I see
>> > >>>>>> the
>> > >>>>>>>>>>>>>>> same
>> > >>>>>>>>>>>>>>>>>> error on
>> > >>>>>>>>>>>>>>>>>>> same line number.
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> Thanks & Regards, Ritu S.
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> -----Original Message-----
>> > >>>>>>>>>>>>>>>>>>> From: Mike Tutkowski [mailto:
>> > >> mike.tutkowski@solidfire.com
>> > >>>>>> ]
>> > >>>>>>>>>>>>>>>>>>> Sent: Tuesday, September 16, 2014 8:32 PM
>> > >>>>>>>>>>>>>>>>>>> To: dev@cloudstack.apache.org
>> > >>>>>>>>>>>>>>>>>>> Cc: ilya musayev; Koushik Das; Sateesh
>> > >>>>>>>>>>>>>>>>>>> Chodapuneedi; Adip
>> > >>>>>>>>>>>>>>> Shetty
>> > >>>>>>>>>>>>>>>>>>> Subject: Re: [VMWARE SETUP ERROR] Error seeing
>> > >>>>>>>>>>>>>>>>>>> in brining
>> > >>>>>> up
>> > >>>>>>>>>>>>>>>>>>> System VMs with Vmware setup with CS server
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> Can you tell us what commit SHA you are running
>> under?
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> I just updated master and line 2094 in
>> > >>>>>>>>>>>>>>>>>>> VmwareResource is
>> > >>>>>> the
>> > >>>>>>>>>>>>>>> following:
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> String[] diskChain = diskInfo.getDiskChain();
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> The only candidate for a NullPointerException
>> > >>>>>>>>>>>>>>>>>>> there is
>> > >>>>>>>>>>>>>>> diskInfo;
>> > >>>>>>>>>>>>>>>>>> however,
>> > >>>>>>>>>>>>>>>>>>> the previous line would have caught this as it
>> > >>>>>>>>>>>>>>>>>>> looks like
>> > >>>>>>>>>>>>>>> this:
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> assert (diskInfo != null);
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> That being the case, I'm curious what commit
>> > >>>>>>>>>>>>>>>>>>> SHA you saw
>> > >>>>>>> this
>> > >>>>>>>>>>>>>>> on?
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> Thanks!
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> On Tue, Sep 16, 2014 at 5:22 PM, Ritu Sabharwal
>> > >>>>>>>>>>>>>>>>>>> <rsabharw@brocade.com>
>> > >>>>>>>>>>>>>>>>>>> wrote:
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>> Hi Sateesh, Koushik,
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>> I am setting up Vmware Cluster with CS
>> > >>>>>>>>>>>>>>>>>>>> (master) and
>> > >>>>>> seeing
>> > >>>>>>>>>>>>>>> errors.
>> > >>>>>>>>>>>>>>>>>>>> ilya was helping me for this setup and figured
>> > >>>>>>>>>>>>>>>>>>>> out this
>> > >>>>>>>>>>>>>>> error.
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>> The System VMs(Secondary Stogare VM and
>> > >>>>>>>>>>>>>>>>>>>> Console Proxy
>> > >>>>>> VM)
>> > >>>>>>>>>>>>>>> are
>> > >>>>>>>>>>>>>>>>>>>> not coming up properly. The system vms are
>> > >>>>>>>>>>>>>>>>>>>> reconfiguring
>> > >>>>>>> and
>> > >>>>>>>>>>>>>>>>>>>> destroying again and again in cycle.
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>> I have used Vmware Vsphere 5.1 SDK for building CS.
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>> The error logs give this error:
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>> 2014-09-16 16:11:01,619 WARN
>> > >>>>>>>>>>>>>>>>>>>> [c.c.h.v.r.VmwareResource]
>> > >>>>>>>>>>>>>>>>>>>> (DirectAgent-8:ctx-8909215e 10.24.41.149,
>> > >>>>>>>>>>>>>>>>>>>> job-54/job-68,
>> > >>>>>>>>>>>>>>> cmd:
>> > >>>>>>>>>>>>>>>>>>>> StartCommand) StartCommand failed due to Exception:
>> > >>>>>>>>>>>>>>>>>>>> java.lang.NullPointerException
>> > >>>>>>>>>>>>>>>>>>>> Message: null
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>> java.lang.NullPointerException
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> com.cloud.hypervisor.vmware.resource.VmwareResource.postDis
>> > >>>>>>> kConf
>> > >>>>>>> igBe
>> > >>>>>>>>>>>>>>>>>> foreStart(VmwareResource.java:2094)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> com.cloud.hypervisor.vmware.resource.VmwareResource.execute
>> > >>>>>>> (Vmwa
>> > >>>>>>> reRe
>> > >>>>>>>>>>>>>>>>>> source.java:1685)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> com.cloud.hypervisor.vmware.resource.VmwareResource.execute
>> > >>>>>>> Reque
>> > >>>>>>> st(V
>> > >>>>>>>>>>>>>>>>>> mwareResource.java:448)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> com.cloud.agent.manager.DirectAgentAttache$Task.runInContex
>> > >>>>>>> t(Dir
>> > >>>>>>> ectA
>> > >>>>>>>>>>>>>>>>>> gentAttache.java:294)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> org.apache.cloudstack.managed.context.ManagedContextRunnabl
>> > >>>>>>> e$1.r
>> > >>>>>>> un(M
>> > >>>>>>>>>>>>>>>>>> anagedContextRunnable.java:49)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> org.apache.cloudstack.managed.context.impl.DefaultManagedCo
>> > >>>>>>> ntext
>> > >>>>>>> $1.c
>> > >>>>>>>>>>>>>>>>>> all(DefaultManagedContext.java:56)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> org.apache.cloudstack.managed.context.impl.DefaultManagedCo
>> > >>>>>>> ntext
>> > >>>>>>> .cal
>> > >>>>>>>>>>>>>>>>>> lWithContext(DefaultManagedContext.java:103)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> org.apache.cloudstack.managed.context.impl.DefaultManagedCo
>> > >>>>>>> ntext
>> > >>>>>>> .run
>> > >>>>>>>>>>>>>>>>>> WithContext(DefaultManagedContext.java:53)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> org.apache.cloudstack.managed.context.ManagedContextRunnabl
>> > >>>>>>> e.run
>> > >>>>>>> (Man
>> > >>>>>>>>>>>>>>>>>> agedContextRunnable.java:46)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> java.util.concurrent.Executors$RunnableAdapter.call(Executo
>> > >>>>>>> rs.ja
>> > >>>>>>> va:4
>> > >>>>>>>>>>>>>>>>>> 71)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>> java.util.concurrent.FutureTask.run(FutureTask.java
>> > >>>>>>>>>>>>>>> :262)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledF
>> > >>>>>>> uture
>> > >>>>>>> Task
>> > >>>>>>>>>>>>>>>>>> .access$201(ScheduledThreadPoolExecutor.java:178
>> > >>>>>>>>>>>>>>>>>> )
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledF
>> > >>>>>>> uture
>> > >>>>>>> Task
>> > >>>>>>>>>>>>>>>>>> .run(ScheduledThreadPoolExecutor.java:292)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoo
>> > >>>>>>> lExec
>> > >>>>>>> utor
>> > >>>>>>>>>>>>>>>>>> .java:1145)
>> > >>>>>>>>>>>>>>>>>>>>      at
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPo
>> > >>>>>>> olExe
>> > >>>>>>> cuto
>> > >>>>>>>>>>>>>>>>>> r.java:615)
>> > >>>>>>>>>>>>>>>>>>>>      at java.lang.Thread.run(Thread.java:744)
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>> Please help to resolve this issue.
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>> Thanks & Regards, Ritu S.
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>> --
>> > >>>>>>>>>>>>>>>>>>> *Mike Tutkowski*
>> > >>>>>>>>>>>>>>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>>>>>>>>>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>>>>>>>>>>>>>> o: 303.746.7302
>> > >>>>>>>>>>>>>>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>>>>>>>>>>>>>> <http://solidfire.com/solution/overview/?video=play
>> >
>> > >>>>>>>>>>>>>>>>>>> *T*
>> > >>>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>> --
>> > >>>>>>>>>>>>>>>>> *Mike Tutkowski*
>> > >>>>>>>>>>>>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>>>>>>>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>>>>>>>>>>>> o: 303.746.7302
>> > >>>>>>>>>>>>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>>>>>>>>>>>> <http://solidfire.com/solution/overview/?video=play
>> >*T
>> > >>>>>>>>>>>>>>>>> *
>> > >>>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>> --
>> > >>>>>>>>>>>>>>>> *Mike Tutkowski*
>> > >>>>>>>>>>>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>>>>>>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>>>>>>>>>>> o: 303.746.7302
>> > >>>>>>>>>>>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>>>>>>>>>>> <http://solidfire.com/solution/overview/?video=play
>> >*T*
>> > >>>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>> --
>> > >>>>>>>>>>>>>>> *Mike Tutkowski*
>> > >>>>>>>>>>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>>>>>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>>>>>>>>>> o: 303.746.7302
>> > >>>>>>>>>>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>>>>>>>>>> <http://solidfire.com/solution/overview/?video=play>*T*
>> > >>>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>> --
>> > >>>>>>>>>>>>>> *Mike Tutkowski*
>> > >>>>>>>>>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>>>>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>>>>>>>>> o: 303.746.7302
>> > >>>>>>>>>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>>>>>>>>> <http://solidfire.com/solution/overview/?video=play>*T*
>> > >>>>>>>>>>>>>>
>> > >>>>>>>>>>>>>
>> > >>>>>>>>>>>>>
>> > >>>>>>>>>>>>>
>> > >>>>>>>>>>>>> --
>> > >>>>>>>>>>>>> *Mike Tutkowski*
>> > >>>>>>>>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>>>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>>>>>>>> o: 303.746.7302
>> > >>>>>>>>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>>>>>>>> <http://solidfire.com/solution/overview/?video=play>*T*
>> > >>>>>>>>>>>>>
>> > >>>>>>>>>>>>
>> > >>>>>>>>>>>>
>> > >>>>>>>>>>>>
>> > >>>>>>>>>>>> --
>> > >>>>>>>>>>>> *Mike Tutkowski*
>> > >>>>>>>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>>>>>>> o: 303.746.7302
>> > >>>>>>>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>>>>>>> <http://solidfire.com/solution/overview/?video=play>*T*
>> > >>>>>>>>>>>>
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>
>> > >>>>>>>>>>>
>> > >>>>>>>>>>> --
>> > >>>>>>>>>>> *Mike Tutkowski*
>> > >>>>>>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>>>>>> o: 303.746.7302
>> > >>>>>>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>>>>>> <http://solidfire.com/solution/overview/?video=play>*T*
>> > >>>>>>>>>>>
>> > >>>>>>>>>>
>> > >>>>>>>>>>
>> > >>>>>>>>>>
>> > >>>>>>>>>> --
>> > >>>>>>>>>> *Mike Tutkowski*
>> > >>>>>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>>>>> o: 303.746.7302
>> > >>>>>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>>>>> <http://solidfire.com/solution/overview/?video=play>*T*
>> > >>>>>>>>>>
>> > >>>>>>>>>>
>> > >>>>>>>>>>
>> > >>>>>>>>>
>> > >>>>>>>>>
>> > >>>>>>>>> --
>> > >>>>>>>>> *Mike Tutkowski*
>> > >>>>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>>>> o: 303.746.7302
>> > >>>>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>>>> <http://solidfire.com/solution/overview/?video=play>*T*
>> > >>>>>>>>>
>> > >>>>>>>>
>> > >>>>>>>>
>> > >>>>>>>>
>> > >>>>>>>> --
>> > >>>>>>>> *Mike Tutkowski*
>> > >>>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>>> o: 303.746.7302
>> > >>>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>>> <http://solidfire.com/solution/overview/?video=play>*T*
>> > >>>>>>>>
>> > >>>>>>>
>> > >>>>>>>
>> > >>>>>>>
>> > >>>>>>> --
>> > >>>>>>> *Mike Tutkowski*
>> > >>>>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>>>> e: mike.tutkowski@solidfire.com
>> > >>>>>>> o: 303.746.7302
>> > >>>>>>> Advancing the way the world uses the cloud
>> > >>>>>>> <http://solidfire.com/solution/overview/?video=play>*T*
>> > >>>>>>>
>> > >>>>>>
>> > >>>>>
>> > >>>>>
>> > >>>>>
>> > >>>>> --
>> > >>>>> *Mike Tutkowski*
>> > >>>>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>>>> e: mike.tutkowski@solidfire.com
>> > >>>>> o: 303.746.7302
>> > >>>>> Advancing the way the world uses the cloud
>> > >>>>> <http://solidfire.com/solution/overview/?video=play>*T*
>> > >>>>
>> > >>>>
>> > >>>
>> > >>>
>> > >>> --
>> > >>> *Mike Tutkowski*
>> > >>> *Senior CloudStack Developer, SolidFire Inc.*
>> > >>> e: mike.tutkowski@solidfire.com
>> > >>> o: 303.746.7302
>> > >>> Advancing the way the world uses the cloud
>> > >>> <http://solidfire.com/solution/overview/?video=play>*T*
>> > >>
>> > >>
>> > >
>> > >
>> > > --
>> > > *Mike Tutkowski*
>> > > *Senior CloudStack Developer, SolidFire Inc.*
>> > > e: mike.tutkowski@solidfire.com
>> > > o: 303.746.7302
>> > > Advancing the way the world uses the cloud
>> > > <http://solidfire.com/solution/overview/?video=play>*T*
>>
>>
>
>
> --
> *Mike Tutkowski*
> *Senior CloudStack Developer, SolidFire Inc.*
> e: mike.tutkowski@solidfire.com
> o: 303.746.7302
> Advancing the way the world uses the cloud
> <http://solidfire.com/solution/overview/?video=play>*™*
>



--
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the cloud
<http://solidfire.com/solution/overview/?video=play>*™*
Mime
View raw message