cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Weber <terbol...@gmail.com>
Subject Re: [VOTE] Release Apache CloudStack 4.3.1 round #4
Date Thu, 11 Sep 2014 09:38:45 GMT
On Thu, Sep 11, 2014 at 10:54 AM, Rohit Yadav <rohit.yadav@shapeblue.com>
wrote:

> Hi Erik,
>
> On 11-Sep-2014, at 10:11 am, Erik Weber <terbolous@gmail.com> wrote:
> > I don't know if packaging issues is relevant or not, but rpms require
> > openjdk 1.6 rather than 1.7, which makes the kvm agent unable to start.
> >
> > [root@cloud-lab-node3 cloudstack]# cat agent/cloudstack-agent.err
> >
> > log4j:WARN No appenders could be found for logger
> > (com.cloud.agent.AgentShell).
>
> I checked cloud.spec, The rpms requires java 1.6.0 or above, when you
> install cloudstack-agent does it automatically only install openjdk 1.6? If
> you install openjdk 1.7 does this problem go away?
>
>
Yes, I only had openjdk 1.6 installed. Installing openjdk 1.7 and removing
1.6 solved the issue.



> Are you using the rpms from the repo I shared, those RPMs were build using
> JDK 1.7 so running them on 1.6 JRE/JVM can cause issues. Can you try
> building the rpms yourself using JDK 1.6 and running them on 1.6 and see if
> you can reproduce this issue.
>
>
I actually used the latest from jenkins. The spec file is the same, but I
can try building them myself just to be sure.

-- 
Erik

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message