cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Indra Pramana <in...@sg.or.id>
Subject Unable to upload SSL certificate for realhostip replacement
Date Mon, 22 Sep 2014 11:36:03 GMT
Dear all,

I am following the instruction on this documentation to replace
realhostip.com with my own domain.

https://cwiki.apache.org/confluence/display/CLOUDSTACK/Procedure+to+Replace+realhostip.com+with+Your+Own+Domain+Name

Everything is fine until I need to upload the root certificate via API. I
have URL-encoded the certificate using online URL encoder tool such as:

http://www.url-encode-decode.com/

However, when I run the API command, the certificate is rejected, saying
that it contains illegal ASCII non-printable characters:

for parameter certificate is invalid, contains illegal ASCII non-printable
characters

I have ensured and verified that it only contains generic ASCII text
format, no space, symbol etc. Tried using UTF-8, US-ASCII format while
encoding, but still cannot work.

Any advice is greatly appreciated.

Looking forward to your reply, thank you.

Cheers.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message