cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Punith S <punit...@cloudbyte.com>
Subject SSVM JAVA PROCESS NOT RUNNING, systemvm didn't get patched with the agent specific code
Date Thu, 04 Sep 2014 09:27:46 GMT
hi,

i have been working on building noredist of master for vmware,

since i'm using mvn commands and jetty for deploying cloudstack

i'm building the cloudstack using
 $ mvn clean
$ mvn install -Dnoredist

deploying using $ mvn -pl :cloud-client-ui jetty:run -Dnoredist

also i'm seeding the SSVM template by using
as the link suggests
https://cwiki.apache.org/confluence/display/CLOUDSTACK/How+to+build+CloudStack

# mkdir -p /etc/cloudstack/management/
# cp ./client/target/cloud-client-ui-4.5.0-SNAPSHOT/WEB-INF/classes/db.properties
/etc/cloudstack/management/
#
./client/target/generated-webapp/WEB-INF/classes/scripts/storage/secondary/cloud-install-sys-tmplt
-m /mnt/secondary -u http://
jenkins.buildacloud.org/view/master/job/build-systemvm-master/lastSuccessfulBuild/artifact/tools/appliance/dist/systemvmtemplate-master-vmware.ova
-h vmware -F

when i deploy a vmware zone,everything come up fine but the systemvm's
agent is not running!

when i log into the ssvm,* i see 4.4.SNAPSHOT jars being patched in the
/use/local/cloud/ssvm*

hence the java process is not running
logs show
2014-09-04 09:20:24,760 INFO  [cloud.agent.AgentShell] (main:null) Agent
started
2014-09-04 09:20:24,764 INFO  [cloud.agent.AgentShell] (main:null)
Implementation Version is 4.4.0-SNAPSHOT
2014-09-04 09:20:24,765 INFO  [cloud.agent.AgentShell] (main:null)
agent.properties found at /usr/local/cloud/systemvm/conf/agent.properties
2014-09-04 09:20:24,772 DEBUG [cloud.agent.AgentShell] (main:null) Found
property: instance
2014-09-04 09:20:24,774 DEBUG [cloud.agent.AgentShell] (main:null) Found
property: resource
2014-09-04 09:20:24,774 INFO  [cloud.agent.AgentShell] (main:null)
Defaulting to using properties file for storage
2014-09-04 09:20:24,781 INFO  [cloud.agent.AgentShell] (main:null)
Defaulting to the constant time backoff algorithm
2014-09-04 09:20:24,801 INFO  [cloud.utils.LogUtils] (main:null) log4j
configuration found at /usr/local/cloud/systemvm/conf/log4j-cloud.xml
2014-09-04 09:20:24,825 DEBUG [cloud.agent.AgentShell] (main:null) Checking
to see if agent.SecStorage.pid exists.
2014-09-04 09:20:24,828 DEBUG [cloud.utils.ProcessUtil] (main:null)
environment.properties could not be opened
2014-09-04 09:20:24,836 DEBUG [cloud.utils.ProcessUtil] (main:null)
Executing: bash -c echo $PPID
2014-09-04 09:20:24,844 DEBUG [cloud.utils.ProcessUtil] (main:null)
Execution is successful.
*2014-09-04 09:20:24,853 ERROR [cloud.agent.AgentShell] (main:null) Unable
to start agent: Resource class not found:
com.cloud.storage.resource.PremiumSecondaryStorageResource due to:
java.lang.ClassNotFoundException:
com.cloud.storage.resource.PremiumSecondaryStorageResource*

i'm guessing there was no patch up between agent specific code !
am i missing out something here ?

thanks!
-- 
regards,

punith s
cloudbyte.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message