cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daan Hoogland <daan.hoogl...@gmail.com>
Subject Re: test case tagging and travis output
Date Sat, 06 Sep 2014 09:10:44 GMT
Santosh, the expunge error seems to be constant. It might be
1. a simulator issue.
2. a test error (though I think it is not a false positive)
3. a expunge logic/timing issue

my guess now is 1. the expunged vm shows in the result listing as destroyed

regards,


On Sat, Sep 6, 2014 at 9:13 AM, Santhosh Edukulla <
santhosh.edukulla@citrix.com> wrote:

> Sure.
>
> 1. It seems we are running only few tests like below, do we want to run
> all smoke/ tests?
> export TESTS="test_secondary_storage test_service_offerings test_ssvm
> test_templates misc/test_deploy_vm test_vm_life_cycle test_volumes
> test_vpc_vpn"
>
> 2. There is one big dict printed to stdout, i removed it from script now.
>
> 3. Instead of running in for loop, just run with nose -w switch and
> --exclude-- to remove exclude suites.
>
> 4. Are we referring to job 64.3, I could see only one expunge related test
> case has failed? Where can we see the logs for that run? It could be a temp
> issue as well, if it fails in continuous run, its aconcern to look at.
>
> Santhosh
>
> ________________________________________
> From: Sebastien Goasguen [runseb@gmail.com]
> Sent: Thursday, September 04, 2014 11:38 AM
> To: dev@cloudstack.apache.org
> Subject: Re: test case tagging and travis output
>
> On Sep 4, 2014, at 10:34 AM, Santhosh Edukulla <
> santhosh.edukulla@citrix.com> wrote:
>
> > One small note regarding return values, if we are running tests using
> nose, then discovery, run and report is all handled by it, so in a way
> commands output depends on the nose handling success, failure and error
> output from tests, its nothing to do much with marvin.
> >
>
> Maybe you can help us figuring out why some tests are red in:
>
> https://travis-ci.org/apache/cloudstack/builds/34385313
>
> Could be the way we deploy the simulator and run the test on travis, could
> be nose, could be the tags we are using...
>
> >
> > Regards,
> > Santhosh
> > ________________________________________
> > From: Sebastien Goasguen [runseb@gmail.com]
> > Sent: Thursday, September 04, 2014 10:19 AM
> > To: dev@cloudstack.apache.org
> > Cc: Ian Duffy
> > Subject: Re: test case tagging and travis output
> >
> > On Sep 4, 2014, at 10:14 AM, Daan Hoogland <daan.hoogland@gmail.com>
> wrote:
> >
> >> H Ian,
> >>
> >> As discussed off-list I am looking at the failure of extractIso in the
> >
> > fwiw, I removed that test from 4.3 testing.
> >
> > all test seem to pass for 4.3 but Travis still outputs "red" because of
> some strange return values by Marvin
> >
> > but with the marvin refactoring, there are differences between master,
> 4.4 and 4.3.
> >
> >
> >> travis-ci run of the 4.4 branch. Can I tune it to give more output?
> Unlike
> >> the expungeVM test, this one is not run in the simulator-singlerun so
> >> looking at the output there doesn't help.
> >>
> >> It seems that CLOUDSTACK-6914 introduced some new tagging scheme for
> test
> >> and I am assuming the new tagging should exclude the test from the
> travis
> >> run (makes sense and trying now). The new tagging scheme is not
> documented
> >> in the bug in spite of Alex Brett asking for it, so once again:
> >> @anyone: is this described somewhere?
> >>
> >> --
> >> Daan
> >
>
>


-- 
Daan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message