cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Tutkowski <mike.tutkow...@solidfire.com>
Subject Re: [VMWARE SETUP ERROR] Error seeing in brining up System VMs with Vmware setup with CS server
Date Wed, 17 Sep 2014 20:53:37 GMT
You're right, Marcus. Now that I think about it, asserts are ignored by
default.

On Wed, Sep 17, 2014 at 1:59 PM, Marcus <shadowsor@gmail.com> wrote:

> Aren't asserts ignored by default? I think we had an issue with asserts in
> the past, and I believe at the time the default config had asserts
> disabled.
>
>
> On Wed, Sep 17, 2014 at 1:35 PM, Ritu Sabharwal <rsabharw@brocade.com>
> wrote:
>
> > Hi Mike,
> >
> > I updated the master just now and tried the setup. I see the same error
> on
> > same line number.
> >
> > Thanks & Regards,
> > Ritu S.
> >
> > -----Original Message-----
> > From: Mike Tutkowski [mailto:mike.tutkowski@solidfire.com]
> > Sent: Tuesday, September 16, 2014 8:32 PM
> > To: dev@cloudstack.apache.org
> > Cc: ilya musayev; Koushik Das; Sateesh Chodapuneedi; Adip Shetty
> > Subject: Re: [VMWARE SETUP ERROR] Error seeing in brining up System VMs
> > with Vmware setup with CS server
> >
> > Can you tell us what commit SHA you are running under?
> >
> > I just updated master and line 2094 in VmwareResource is the following:
> >
> > String[] diskChain = diskInfo.getDiskChain();
> >
> > The only candidate for a NullPointerException there is diskInfo; however,
> > the previous line would have caught this as it looks like this:
> >
> > assert (diskInfo != null);
> >
> > That being the case, I'm curious what commit SHA you saw this on?
> >
> > Thanks!
> >
> > On Tue, Sep 16, 2014 at 5:22 PM, Ritu Sabharwal <rsabharw@brocade.com>
> > wrote:
> >
> > > Hi Sateesh, Koushik,
> > >
> > > I am setting up Vmware Cluster with CS (master) and seeing errors.
> > > ilya was helping me for this setup and figured out this error.
> > >
> > > The System VMs(Secondary Stogare VM and Console Proxy VM) are not
> > > coming up properly. The system vms are reconfiguring and destroying
> > > again and again in cycle.
> > >
> > > I have used Vmware Vsphere 5.1 SDK for building CS.
> > >
> > > The error logs give this error:
> > >
> > > 2014-09-16 16:11:01,619 WARN  [c.c.h.v.r.VmwareResource]
> > > (DirectAgent-8:ctx-8909215e 10.24.41.149, job-54/job-68, cmd:
> > > StartCommand) StartCommand failed due to Exception:
> > > java.lang.NullPointerException
> > > Message: null
> > >
> > > java.lang.NullPointerException
> > >         at
> > >
> >
> com.cloud.hypervisor.vmware.resource.VmwareResource.postDiskConfigBeforeStart(VmwareResource.java:2094)
> > >         at
> > >
> >
> com.cloud.hypervisor.vmware.resource.VmwareResource.execute(VmwareResource.java:1685)
> > >         at
> > >
> >
> com.cloud.hypervisor.vmware.resource.VmwareResource.executeRequest(VmwareResource.java:448)
> > >         at
> > >
> >
> com.cloud.agent.manager.DirectAgentAttache$Task.runInContext(DirectAgentAttache.java:294)
> > >         at
> > >
> >
> org.apache.cloudstack.managed.context.ManagedContextRunnable$1.run(ManagedContextRunnable.java:49)
> > >         at
> > >
> >
> org.apache.cloudstack.managed.context.impl.DefaultManagedContext$1.call(DefaultManagedContext.java:56)
> > >         at
> > >
> >
> org.apache.cloudstack.managed.context.impl.DefaultManagedContext.callWithContext(DefaultManagedContext.java:103)
> > >         at
> > >
> >
> org.apache.cloudstack.managed.context.impl.DefaultManagedContext.runWithContext(DefaultManagedContext.java:53)
> > >         at
> > >
> >
> org.apache.cloudstack.managed.context.ManagedContextRunnable.run(ManagedContextRunnable.java:46)
> > >         at
> > > java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
> > >         at java.util.concurrent.FutureTask.run(FutureTask.java:262)
> > >         at
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:178)
> > >         at
> > >
> >
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:292)
> > >         at
> > >
> >
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
> > >         at
> > >
> >
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> > >         at java.lang.Thread.run(Thread.java:744)
> > >
> > > Please help to resolve this issue.
> > >
> > > Thanks & Regards,
> > > Ritu S.
> > >
> > >
> >
> >
> > --
> > *Mike Tutkowski*
> > *Senior CloudStack Developer, SolidFire Inc.*
> > e: mike.tutkowski@solidfire.com
> > o: 303.746.7302
> > Advancing the way the world uses the cloud
> > <http://solidfire.com/solution/overview/?video=play>*™*
> >
>



-- 
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the cloud
<http://solidfire.com/solution/overview/?video=play>*™*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message