cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastien Goasguen <run...@gmail.com>
Subject Re: simulator run
Date Thu, 04 Sep 2014 12:52:26 GMT

On Sep 4, 2014, at 8:42 AM, Koushik Das <koushik.das@citrix.com> wrote:

> For master/4.4 the command/filter specified by Hugo should work. For 4.3 check for tests
tagged with "simulator".
> 

so in 4.3, even if I deploy an advanced zone, I should run the tests that have tags=simulator
, and not tags=advanced ?

> -----Original Message-----
> From: Ian Duffy [mailto:ian@ianduffy.ie] 
> Sent: Thursday, 4 September 2014 5:50 PM
> To: CloudStack Dev
> Subject: Re: simulator run
> 
> Koushik,
> 
> Any chance of getting a list of tests that are valid for execution against the simulator
for 4.3, 4.4 and master?
> 
> Thanks,
> Ian
> 
> 
> On 4 September 2014 13:03, Koushik Das <koushik.das@citrix.com> wrote:
> 
>> Ok, in that case the tests under /misc won't get executed. Looks like 
>> there are some other issues with the failing tests
>> 
>>> grep required_hardware= test/integration/smoke/misc/*.py
>> test/integration/smoke/misc/test_deploy_vm.py:    @attr(tags =
>> ['advanced'], required_hardware="simulator only")
>> test/integration/smoke/misc/test_deploy_vm.py:    @attr(tags =
>> ['advanced'], required_hardware="simulator only")
>> test/integration/smoke/misc/test_vm_ha.py:    @attr(tags = ['advanced'],
>> required_hardware="simulator only")
>> test/integration/smoke/misc/test_vm_sync.py:    @attr(tags = ['advanced'],
>> required_hardware="simulator only")
>> 
>> -----Original Message-----
>> From: Trippie [mailto:trippie@gmail.com] On Behalf Of Hugo Trippaers
>> Sent: Thursday, 4 September 2014 5:23 PM
>> To: dev@cloudstack.apache.org
>> Subject: Re: simulator run
>> 
>> Hey,
>> 
>> This is what i'm executing to run the tests:
>> 
>> /usr/local/bin/nosetests-2.7 -v --with-marvin 
>> --marvin-config=setup/dev/advanced.cfg --with-xunit 
>> --xunit-file=xunit.xml -a tags=advanced,required_hardware=false 
>> --zone=Sandbox-simulator --hypervisor=simulator -w 
>> test/integration/smoke
>> 
>> 
>> 
>> Cheers,
>> 
>> Hugo
>> 
>> On 4 sep. 2014, at 13:32, Koushik Das <koushik.das@citrix.com> wrote:
>> 
>>> Are the tests present under test/integration/smoke/misc also getting
>> executed? If so please exclude them for now.
>>> The tests under /misc folder is based on the new simulator changes 
>>> to
>> test failures from agent layer. These tests can cause interference in 
>> other tests.
>>> 
>>> There are 2 options to make them work together:
>>> - Run tests under /misc folder separately and in sequence
>>> - All existing smoke tests needs to be modified to run against some
>> targeted host(s). So that there is no interference from agent layer 
>> simulated failures (these tests can target some specific hosts that 
>> are not used by any other tests).
>>> 
>>> -----Original Message-----
>>> From: Trippie [mailto:trippie@gmail.com] On Behalf Of Hugo Trippaers
>>> Sent: Thursday, 4 September 2014 1:09 PM
>>> To: <dev@cloudstack.apache.org>
>>> Subject: simulator run
>>> 
>>> Heya,
>>> 
>>> The simulator run reports three errors at the moment:
>>> 
>>> integration.smoke.test_vm_life_cycle.TestVMLifeCycle.test_09_expunge
>>> _v m integration.smoke.test_network.TestReleaseIP.test_releaseIP
>>> integration.smoke.test_network.TestDeleteAccount.test_delete_account
>>> 
>>> Can somebody with a bit of background on these tests do the
>> investigation? I'm happy to help with fixing the issue, but i can't 
>> really figure it out atm.
>>> 
>>> 
>>> Cheers,
>>> 
>>> Hugo
>>> 
>>> 
>>> 
>>> 
>> 
>> 


Mime
View raw message