cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastien Goasguen <run...@gmail.com>
Subject Re: cloud-init issue
Date Tue, 26 Aug 2014 09:06:41 GMT
I applied a new patch from Erik that fixes all URL, as reported by Carlos.

@Nux could you grab 4.3 source and test it with your templates…making sure it works with
cloud-init ?

thanks,

On Aug 25, 2014, at 6:07 PM, Carlos Reátegui <creategui@gmail.com> wrote:

> 
> On Aug 25, 2014, at 12:32 PM, Erik Weber <terbolous@gmail.com> wrote:
> 
>> On Mon, Aug 25, 2014 at 6:02 PM, Carlos Reátegui <creategui@gmail.com>
>> wrote:
>> 
>>> Not sure about this ‘fix’.  If the goal is to match AWS here is the way it
>>> works compared to 4.3.
>>> 
>>> 
>> The actual fix was just for the reported url, ie. meta-data
>> 
>> 
>>> 1) /latest/user-data
>>> 
>>> On AWS one can query /latest/user-data with or without the trailing slash
>>> and BOTH return the user-data
>>> 
>>> On ACS 4.3 /latest/user-data works but with trailing / returns a 404.
>>> 
>>> 2) /latest/meta-data
>>> 
>>> On AWS /latest/meta-data returns a 301 pointing to trailing / version.
>>> With a trailing slash it return the meta-data objects available.
>>> 
>>> 
>> Is it required to respons with 301, or is 200 with the actual content ok?
> I would think 200 with actual content is ok.
> 
>> 
>> 
>>> On ACS 4.3 /latest/meta-data returns 404. With a trailing slash it returns
>>> the meta-data objects available.
>>> 
>>> 3) /latest/meta-data/<object>
>>> 
>>> On AWS with and without / returns the object value(s)
>>> 
>>> On ACS 4.3 without a / it returns the value.  With the / it returns a 404.
>>> 
>> 
>> 
>> I'll work on an improved patch that fixes all the URLs.
>> 
>> Erik
> 


Mime
View raw message