cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Burke <n...@nickburke.com>
Subject traffic shaping not working correctly or not respecting configuration?
Date Wed, 20 Aug 2014 22:31:29 GMT
Hello Cloudstack Devs,

It was suggested by a few people that I move this discussion from users@ to
dev@ regarding an issue I'm having with traffic shaping/network throttling.

First, the details:
Hypervisor is Ubuntu 12.04.3 LTS  KVM across the board
CS4.3.0 (upgraded from 4.0)
Advanced networking


The issue is that even after setting network.throttling.rate and
vm.network.throttling.rate to 20000 (and either restarting OR creating a
new network) the traffic shaping still shapes to a really low and sporadic
amount. This happens with the default service offering AND in a network
offering that ties directly to a VLAN that is set to allow transfer of
100Mbs (or 1000Mbs).  Throughput is usually within the 1.5Mb/s to 3 Mb/s.
If I take off the traffic shapping rules (via tc qdisc del dev INTERFACE
root; tc qdisc del dev INTERFACE ingress) I get over 13Gb/s from instances
within the same host and ~800Mb/s from instances on separate hosts. Of
course, if the instance is shutdown/moved/etc the tc rules get put back and
I'm back to square one.


Here is a pastebin with some details including the tc display and some
details on the network from cloudmonkey:

http://pastebin.com/30Fxj3PW

Please note that this pastebin is prior to upping network.throttling.rate
and vm.network.throttling.rate to 20000, however, after upping those two
(and restarting CSmanagement) there is no difference.


I'm available on IRC in the CS channel if someone wants to engage me there.

-- 
Nick





*'What is a human being, then?' 'A seed' 'A... seed?' 'An acorn that is
unafraid to destroy itself in growing into a tree.' -David Zindell, A
Requiem for Homo Sapiens*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message