cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Indra Pramana <in...@sg.or.id>
Subject Password reset doesn't work, fail to acquire the lock passwdlock
Date Sat, 16 Aug 2014 01:50:43 GMT
Dear all,

Good day to all of you.

I am using CloudStack 4.2.0 and KVM hypervisor.

Suddenly our password reset function doesn't work anymore. I logged in into
the virtual router and found these messages on /var/log/messages:

Aug 16 01:43:04 r-2606-VM cloud: Process /opt/cloud/bin/serve_password.sh
pid 3455 waiting for the lock passwdlock for another 1 second
Aug 16 01:43:05 r-2606-VM cloud: Process /opt/cloud/bin/serve_password.sh
pid 3455 waiting for the lock passwdlock for another 1 second
Aug 16 01:43:06 r-2606-VM cloud: Process /opt/cloud/bin/serve_password.sh
pid 3455 waiting for the lock passwdlock for another 1 second
Aug 16 01:43:07 r-2606-VM cloud: Process /opt/cloud/bin/serve_password.sh
pid 3455 waiting for the lock passwdlock for another 1 second
Aug 16 01:43:08 r-2606-VM cloud: Process /opt/cloud/bin/serve_password.sh
pid 3455 waiting for the lock passwdlock for another 1 second
Aug 16 01:43:09 r-2606-VM cloud: Process /opt/cloud/bin/serve_password.sh
pid 3455 waiting for the lock passwdlock for another 1 second
Aug 16 01:43:11 r-2606-VM cloud: Process /opt/cloud/bin/serve_password.sh
pid 3455 waiting for the lock passwdlock for another 1 second
Aug 16 01:43:11 r-2606-VM cloud: fail to acquire the lock passwdlock for
process /opt/cloud/bin/serve_password.sh pid 3455 after 30 seconds time out!
Aug 16 01:43:11 r-2606-VM cloud: waiting for process: USER PID %CPU %MEM
VSZ RSS TTY STAT START TIME COMMAND root 15310 0.0 0.8 4620 1088 ? S 19:53
0:00 /bin/bash /opt/cloud/bin/serve_password.sh X.X.X.X
Aug 16 01:43:11 r-2606-VM cloud: Failed job detail: USER       PID %CPU
%MEM    VSZ   RSS TTY      STAT START   TIME COMMAND#012root      3455
0.0  0.8   4620  1084 ?        S    01:42   0:00 /bin/bash
/opt/cloud/bin/serve_password.sh X.X.X.Y

It seems that there's some locking issues causing the password reset
process to fail. I believe these are the related scripts on the VR related
to the issue:

/opt/cloud/bin/serve_password.sh
/root/func.sh

Anyone can help on how to reset the lock file and resolve the problem?

Looking forward to your reply, thank you.

Cheers.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message