cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Devdeep Singh <devdeep.si...@citrix.com>
Subject RE: Building of Hyper-V Agent seems broken in 4.4 branch
Date Fri, 01 Aug 2014 10:40:23 GMT
Applied the patch to 4.4 branch and pushed. Thanks Anshul.

Regards,
Devdeep

> -----Original Message-----
> From: Daan Hoogland [mailto:daan.hoogland@gmail.com]
> Sent: Friday, August 1, 2014 2:13 PM
> To: dev
> Subject: Re: Building of Hyper-V Agent seems broken in 4.4 branch
> 
> Anshul, go ahead.
> 
> On Fri, Aug 1, 2014 at 7:24 AM, Anshul Gangwar <anshul.gangwar@citrix.com>
> wrote:
> > I have created the patch https://reviews.apache.org/r/24174/ to fix the
> issue.
> > Is it ok to go ahead and commit it into 4.4 branch?
> >
> > Regards,
> > Anshul
> >
> > -----Original Message-----
> > From: Anshul Gangwar [mailto:anshul.gangwar@citrix.com]
> > Sent: Friday, August 01, 2014 10:22 AM
> > To: dev@cloudstack.apache.org
> > Subject: RE: Building of Hyper-V Agent seems broken in 4.4 branch
> >
> > The commits are not applied in correct order.
> >
> > This commit 8fb89cdc8e2dff60d49fecd3e51a9bf997061035 is applied after
> ef0cec938165fdf3531f92dc8f4c2930ff95fa5e. The later commit has resolve
> conflicts in cherry-picking. It was not resolved correctly which introduces this
> build failure.
> >
> > Regards,
> > Anshul
> >
> > -----Original Message-----
> > From: Devdeep Singh [mailto:devdeep.singh@citrix.com]
> > Sent: Friday, August 01, 2014 10:01 AM
> > To: dev@cloudstack.apache.org
> > Subject: RE: Building of Hyper-V Agent seems broken in 4.4 branch
> >
> > Taking a look at it. Maybe a cherry-pick from 4.4-forward to 4.4 was missed.
> >
> > Regards,
> > Devdeep
> >
> >> -----Original Message-----
> >> From: Erik Weber [mailto:terbolous@gmail.com]
> >> Sent: Thursday, July 31, 2014 9:18 PM
> >> To: dev
> >> Subject: Building of Hyper-V Agent seems broken in 4.4 branch
> >>
> >> 4.4.0 tag is working correctly, as is master branch.
> >>
> >> Any fix or advice appreciated.
> >>
> >>
> >> Erik
> >>
> >> ---------- compile output ------------
> >>
> >>                      Target CoreCompile:
> >>                                 Tool
> >> C:\PROGRA~2\MONO-3~1.3\bin\mcs.bat
> >> execution started with arguments: /noconfig /debug:full /debug+
> >> /optimize- /out:obj\Debug\HypervResource.dll CloudStackTypes.cs
> >> IWmiCallsV2.cs WmiCallsV2.cs Properties\AssemblyInfo.cs
> >> HypervResourceController.cs Utils.cs /target:library
> /define:"DEBUG;TRACE"
> >> /reference:..\packages\AWSSDK.1.5.23.0\lib\AWSSDK.dll
> >> /reference:..\packages\DotNetZip.1.9.1.8\lib\net20\Ionic.Zip.dll
> >> /reference:..\packages\log4net.2.0.0\lib\net40-full\log4net.dll
> >>
> /reference:..\packages\Newtonsoft.Json.4.5.11\lib\net40\Newtonsoft.Json.
> >> dll
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.dll
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Confi
> >> g
> >> ura
> >> tion.dll
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Manag
> >> e
> >> m
> >> ent.dll
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >>
> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Net.Http.
> >> dll
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Web.d
> >> l
> >> l
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Web.H
> >> t
> >> tp
> >> .dll
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >>
> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Xml.Linq.
> >> dll
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Data.
> >> D
> >> ata
> >> SetExtensions.dll
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >>
> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\Microsoft.CSharp.
> >> dll
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Data.
> >> d
> >> ll
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Xml.d
> >> l
> >> l
> >> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-
> >> frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Core.
> >> d
> >> ll
> >>
> /reference:C:\source\cloudstack\plugins\hypervisors\hyperv\DotNet\Ser
> >> v e rResource\WmiWrappers\bin\Debug\\WmiWrappers.dll
> >> /warn:4
> >> WmiCallsV2.cs(336,27): error CS0117: `HypervResource.Utils' does not
> >> contain a definition for `ConnectToRemote'
> >>                                 Utils.cs(32,18): (Location of the
> >> symbol related to previous
> >> error)
> >> WmiCallsV2.cs(2448,69): error CS0103: The name `jobObj' does not
> >> exist in the current context
> >> HypervResourceController.cs(239,31): error CS0117:
> `HypervResource.Utils'
> >> does not contain a definition for `ConnectToRemote'
> >>                                 Utils.cs(32,18): (Location of the
> >> symbol related to previous
> >> error)
> >> HypervResourceController.cs(250,35): error CS0117:
> `HypervResource.Utils'
> >> does not contain a definition for `ConnectToRemote'
> >>                                 Utils.cs(32,18): (Location of the
> >> symbol related to previous
> >> error)
> >> HypervResourceController.cs(992,27): error CS0117:
> `HypervResource.Utils'
> >> does not contain a definition for `ConnectToRemote'
> >>                                 Utils.cs(32,18): (Location of the
> >> symbol related to previous
> >> error)
> >> HypervResourceController.cs(1284,31): error CS0117:
> `HypervResource.Utils'
> >> does not contain a definition for `ConnectToRemote'
> >>                                 Utils.cs(32,18): (Location of the
> >> symbol related to previous
> >> error)
> >> HypervResourceController.cs(1560,39): error CS0117:
> `HypervResource.Utils'
> >> does not contain a definition for `ConnectToRemote'
> >>                                 Utils.cs(32,18): (Location of the
> >> symbol related to previous
> >> error)
> >> HypervResourceController.cs(1567,35): error CS0117:
> `HypervResource.Utils'
> >> does not contain a definition for `ConnectToRemote'
> >>                                 Utils.cs(32,18): (Location of the
> >> symbol related to previous
> >> error)
> >>                         Task "Csc" execution -- FAILED
> >>                         Done building target "CoreCompile" in project
> >>
> "C:\source\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResourc
> >> e
> >> \
> >> HypervResource\HypervResource.csproj".--
> >> FAILED
> >>                 Done building project
> >>
> "C:\source\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResourc
> >> e
> >> \
> >> HypervResource\HypervResource.csproj".--
> >> FAILED
> >>         Task "MSBuild" execution -- FAILED
> >>         Done building target "Build" in project
> >>
> "C:\source\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResourc
> >> e
> >> \
> >> ServerResource.sln".--
> >> FAILED
> >> Done building project
> >>
> "C:\source\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResourc
> >> e
> >> \
> >> ServerResource.sln".--
> >> FAILED
> >>
> >> Build FAILED.
> >> Errors:
> >>
> >>
> C:\source\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource
> >> \
> >> ServerResource.sln
> >> (default targets) ->
> >> (Build target) ->
> >>
> C:\source\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource
> >> \
> >> HypervResource\HypervResource.csproj
> >> (default targets) ->
> >> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.CSharp.targets
> >> (CoreCompile
> >> target) ->
> >>
> >>         WmiCallsV2.cs(336,27): error CS0117: `HypervResource.Utils'
> >> does not contain a definition for `ConnectToRemote'
> >>         WmiCallsV2.cs(2448,69): error CS0103: The name `jobObj' does
> >> not exist in the current context
> >>         HypervResourceController.cs(239,31): error CS0117:
> >> `HypervResource.Utils' does not contain a definition for
> `ConnectToRemote'
> >>         HypervResourceController.cs(250,35): error CS0117:
> >> `HypervResource.Utils' does not contain a definition for
> `ConnectToRemote'
> >>         HypervResourceController.cs(992,27): error CS0117:
> >> `HypervResource.Utils' does not contain a definition for
> `ConnectToRemote'
> >>         HypervResourceController.cs(1284,31): error CS0117:
> >> `HypervResource.Utils' does not contain a definition for
> `ConnectToRemote'
> >>         HypervResourceController.cs(1560,39): error CS0117:
> >> `HypervResource.Utils' does not contain a definition for
> `ConnectToRemote'
> >>         HypervResourceController.cs(1567,35): error CS0117:
> >> `HypervResource.Utils' does not contain a definition for
> `ConnectToRemote'
> >>
> >>          0 Warning(s)
> >>          8 Error(s)
> >>
> >> Time Elapsed 00:00:07.6640000
> 
> 
> 
> --
> Daan
Mime
View raw message