cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@shapeblue.com>
Subject 4.4.1 tests
Date Wed, 13 Aug 2014 18:29:20 GMT
Hi,

I’m tested CloudStack 4.4 branch for the upcoming 4.4.1 target release, using KVM on Ubuntu
(amd64). I’m sharing my observations before creating bugs for every issue that should be
fixed.

Observations:

# Installation
- cloudstack-cli does nothing (why do we have it here or should we add a post install script
that installs cloudmonkey from pypi?)
- Document workaround for https://issues.apache.org/jira/browse/CLOUDSTACK-4770 (Daan , please
cherry-pick the fix from master to 4.4 if needed)
- After doing the workaround of above, I had to redeploy db
Rest of the install and db setup was smooth

# Storage and setup
- Worked fine
- Used 4.4 systemvm template for KVM build #94 from jenkins.buildacloud.org

# Launch
- CloudStack mgmt server launched fine but saw some SQL warnings not sure how critical they
are or if we should ignore them: http://pastebin.com/2CVE3YE8
- Warning related to KVM template not found: 2014-08-13 18:53:46,544 WARN  [c.c.u.d.Upgrade440to441]
(main:null) 4.4.0 KVM SystemVm template not found. KVM hypervisor is not used, so not failing
upgrade

# Tests
- Things from this (except for KVM): https://cwiki.apache.org/confluence/display/CLOUDSTACK/Release+test+procedure
- HA and VMSync for systemvms
- Account, user operations worked for me
- VM lifecycle worked except snapshots

## Using basic zone + SG
- Console proxy worked but was not able to reach internet
- SSVMS worked:, was able to reach internet and common operations worked -- registration of
ISO and template
- Router VM was too not able to reach, users instances were too not able to reach internet
but only route vm (it may be something silly I’m doing since it’s a very common issue)
- Blocker for Basic zone using SG (the above issue): https://issues.apache.org/jira/browse/CLOUDSTACK-7340
(the above issue)
- Deployed basic zone again with fresh setup to test the above with SG

## Using basic zone + default networking (no SG, just VR)
- CPVM, SSVM, RVM all worked fine, were able to reach internet and do their operations
- Registration of template and isos worked
- Launching a user instances using template & iso worked, user instances were able to
reach internet
- VM snapshot failed for both stopped and running vm saying — not enable for hypervisor
type KVM. Did this used to work?

Will try advance zone/network tomorrow.

Cheers,
Rohit Yadav
Software Architect, ShapeBlue
M. +41 779015219 | rohit.yadav@shapeblue.com
Blog: bhaisaab.org | Twitter: @_bhaisaab



Find out more about ShapeBlue and our range of CloudStack related services

IaaS Cloud Design & Build<http://shapeblue.com/iaas-cloud-design-and-build//>
CSForge – rapid IaaS deployment framework<http://shapeblue.com/csforge/>
CloudStack Consulting<http://shapeblue.com/cloudstack-consultancy/>
CloudStack Infrastructure Support<http://shapeblue.com/cloudstack-infrastructure-support/>
CloudStack Bootcamp Training Courses<http://shapeblue.com/cloudstack-training/>

This email and any attachments to it may be confidential and are intended solely for the use
of the individual to whom it is addressed. Any views or opinions expressed are solely those
of the author and do not necessarily represent those of Shape Blue Ltd or related companies.
If you are not the intended recipient of this email, you must neither take any action based
upon its contents, nor copy or show it to anyone. Please contact the sender if you believe
you have received this email in error. Shape Blue Ltd is a company incorporated in England
& Wales. ShapeBlue Services India LLP is a company incorporated in India and is operated
under license from Shape Blue Ltd. Shape Blue Brasil Consultoria Ltda is a company incorporated
in Brasil and is operated under license from Shape Blue Ltd. ShapeBlue SA Pty Ltd is a company
registered by The Republic of South Africa and is traded under license from Shape Blue Ltd.
ShapeBlue is a registered trademark.

Mime
View raw message