cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajani Karuturi <Rajani.Karut...@citrix.com>
Subject Re: Trouble with building cloudstack
Date Fri, 06 Jun 2014 05:19:13 GMT
you have to install java-1.7.0-openjdk-devel package to get javac
http://openjdk.java.net/install/

once thats installed, if you do sudo update-alternatives --config javac , it should list both
1.6 and 1.7 and should allow you to select 1.7 as default.



~Rajani



On 05-Jun-2014, at 11:40 pm, Elapavuluri, Jaya <Jaya.Elapavuluri@netapp.com<mailto:Jaya.Elapavuluri@netapp.com>>
wrote:

Hello,

I am currently working on cloudstack and have got few troubles while setting up the development
environment.

I followed the steps given in : https://cwiki.apache.org/confluence/display/CLOUDSTACK/Setting+up+CloudStack+Development+Environment+on+Linux

However, the following are the problems encountered while trying to build it.

Error1- It says failed to execute goal org.apache.maven.plugins:mavn-compiler-plugin-2.5.1:compile....
Error1-Failed to execute javac but could not parse the error.
Error1-javac:invalid target release:1.7

I tried to figure out the problem but in vain. It would be great if you can help me out with
this issue.

Thank you,
Smruthi Elapavuluri


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message